Upstream information

CVE-2014-2708 at MITRE

Description

Multiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier allow remote attackers to execute arbitrary SQL commands via the (1) graph_start, (2) graph_end, (3) graph_height, (4) graph_width, (5) graph_nolegend, (6) print_source, (7) local_graph_id, or (8) rra_id parameter.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 872008 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • cacti >= 0.8.8b-5.8.1
  • cacti-spine >= 0.8.8b-4.4.1
  • cacti-spine-debuginfo >= 0.8.8b-4.4.1
  • cacti-spine-debugsource >= 0.8.8b-4.4.1
Patchnames:
openSUSE-2014-331
openSUSE 13.1
  • cacti >= 0.8.8b-4.1
  • cacti-spine >= 0.8.8b-4.4.1
  • cacti-spine-debuginfo >= 0.8.8b-4.4.1
  • cacti-spine-debugsource >= 0.8.8b-4.4.1
Patchnames:
openSUSE-2014-331
openSUSE Tumbleweed
  • cacti >= 0.8.8h-1.2
  • cacti-doc >= 0.8.8h-1.2
Patchnames:
openSUSE Tumbleweed GA cacti