Upstream information

CVE-2014-2015 at MITRE

Description

Stack-based buffer overflow in the normify function in the rlm_pap module (modules/rlm_pap/rlm_pap.c) in FreeRADIUS 2.x, possibly 2.2.3 and earlier, and 3.x, possibly 3.0.1 and earlier, might allow attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password hash, as demonstrated by an SSHA hash.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 864576 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Server Applications 15
  • freeradius-server >= 3.0.16-1.41
  • freeradius-server-devel >= 3.0.16-1.41
  • freeradius-server-krb5 >= 3.0.16-1.41
  • freeradius-server-ldap >= 3.0.16-1.41
  • freeradius-server-libs >= 3.0.16-1.41
  • freeradius-server-mysql >= 3.0.16-1.41
  • freeradius-server-perl >= 3.0.16-1.41
  • freeradius-server-postgresql >= 3.0.16-1.41
  • freeradius-server-python >= 3.0.16-1.41
  • freeradius-server-sqlite >= 3.0.16-1.41
  • freeradius-server-utils >= 3.0.16-1.41
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA freeradius-server
SUSE Linux Enterprise Server 11 SP3
  • freeradius-server >= 2.1.1-7.18.1
  • freeradius-server-dialupadmin >= 2.1.1-7.18.1
  • freeradius-server-doc >= 2.1.1-7.18.1
  • freeradius-server-libs >= 2.1.1-7.18.1
  • freeradius-server-utils >= 2.1.1-7.18.1
Patchnames:
slessp3-freeradius-server
SUSE Linux Enterprise Server 11 SP4
  • freeradius-server >= 2.1.1-7.18.1
  • freeradius-server-dialupadmin >= 2.1.1-7.18.1
  • freeradius-server-doc >= 2.1.1-7.18.1
  • freeradius-server-libs >= 2.1.1-7.18.1
  • freeradius-server-utils >= 2.1.1-7.18.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA freeradius-server
SUSE Linux Enterprise Server 12
  • freeradius-server >= 3.0.3-3.3
  • freeradius-server-doc >= 3.0.3-3.3
  • freeradius-server-libs >= 3.0.3-3.3
  • freeradius-server-utils >= 3.0.3-3.3
Patchnames:
SUSE Linux Enterprise Server 12 GA freeradius-server
SUSE Linux Enterprise Server 12 SP1
  • freeradius-server >= 3.0.3-10.1
  • freeradius-server-doc >= 3.0.3-10.1
  • freeradius-server-krb5 >= 3.0.3-10.1
  • freeradius-server-ldap >= 3.0.3-10.1
  • freeradius-server-libs >= 3.0.3-10.1
  • freeradius-server-mysql >= 3.0.3-10.1
  • freeradius-server-perl >= 3.0.3-10.1
  • freeradius-server-postgresql >= 3.0.3-10.1
  • freeradius-server-python >= 3.0.3-10.1
  • freeradius-server-sqlite >= 3.0.3-10.1
  • freeradius-server-utils >= 3.0.3-10.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA freeradius-server
SUSE Linux Enterprise Server 12 SP2
  • freeradius-server >= 3.0.3-10.1
  • freeradius-server-doc >= 3.0.3-10.1
  • freeradius-server-krb5 >= 3.0.3-10.1
  • freeradius-server-ldap >= 3.0.3-10.1
  • freeradius-server-libs >= 3.0.3-10.1
  • freeradius-server-mysql >= 3.0.3-10.1
  • freeradius-server-perl >= 3.0.3-10.1
  • freeradius-server-postgresql >= 3.0.3-10.1
  • freeradius-server-python >= 3.0.3-10.1
  • freeradius-server-sqlite >= 3.0.3-10.1
  • freeradius-server-utils >= 3.0.3-10.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA freeradius-server
SUSE Linux Enterprise Server 12 SP3
  • freeradius-server >= 3.0.14-1.8
  • freeradius-server-doc >= 3.0.14-1.8
  • freeradius-server-krb5 >= 3.0.14-1.8
  • freeradius-server-ldap >= 3.0.14-1.8
  • freeradius-server-libs >= 3.0.14-1.8
  • freeradius-server-mysql >= 3.0.14-1.8
  • freeradius-server-perl >= 3.0.14-1.8
  • freeradius-server-postgresql >= 3.0.14-1.8
  • freeradius-server-python >= 3.0.14-1.8
  • freeradius-server-sqlite >= 3.0.14-1.8
  • freeradius-server-utils >= 3.0.14-1.8
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA freeradius-server
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • freeradius-server >= 3.0.3-10.1
  • freeradius-server-doc >= 3.0.3-10.1
  • freeradius-server-krb5 >= 3.0.3-10.1
  • freeradius-server-ldap >= 3.0.3-10.1
  • freeradius-server-libs >= 3.0.3-10.1
  • freeradius-server-mysql >= 3.0.3-10.1
  • freeradius-server-perl >= 3.0.3-10.1
  • freeradius-server-postgresql >= 3.0.3-10.1
  • freeradius-server-python >= 3.0.3-10.1
  • freeradius-server-sqlite >= 3.0.3-10.1
  • freeradius-server-utils >= 3.0.3-10.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA freeradius-server
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • freeradius-server >= 2.1.1-7.18.1
  • freeradius-server-dialupadmin >= 2.1.1-7.18.1
  • freeradius-server-doc >= 2.1.1-7.18.1
  • freeradius-server-libs >= 2.1.1-7.18.1
  • freeradius-server-utils >= 2.1.1-7.18.1
Patchnames:
slessp3-freeradius-server
SUSE Linux Enterprise Server for VMWare 11 SP3
  • freeradius-server >= 2.1.1-7.18.1
  • freeradius-server-dialupadmin >= 2.1.1-7.18.1
  • freeradius-server-doc >= 2.1.1-7.18.1
  • freeradius-server-libs >= 2.1.1-7.18.1
  • freeradius-server-utils >= 2.1.1-7.18.1
Patchnames:
slessp3-freeradius-server
SUSE Linux Enterprise Software Development Kit 11 SP3
  • freeradius-server-devel >= 2.1.1-7.18.1
  • freeradius-server-libs >= 2.1.1-7.18.1
Patchnames:
sdksp3-freeradius-server
SUSE Linux Enterprise Software Development Kit 11 SP4
  • freeradius-server-devel >= 2.1.1-7.18.1
  • freeradius-server-libs >= 2.1.1-7.18.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA freeradius-server-devel
SUSE Linux Enterprise Software Development Kit 12
  • freeradius-server-devel >= 3.0.3-3.10
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA freeradius-server-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • freeradius-server-devel >= 3.0.3-10.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA freeradius-server-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • freeradius-server-devel >= 3.0.3-10.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA freeradius-server-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • freeradius-server-devel >= 3.0.14-1.8
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA freeradius-server-devel
SUSE Linux Enterprise Software Development Kit 11 SP3
  • freeradius-server-devel >= 2.1.1-7.18.1
  • freeradius-server-libs >= 2.1.1-7.18.1
Builds
SAT Patch Nr: 8968
SUSE Linux Enterprise Software Development Kit 11 SP3
  • freeradius-server-devel >= 2.1.1-7.18.1
Builds
SAT Patch Nr: 8968
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • freeradius-server >= 2.1.1-7.18.1
  • freeradius-server-dialupadmin >= 2.1.1-7.18.1
  • freeradius-server-doc >= 2.1.1-7.18.1
  • freeradius-server-libs >= 2.1.1-7.18.1
  • freeradius-server-utils >= 2.1.1-7.18.1
Builds
SAT Patch Nr: 8968
openSUSE 12.3
  • freeradius-server >= 2.2.0-3.8.1
  • freeradius-server-debuginfo >= 2.2.0-3.8.1
  • freeradius-server-debugsource >= 2.2.0-3.8.1
  • freeradius-server-devel >= 2.2.0-3.8.1
  • freeradius-server-dialupadmin >= 2.2.0-3.8.1
  • freeradius-server-doc >= 2.2.0-3.8.1
  • freeradius-server-libs >= 2.2.0-3.8.1
  • freeradius-server-libs-debuginfo >= 2.2.0-3.8.1
  • freeradius-server-utils >= 2.2.0-3.8.1
  • freeradius-server-utils-debuginfo >= 2.2.0-3.8.1
Patchnames:
openSUSE-2014-191
openSUSE 13.1
  • freeradius-server >= 2.2.0-7.4.1
  • freeradius-server-debuginfo >= 2.2.0-7.4.1
  • freeradius-server-debugsource >= 2.2.0-7.4.1
  • freeradius-server-devel >= 2.2.0-7.4.1
  • freeradius-server-dialupadmin >= 2.2.0-7.4.1
  • freeradius-server-doc >= 2.2.0-7.4.1
  • freeradius-server-libs >= 2.2.0-7.4.1
  • freeradius-server-libs-debuginfo >= 2.2.0-7.4.1
  • freeradius-server-utils >= 2.2.0-7.4.1
  • freeradius-server-utils-debuginfo >= 2.2.0-7.4.1
Patchnames:
openSUSE-2014-191
openSUSE Tumbleweed
  • freeradius-server >= 3.0.12-1.1
  • freeradius-server-devel >= 3.0.12-1.1
  • freeradius-server-doc >= 3.0.12-1.1
  • freeradius-server-krb5 >= 3.0.12-1.1
  • freeradius-server-ldap >= 3.0.12-1.1
  • freeradius-server-libs >= 3.0.12-1.1
  • freeradius-server-mysql >= 3.0.12-1.1
  • freeradius-server-perl >= 3.0.12-1.1
  • freeradius-server-postgresql >= 3.0.12-1.1
  • freeradius-server-python >= 3.0.12-1.1
  • freeradius-server-sqlite >= 3.0.12-1.1
  • freeradius-server-utils >= 3.0.12-1.1
Patchnames:
openSUSE Tumbleweed GA freeradius-server


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP1 freeradius-server Released
SUSE Linux Enterprise SDK 11 SP2 freeradius-server Released
SUSE Linux Enterprise SDK 11 SP3 freeradius-server Released
SUSE Linux Enterprise SDK 11 SP4 freeradius-server Released
SUSE Linux Enterprise Server 11 SP1 freeradius-server Released
SUSE Linux Enterprise Server 11 SP1 LTSS freeradius-server Released
SUSE Linux Enterprise Server 11 SP2 freeradius-server Released
SUSE Linux Enterprise Server 11 SP2 LTSS freeradius-server Released
SUSE Linux Enterprise Server 11 SP3 freeradius-server Released
SUSE Linux Enterprise Server 11 SP3 LTSS freeradius-server Released
SUSE Linux Enterprise Server 11 SP4 freeradius-server Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 freeradius-server Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 freeradius-server Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 freeradius-server Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 freeradius-server Released
SUSE Linux Enterprise Server for VMWare 11 SP2 freeradius-server Released
SUSE Linux Enterprise Server for VMWare 11 SP3 freeradius-server Released