Upstream information

CVE-2014-1829 at MITRE

Description

Requests (aka python-requests) before 2.3.0 allows remote servers to obtain a netrc password by reading the Authorization header in a redirected request.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 897658 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Cloud Compute Node for SUSE Linux Enterprise 12 5
  • python-requests >= 2.3.0-1.6
Patchnames:
SUSE Cloud Compute Node for SUSE Linux Enterprise 12 5 GA python-requests
SUSE Linux Enterprise Desktop 12 SP1
  • python-requests >= 2.3.0-6.5.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA python-requests
SUSE Linux Enterprise Desktop 12 SP2
  • python-requests >= 2.8.1-6.11.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA python-requests
SUSE Linux Enterprise Desktop 12 SP3
  • python-requests >= 2.8.1-6.16.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA python-requests
SUSE Linux Enterprise High Availability 12 SP2
  • python-requests >= 2.8.1-6.11.1
Patchnames:
SUSE Linux Enterprise High Availability 12 SP2 GA python-requests
SUSE Linux Enterprise High Availability 12 SP3
  • python-requests >= 2.8.1-6.16.1
Patchnames:
SUSE Linux Enterprise High Availability 12 SP3 GA python-requests
SUSE Linux Enterprise Module for Basesystem 15
  • python2-requests >= 2.18.4-1.35
  • python3-requests >= 2.18.4-1.35
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA python2-requests
SUSE Linux Enterprise Module for Public Cloud 12
  • python-requests >= 2.3.0-1.6
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 12 GA python-requests
SUSE Linux Enterprise Server 12 SP1
  • python-requests >= 2.3.0-6.5.2
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA python-requests
SUSE Linux Enterprise Server 12 SP2
  • python-requests >= 2.8.1-6.11.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA python-requests
SUSE Linux Enterprise Server 12 SP3
  • python-requests >= 2.8.1-6.16.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA python-requests
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • python-requests >= 2.8.1-6.11.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA python-requests
SUSE OpenStack Cloud 6
  • python-requests >= 2.8.1-6.9.1
Patchnames:
SUSE OpenStack Cloud 6 GA python-requests
openSUSE Leap 15.0
  • python3-requests >= 2.18.4-lp150.1.6
Patchnames:
openSUSE Leap 15.0 GA python3-requests
openSUSE Leap 42.1
  • python3-requests >= 2.7.0-2.3
Patchnames:
openSUSE Leap 42.1 GA python3-requests
openSUSE Leap 42.2
  • python-requests >= 2.11.1-1.1
  • python3-requests >= 2.7.0-3.3
Patchnames:
openSUSE Leap 42.2 GA python-requests
openSUSE Leap 42.2 GA python3-requests
openSUSE Leap 42.3
  • python-requests >= 2.11.1-3.4
  • python3-requests >= 2.7.0-9.1
Patchnames:
openSUSE Leap 42.3 GA python-requests
openSUSE Leap 42.3 GA python3-requests
openSUSE Tumbleweed
  • python-requests >= 2.11.1-1.1
  • python3-requests >= 2.11.1-1.2
Patchnames:
openSUSE Tumbleweed GA python-requests
openSUSE Tumbleweed GA python3-requests


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Cloud 11.3 python-requests Ignore
SUSE Cloud 2.0 python-requests Ignore
SUSE Cloud 4 python-requests Ignore
SUSE Cloud 5 python-requests Not affected
SUSE Linux Enterprise Server 11 SP3 python-requests Ignore