Upstream information

CVE-2014-1551 at MITRE

Description

Use-after-free vulnerability in the FontTableRec destructor in Mozilla Firefox before 31.0, Firefox ESR 24.x before 24.7, and Thunderbird before 24.7 on Windows allows remote attackers to execute arbitrary code via crafted use of fonts in MathML content, leading to improper handling of a DirectWrite font-face object.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 887746 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP3
  • MozillaFirefox-devel >= 24.7.0esr-0.8.2
  • mozilla-nss-devel >= 3.16.2-0.8.1
Builds
SAT Patch Nr: 9569
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • MozillaFirefox >= 24.7.0esr-0.8.2
  • MozillaFirefox-translations >= 24.7.0esr-0.8.2
  • libfreebl3 >= 3.16.2-0.8.1
  • libsoftokn3 >= 3.16.2-0.8.1
  • mozilla-nss >= 3.16.2-0.8.1
  • mozilla-nss-tools >= 3.16.2-0.8.1
Builds
SAT Patch Nr: 9569
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • MozillaFirefox >= 24.7.0esr-0.8.2
  • MozillaFirefox-translations >= 24.7.0esr-0.8.2
  • libfreebl3 >= 3.16.2-0.8.1
  • libfreebl3-32bit >= 3.16.2-0.8.1
  • libsoftokn3 >= 3.16.2-0.8.1
  • libsoftokn3-32bit >= 3.16.2-0.8.1
  • mozilla-nss >= 3.16.2-0.8.1
  • mozilla-nss-32bit >= 3.16.2-0.8.1
  • mozilla-nss-tools >= 3.16.2-0.8.1
Builds
SAT Patch Nr: 9569
SUSE Linux Enterprise Server 11 SP3
  • MozillaFirefox >= 24.7.0esr-0.8.2
  • MozillaFirefox-translations >= 24.7.0esr-0.8.2
  • libfreebl3 >= 3.16.2-0.8.1
  • libfreebl3-x86 >= 3.16.2-0.8.1
  • libsoftokn3 >= 3.16.2-0.8.1
  • libsoftokn3-x86 >= 3.16.2-0.8.1
  • mozilla-nss >= 3.16.2-0.8.1
  • mozilla-nss-tools >= 3.16.2-0.8.1
  • mozilla-nss-x86 >= 3.16.2-0.8.1
Builds
SAT Patch Nr: 9569
SUSE Linux Enterprise Server 11 SP2 LTSS
  • MozillaFirefox >= 24.7.0esr-0.3.1
  • MozillaFirefox-translations >= 24.7.0esr-0.3.1
  • libfreebl3 >= 3.16.2-0.3.1
  • mozilla-nss >= 3.16.2-0.3.1
  • mozilla-nss-devel >= 3.16.2-0.3.1
  • mozilla-nss-tools >= 3.16.2-0.3.1
Builds
SAT Patch Nr: 9555
SUSE Linux Enterprise Server 11 SP2 LTSS
  • MozillaFirefox >= 24.7.0esr-0.3.1
  • MozillaFirefox-translations >= 24.7.0esr-0.3.1
  • libfreebl3 >= 3.16.2-0.3.1
  • libfreebl3-32bit >= 3.16.2-0.3.1
  • mozilla-nss >= 3.16.2-0.3.1
  • mozilla-nss-32bit >= 3.16.2-0.3.1
  • mozilla-nss-devel >= 3.16.2-0.3.1
  • mozilla-nss-tools >= 3.16.2-0.3.1
Builds
SAT Patch Nr: 9555
SUSE Linux Enterprise Server 11 SP1 LTSS
  • MozillaFirefox >= 24.7.0esr-0.3.1
  • MozillaFirefox-translations >= 24.7.0esr-0.3.1
  • libfreebl3 >= 3.16.2-0.3.1
  • mozilla-nss >= 3.16.2-0.3.1
  • mozilla-nss-tools >= 3.16.2-0.3.1
Builds
SAT Patch Nr: 9554
SUSE Linux Enterprise Server 11 SP1 LTSS
  • MozillaFirefox >= 24.7.0esr-0.3.1
  • MozillaFirefox-translations >= 24.7.0esr-0.3.1
  • libfreebl3 >= 3.16.2-0.3.1
  • libfreebl3-32bit >= 3.16.2-0.3.1
  • mozilla-nss >= 3.16.2-0.3.1
  • mozilla-nss-32bit >= 3.16.2-0.3.1
  • mozilla-nss-tools >= 3.16.2-0.3.1
Builds
SAT Patch Nr: 9554
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • MozillaFirefox >= 24.7.0esr-0.5.1
  • MozillaFirefox-translations >= 24.7.0esr-0.5.1
  • mozilla-nss >= 3.16.2-0.5.1
  • mozilla-nss-devel >= 3.16.2-0.5.1
  • mozilla-nss-tools >= 3.16.2-0.5.1
Builds
ZYPP Patch Nr: 8916
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • MozillaFirefox >= 24.7.0esr-0.5.1
  • MozillaFirefox-translations >= 24.7.0esr-0.5.1
  • mozilla-nss >= 3.16.2-0.5.1
  • mozilla-nss-32bit >= 3.16.2-0.5.1
  • mozilla-nss-devel >= 3.16.2-0.5.1
  • mozilla-nss-tools >= 3.16.2-0.5.1
Builds
ZYPP Patch Nr: 8916
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • MozillaFirefox >= 24.7.0esr-0.5.1
  • MozillaFirefox-translations >= 24.7.0esr-0.5.1
  • mozilla-nss >= 3.16.2-0.5.1
  • mozilla-nss-devel >= 3.16.2-0.5.1
  • mozilla-nss-tools >= 3.16.2-0.5.1
Builds
ZYPP Patch Nr: 8917
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
  • MozillaFirefox >= 24.7.0esr-0.5.1
  • MozillaFirefox-translations >= 24.7.0esr-0.5.1
  • mozilla-nss >= 3.16.2-0.5.1
  • mozilla-nss-32bit >= 3.16.2-0.5.1
  • mozilla-nss-devel >= 3.16.2-0.5.1
  • mozilla-nss-tools >= 3.16.2-0.5.1
Builds
ZYPP Patch Nr: 8917