Upstream information

CVE-2014-0593 at MITRE

Description

The set_version script as shipped with obs-service-set_version is a source validator for the Open Build Service (OBS). In versions prior to 0.5.3-1.1 this script did not properly sanitize the input provided by the user, allowing for code execution on the executing server.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 866966 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • obs-service-set_version >= 0.5.3-1.1
Patchnames:
openSUSE Leap 42.1 GA obs-service-set_version
openSUSE Leap 42.2
  • obs-service-set_version >= 0.5.3-4.1
Patchnames:
openSUSE Leap 42.2 GA obs-service-set_version
openSUSE Leap 42.3
  • obs-service-set_version >= 0.5.6-6.1
Patchnames:
openSUSE Leap 42.3 GA obs-service-set_version
openSUSE Tumbleweed
  • obs-service-set_version >= 0.5.3-4.2
Patchnames:
openSUSE Tumbleweed GA obs-service-set_version