Upstream information

CVE-2014-0466 at MITRE

Description

The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 871097 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • a2ps >= 4.13-1326.37.1
Patchnames:
sledsp3-a2ps
SUSE Linux Enterprise Server 11 SP3
  • a2ps >= 4.13-1326.37.1
Patchnames:
slessp3-a2ps
SUSE Linux Enterprise Server 11 SP4
  • a2ps >= 4.13-1326.37.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA a2ps
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • a2ps >= 4.13-1326.37.1
Patchnames:
slessp3-a2ps
SUSE Linux Enterprise Server for VMWare 11 SP3
  • a2ps >= 4.13-1326.37.1
Patchnames:
slessp3-a2ps
SUSE Linux Enterprise Software Development Kit 11 SP3
  • a2ps-devel >= 4.13-1326.37.1
Patchnames:
sdksp3-a2ps
SUSE Linux Enterprise Software Development Kit 11 SP4
  • a2ps-devel >= 4.13-1326.37.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA a2ps-devel
SUSE Linux Enterprise Software Development Kit 11 SP3
  • a2ps-devel >= 4.13-1326.37.1
Builds
SAT Patch Nr: 9064
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • a2ps >= 4.13-1326.37.1
Builds
SAT Patch Nr: 9064
openSUSE 12.3
  • a2ps >= 4.13-1353.4.1
  • a2ps-debuginfo >= 4.13-1353.4.1
  • a2ps-debugsource >= 4.13-1353.4.1
  • a2ps-devel >= 4.13-1353.4.1
Patchnames:
openSUSE-2014-279
openSUSE 13.1
  • a2ps >= 4.13-1356.4.1
  • a2ps-debuginfo >= 4.13-1356.4.1
  • a2ps-debugsource >= 4.13-1356.4.1
  • a2ps-devel >= 4.13-1356.4.1
Patchnames:
openSUSE-2014-279
openSUSE Leap 42.1
  • a2ps >= 4.14-1.2
Patchnames:
openSUSE Leap 42.1 GA a2ps
openSUSE Leap 42.2
  • a2ps >= 4.14-2.32
Patchnames:
openSUSE Leap 42.2 GA a2ps
openSUSE Leap 42.3
  • a2ps >= 4.14-4.20
Patchnames:
openSUSE Leap 42.3 GA a2ps
openSUSE Tumbleweed
  • a2ps >= 4.14-6.6
  • a2ps-devel >= 4.14-6.6
Patchnames:
openSUSE Tumbleweed GA a2ps


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 a2ps Released
SUSE Linux Enterprise Desktop 11 SP1 a2ps Released
SUSE Linux Enterprise Desktop 11 SP3 a2ps Released
SUSE Linux Enterprise SDK 11 SP1 a2ps Released
SUSE Linux Enterprise SDK 11 SP3 a2ps Released
SUSE Linux Enterprise Server 10 SP3 a2ps Released
SUSE Linux Enterprise Server 11 SP1 a2ps Released
SUSE Linux Enterprise Server 11 SP1 LTSS a2ps Released
SUSE Linux Enterprise Server 11 SP3 a2ps Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 a2ps Released
SUSE Linux Enterprise Server for VMWare 11 SP3 a2ps Released