Upstream information

CVE-2014-0130 at MITRE

Description

Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the implicit-render implementation in Ruby on Rails before 3.2.18, 4.0.x before 4.0.5, and 4.1.x before 4.1.1, when certain route globbing configurations are enabled, allows remote attackers to read arbitrary files via a crafted request.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 5
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network Network
Access Complexity Medium Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entry: 876714 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Lifecycle Management Server 1.3
  • rubygem-actionpack-3_2 >= 3.2.12-0.15.1
Patchnames:
sleslms13-rubygem-actionpack-3_2
SUSE Linux Enterprise Software Development Kit 11 SP4
  • rubygem-actionpack-3_2 >= 3.2.12-0.19.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA rubygem-actionpack-3_2
SUSE OpenStack Cloud 3.0
  • rubygem-actionpack-2_3 >= 2.3.17-0.17.1
Patchnames:
sleclo30sp3-rubygem-actionpack-2_3
SUSE Studio Onsite 1.3
  • rubygem-actionpack-3_2 >= 3.2.12-0.15.1
Patchnames:
slestso13-rubygem-actionpack-3_2
SUSE WebYast 1.3
  • rubygem-actionpack-3_2 >= 3.2.12-0.15.1
Patchnames:
slewyst13-rubygem-actionpack-3_2
SUSE Studio Onsite 1.3
  • susestudio >= 1.3.8-0.15.2
  • susestudio-bundled-packages >= 1.3.8-0.15.2
  • susestudio-common >= 1.3.8-0.15.2
  • susestudio-runner >= 1.3.8-0.15.2
  • susestudio-sid >= 1.3.8-0.15.2
  • susestudio-ui-server >= 1.3.8-0.15.2
Builds
SAT Patch Nr: 9638
SUSE Cloud 3
  • rubygem-actionpack-2_3 >= 2.3.17-0.17.1
Builds
SAT Patch Nr: 9291
SUSE Lifecycle Management Server 1.3
SUSE Studio Onsite 1.3
WebYaST 1.3
  • rubygem-actionpack-3_2 >= 3.2.12-0.15.1
Builds
SAT Patch Nr: 9292
openSUSE 12.3
  • rubygem-actionpack-3_2 >= 3.2.12-1.28.1
  • rubygem-actionpack-3_2-doc >= 3.2.12-1.28.1
Patchnames:
openSUSE-2014-396
openSUSE 13.1
  • rubygem-actionpack-3_2 >= 3.2.13-2.24.1
  • rubygem-actionpack-3_2-doc >= 3.2.13-2.24.1
Patchnames:
openSUSE-2014-397


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Cloud 11.3 rubygem-actionpack-2_3 Released
SUSE Cloud 2.0 rubygem-actionpack-2_3 Released
SUSE Cloud 4 rubygem-actionpack-2_3 Released