Upstream information

CVE-2013-7038 at MITRE

Description

The MHD_http_unescape function in libmicrohttpd before 0.9.32 might allow remote attackers to obtain sensitive information or cause a denial of service (crash) via unspecified vectors that trigger an out-of-bounds read.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.4 5.8
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P AV:N/AC:M/Au:N/C:P/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  SUSE
Base Score 6.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact Low
SUSE Bugzilla entry: 854443 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15
  • libmicrohttpd-devel >= 0.9.57-1.33
  • libmicrohttpd12 >= 0.9.57-1.33
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libmicrohttpd-devel
SUSE Linux Enterprise Server 12 SP2
  • libmicrohttpd >= 0.9.30-5.1
  • libmicrohttpd10 >= 0.9.30-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-966
SUSE Linux Enterprise Server 12 SP3
  • libmicrohttpd10 >= 0.9.30-5.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libmicrohttpd10
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libmicrohttpd >= 0.9.30-5.1
  • libmicrohttpd10 >= 0.9.30-5.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-966
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libmicrohttpd >= 0.9.30-5.1
  • libmicrohttpd10 >= 0.9.30-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-966
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libmicrohttpd >= 0.9.30-5.1
  • libmicrohttpd-devel >= 0.9.30-5.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-966
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libmicrohttpd-devel >= 0.9.30-5.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libmicrohttpd-devel
openSUSE Leap 42.2
  • libmicrohttpd >= 0.9.30-5.3.1
  • libmicrohttpd-debugsource >= 0.9.30-5.3.1
  • libmicrohttpd-devel >= 0.9.30-5.3.1
  • libmicrohttpd10 >= 0.9.30-5.3.1
  • libmicrohttpd10-debuginfo >= 0.9.30-5.3.1
  • libmicrospdy-devel >= 0.9.30-5.3.1
  • libmicrospdy0 >= 0.9.30-5.3.1
  • libmicrospdy0-debuginfo >= 0.9.30-5.3.1
  • microspdy2http >= 0.9.30-5.3.1
  • microspdy2http-debuginfo >= 0.9.30-5.3.1
Patchnames:
openSUSE-2017-728


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 12 SP1 libmicrohttpd Affected
SUSE Linux Enterprise SDK 12 SP2 libmicrohttpd Released
SUSE Linux Enterprise Server 12 GA LTSS libmicrohttpd Affected
SUSE Linux Enterprise Server 12 SP1 libmicrohttpd Affected
SUSE Linux Enterprise Server 12 SP2 libmicrohttpd Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI libmicrohttpd Released