Upstream information

CVE-2013-4788 at MITRE

Description

The PTR_MANGLE implementation in the GNU C Library (aka glibc or libc6) 2.4, 2.17, and earlier, and Embedded GLIBC (EGLIBC) does not initialize the random value for the pointer guard, which makes it easier for context-dependent attackers to control execution flow by leveraging a buffer-overflow vulnerability in an application and using the known zero value pointer guard to calculate a pointer address.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 830268 [RESOLVED / FIXED], 882910 [CLOSED / NORESPONSE], 950944 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • glibc >= 2.11.3-17.45.49.1
  • glibc-32bit >= 2.11.3-17.45.49.1
  • glibc-devel >= 2.11.3-17.45.49.1
  • glibc-devel-32bit >= 2.11.3-17.45.49.1
  • glibc-i18ndata >= 2.11.3-17.45.49.1
  • glibc-locale >= 2.11.3-17.45.49.1
  • glibc-locale-32bit >= 2.11.3-17.45.49.1
  • nscd >= 2.11.3-17.45.49.1
Patchnames:
sledsp2-glibc
SUSE Linux Enterprise Desktop 11 SP3
  • glibc >= 2.11.3-17.56.2
  • glibc-32bit >= 2.11.3-17.56.2
  • glibc-devel >= 2.11.3-17.56.2
  • glibc-devel-32bit >= 2.11.3-17.56.2
  • glibc-i18ndata >= 2.11.3-17.56.2
  • glibc-locale >= 2.11.3-17.56.2
  • glibc-locale-32bit >= 2.11.3-17.56.2
  • nscd >= 2.11.3-17.56.2
Patchnames:
sledsp3-glibc
SUSE Linux Enterprise Server 11 SP1-LTSS
  • glibc >= 2.11.1-0.58.1
  • glibc-32bit >= 2.11.1-0.58.1
  • glibc-devel >= 2.11.1-0.58.1
  • glibc-devel-32bit >= 2.11.1-0.58.1
  • glibc-html >= 2.11.1-0.58.1
  • glibc-i18ndata >= 2.11.1-0.58.1
  • glibc-info >= 2.11.1-0.58.1
  • glibc-locale >= 2.11.1-0.58.1
  • glibc-locale-32bit >= 2.11.1-0.58.1
  • glibc-profile >= 2.11.1-0.58.1
  • glibc-profile-32bit >= 2.11.1-0.58.1
  • nscd >= 2.11.1-0.58.1
Patchnames:
slessp1-glibc
SUSE Linux Enterprise Server 11 SP2
  • glibc >= 2.11.3-17.45.49.1
  • glibc-32bit >= 2.11.3-17.45.49.1
  • glibc-devel >= 2.11.3-17.45.49.1
  • glibc-devel-32bit >= 2.11.3-17.45.49.1
  • glibc-html >= 2.11.3-17.45.49.1
  • glibc-i18ndata >= 2.11.3-17.45.49.1
  • glibc-info >= 2.11.3-17.45.49.1
  • glibc-locale >= 2.11.3-17.45.49.1
  • glibc-locale-32bit >= 2.11.3-17.45.49.1
  • glibc-locale-x86 >= 2.11.3-17.45.49.1
  • glibc-profile >= 2.11.3-17.45.49.1
  • glibc-profile-32bit >= 2.11.3-17.45.49.1
  • glibc-profile-x86 >= 2.11.3-17.45.49.1
  • glibc-x86 >= 2.11.3-17.45.49.1
  • nscd >= 2.11.3-17.45.49.1
Patchnames:
slessp2-glibc
SUSE Linux Enterprise Server 11 SP3
  • glibc >= 2.11.3-17.56.2
  • glibc-32bit >= 2.11.3-17.56.2
  • glibc-devel >= 2.11.3-17.56.2
  • glibc-devel-32bit >= 2.11.3-17.56.2
  • glibc-html >= 2.11.3-17.56.2
  • glibc-i18ndata >= 2.11.3-17.56.2
  • glibc-info >= 2.11.3-17.56.2
  • glibc-locale >= 2.11.3-17.56.2
  • glibc-locale-32bit >= 2.11.3-17.56.2
  • glibc-locale-x86 >= 2.11.3-17.72.14
  • glibc-profile >= 2.11.3-17.56.2
  • glibc-profile-32bit >= 2.11.3-17.56.2
  • glibc-profile-x86 >= 2.11.3-17.72.14
  • glibc-x86 >= 2.11.3-17.72.14
  • nscd >= 2.11.3-17.56.2
Patchnames:
slessp3-glibc
SUSE Linux Enterprise Server 11 SP4
  • glibc >= 2.11.3-17.84.1
  • glibc-32bit >= 2.11.3-17.84.1
  • glibc-devel >= 2.11.3-17.84.1
  • glibc-devel-32bit >= 2.11.3-17.84.1
  • glibc-html >= 2.11.3-17.84.1
  • glibc-i18ndata >= 2.11.3-17.84.1
  • glibc-info >= 2.11.3-17.84.1
  • glibc-locale >= 2.11.3-17.84.1
  • glibc-locale-32bit >= 2.11.3-17.84.1
  • glibc-locale-x86 >= 2.11.3-17.84.1
  • glibc-profile >= 2.11.3-17.84.1
  • glibc-profile-32bit >= 2.11.3-17.84.1
  • glibc-profile-x86 >= 2.11.3-17.84.1
  • glibc-x86 >= 2.11.3-17.84.1
  • nscd >= 2.11.3-17.84.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA glibc
SUSE Linux Enterprise Server for VMWare 11 SP2
  • glibc >= 2.11.3-17.45.49.1
  • glibc-32bit >= 2.11.3-17.45.49.1
  • glibc-devel >= 2.11.3-17.45.49.1
  • glibc-devel-32bit >= 2.11.3-17.45.49.1
  • glibc-html >= 2.11.3-17.45.49.1
  • glibc-i18ndata >= 2.11.3-17.45.49.1
  • glibc-info >= 2.11.3-17.45.49.1
  • glibc-locale >= 2.11.3-17.45.49.1
  • glibc-locale-32bit >= 2.11.3-17.45.49.1
  • glibc-locale-x86 >= 2.11.3-17.45.49.1
  • glibc-profile >= 2.11.3-17.45.49.1
  • glibc-profile-32bit >= 2.11.3-17.45.49.1
  • glibc-profile-x86 >= 2.11.3-17.45.49.1
  • glibc-x86 >= 2.11.3-17.45.49.1
  • nscd >= 2.11.3-17.45.49.1
Patchnames:
slessp2-glibc
SUSE Linux Enterprise Server for VMWare 11 SP3
  • glibc >= 2.11.3-17.56.2
  • glibc-32bit >= 2.11.3-17.56.2
  • glibc-devel >= 2.11.3-17.56.2
  • glibc-devel-32bit >= 2.11.3-17.56.2
  • glibc-html >= 2.11.3-17.56.2
  • glibc-i18ndata >= 2.11.3-17.56.2
  • glibc-info >= 2.11.3-17.56.2
  • glibc-locale >= 2.11.3-17.56.2
  • glibc-locale-32bit >= 2.11.3-17.56.2
  • glibc-locale-x86 >= 2.11.3-17.72.14
  • glibc-profile >= 2.11.3-17.56.2
  • glibc-profile-32bit >= 2.11.3-17.56.2
  • glibc-profile-x86 >= 2.11.3-17.72.14
  • glibc-x86 >= 2.11.3-17.72.14
  • nscd >= 2.11.3-17.56.2
Patchnames:
slessp3-glibc
SUSE Linux Enterprise Software Development Kit 11 SP2
  • glibc-html >= 2.11.3-17.45.49.1
  • glibc-info >= 2.11.3-17.45.49.1
Patchnames:
sdksp2-glibc
SUSE Linux Enterprise Software Development Kit 11 SP3
  • glibc-html >= 2.11.3-17.56.2
  • glibc-info >= 2.11.3-17.56.2
Patchnames:
sdksp3-glibc
SUSE Linux Enterprise Software Development Kit 11 SP4
  • glibc-html >= 2.11.3-17.84.1
  • glibc-info >= 2.11.3-17.84.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA glibc-html
SUSE Linux Enterprise Software Development Kit 11 SP3
  • glibc-html >= 2.11.3-17.56.2
  • glibc-info >= 2.11.3-17.56.2
Builds
SAT Patch Nr: 8337
SUSE Linux Enterprise Desktop 11 SP3
  • glibc >= 2.11.3-17.56.2
  • glibc-devel >= 2.11.3-17.56.2
  • glibc-i18ndata >= 2.11.3-17.56.2
  • glibc-locale >= 2.11.3-17.56.2
  • nscd >= 2.11.3-17.56.2
Builds
SAT Patch Nr: 8337
SUSE Linux Enterprise Desktop 11 SP3
  • glibc >= 2.11.3-17.56.2
  • glibc-32bit >= 2.11.3-17.56.2
  • glibc-devel >= 2.11.3-17.56.2
  • glibc-devel-32bit >= 2.11.3-17.56.2
  • glibc-i18ndata >= 2.11.3-17.56.2
  • glibc-locale >= 2.11.3-17.56.2
  • glibc-locale-32bit >= 2.11.3-17.56.2
  • nscd >= 2.11.3-17.56.2
Builds
SAT Patch Nr: 8337
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • glibc >= 2.11.3-17.56.2
  • glibc-devel >= 2.11.3-17.56.2
  • glibc-html >= 2.11.3-17.56.2
  • glibc-i18ndata >= 2.11.3-17.56.2
  • glibc-info >= 2.11.3-17.56.2
  • glibc-locale >= 2.11.3-17.56.2
  • glibc-profile >= 2.11.3-17.56.2
  • nscd >= 2.11.3-17.56.2
Builds
SAT Patch Nr: 8337
SUSE Linux Enterprise Server 11 SP3
  • glibc >= 2.11.3-17.56.2
  • glibc-devel >= 2.11.3-17.56.2
  • glibc-html >= 2.11.3-17.56.2
  • glibc-i18ndata >= 2.11.3-17.56.2
  • glibc-info >= 2.11.3-17.56.2
  • glibc-locale >= 2.11.3-17.56.2
  • glibc-locale-x86 >= 2.11.3-17.56.2
  • glibc-profile >= 2.11.3-17.56.2
  • glibc-profile-x86 >= 2.11.3-17.56.2
  • glibc-x86 >= 2.11.3-17.56.2
  • nscd >= 2.11.3-17.56.2
Builds
SAT Patch Nr: 8337
SUSE Linux Enterprise Server 11 SP3
  • glibc >= 2.11.3-17.56.2
  • glibc-32bit >= 2.11.3-17.56.2
  • glibc-devel >= 2.11.3-17.56.2
  • glibc-devel-32bit >= 2.11.3-17.56.2
  • glibc-html >= 2.11.3-17.56.2
  • glibc-i18ndata >= 2.11.3-17.56.2
  • glibc-info >= 2.11.3-17.56.2
  • glibc-locale >= 2.11.3-17.56.2
  • glibc-locale-32bit >= 2.11.3-17.56.2
  • glibc-profile >= 2.11.3-17.56.2
  • glibc-profile-32bit >= 2.11.3-17.56.2
  • nscd >= 2.11.3-17.56.2
Builds
SAT Patch Nr: 8337
SUSE Linux Enterprise Server 11 SP1 LTSS
  • glibc >= 2.11.1-0.58.1
  • glibc-devel >= 2.11.1-0.58.1
  • glibc-html >= 2.11.1-0.58.1
  • glibc-i18ndata >= 2.11.1-0.58.1
  • glibc-info >= 2.11.1-0.58.1
  • glibc-locale >= 2.11.1-0.58.1
  • glibc-profile >= 2.11.1-0.58.1
  • nscd >= 2.11.1-0.58.1
Builds
SAT Patch Nr: 9664
SUSE Linux Enterprise Server 11 SP1 LTSS
  • glibc >= 2.11.1-0.58.1
  • glibc-32bit >= 2.11.1-0.58.1
  • glibc-devel >= 2.11.1-0.58.1
  • glibc-devel-32bit >= 2.11.1-0.58.1
  • glibc-html >= 2.11.1-0.58.1
  • glibc-i18ndata >= 2.11.1-0.58.1
  • glibc-info >= 2.11.1-0.58.1
  • glibc-locale >= 2.11.1-0.58.1
  • glibc-locale-32bit >= 2.11.1-0.58.1
  • glibc-profile >= 2.11.1-0.58.1
  • glibc-profile-32bit >= 2.11.1-0.58.1
  • nscd >= 2.11.1-0.58.1
Builds
SAT Patch Nr: 9664
SUSE Linux Enterprise Software Development Kit 11 SP2
  • glibc-html >= 2.11.3-17.45.49.1
  • glibc-info >= 2.11.3-17.45.49.1
Builds
SAT Patch Nr: 8335
SUSE Linux Enterprise Desktop 11 SP2
  • glibc >= 2.11.3-17.45.49.1
  • glibc-devel >= 2.11.3-17.45.49.1
  • glibc-i18ndata >= 2.11.3-17.45.49.1
  • glibc-locale >= 2.11.3-17.45.49.1
  • nscd >= 2.11.3-17.45.49.1
Builds
SAT Patch Nr: 8335
SUSE Linux Enterprise Desktop 11 SP2
  • glibc >= 2.11.3-17.45.49.1
  • glibc-32bit >= 2.11.3-17.45.49.1
  • glibc-devel >= 2.11.3-17.45.49.1
  • glibc-devel-32bit >= 2.11.3-17.45.49.1
  • glibc-i18ndata >= 2.11.3-17.45.49.1
  • glibc-locale >= 2.11.3-17.45.49.1
  • glibc-locale-32bit >= 2.11.3-17.45.49.1
  • nscd >= 2.11.3-17.45.49.1
Builds
SAT Patch Nr: 8335
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • glibc >= 2.11.3-17.45.49.1
  • glibc-devel >= 2.11.3-17.45.49.1
  • glibc-html >= 2.11.3-17.45.49.1
  • glibc-i18ndata >= 2.11.3-17.45.49.1
  • glibc-info >= 2.11.3-17.45.49.1
  • glibc-locale >= 2.11.3-17.45.49.1
  • glibc-profile >= 2.11.3-17.45.49.1
  • nscd >= 2.11.3-17.45.49.1
Builds
SAT Patch Nr: 8335
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • glibc >= 2.11.3-17.45.49.1
  • glibc-32bit >= 2.11.3-17.45.49.1
  • glibc-devel >= 2.11.3-17.45.49.1
  • glibc-devel-32bit >= 2.11.3-17.45.49.1
  • glibc-html >= 2.11.3-17.45.49.1
  • glibc-i18ndata >= 2.11.3-17.45.49.1
  • glibc-info >= 2.11.3-17.45.49.1
  • glibc-locale >= 2.11.3-17.45.49.1
  • glibc-locale-32bit >= 2.11.3-17.45.49.1
  • glibc-profile >= 2.11.3-17.45.49.1
  • glibc-profile-32bit >= 2.11.3-17.45.49.1
  • nscd >= 2.11.3-17.45.49.1
Builds
SAT Patch Nr: 8335
SUSE Linux Enterprise Server 11 SP2
  • glibc >= 2.11.3-17.45.49.1
  • glibc-devel >= 2.11.3-17.45.49.1
  • glibc-html >= 2.11.3-17.45.49.1
  • glibc-i18ndata >= 2.11.3-17.45.49.1
  • glibc-info >= 2.11.3-17.45.49.1
  • glibc-locale >= 2.11.3-17.45.49.1
  • glibc-locale-x86 >= 2.11.3-17.45.49.1
  • glibc-profile >= 2.11.3-17.45.49.1
  • glibc-profile-x86 >= 2.11.3-17.45.49.1
  • glibc-x86 >= 2.11.3-17.45.49.1
  • nscd >= 2.11.3-17.45.49.1
Builds
SAT Patch Nr: 8335


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 glibc Affected
SUSE Linux Enterprise Desktop 10 SP4 glibc Released
SUSE Linux Enterprise Desktop 11 SP1 glibc Affected
SUSE Linux Enterprise Desktop 11 SP2 glibc Released
SUSE Linux Enterprise Desktop 11 SP3 glibc Released
SUSE Linux Enterprise Desktop 11 SP4 glibc Released
SUSE Linux Enterprise SDK 11 SP1 glibc Affected
SUSE Linux Enterprise SDK 11 SP2 glibc Released
SUSE Linux Enterprise SDK 11 SP3 glibc Released
SUSE Linux Enterprise SDK 11 SP4 glibc Released
SUSE Linux Enterprise Server 10 SP3 glibc Affected
SUSE Linux Enterprise Server 10 SP4 glibc Released
SUSE Linux Enterprise Server 10 SP4 LTSS glibc Released
SUSE Linux Enterprise Server 11 SP1 glibc Affected
SUSE Linux Enterprise Server 11 SP1 LTSS glibc Affected
SUSE Linux Enterprise Server 11 SP2 glibc Released
SUSE Linux Enterprise Server 11 SP2 LTSS glibc Released
SUSE Linux Enterprise Server 11 SP3 glibc Released
SUSE Linux Enterprise Server 11 SP3 LTSS glibc Released
SUSE Linux Enterprise Server 11 SP4 glibc Released
SUSE Linux Enterprise Server for SAP 11 SP2 glibc Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 glibc Affected
SUSE Linux Enterprise Server for SAP ES 11 SP1 glibc Affected
SUSE Linux Enterprise Server for VMWare 11 SP2 glibc Released
SUSE Linux Enterprise Server for VMWare 11 SP3 glibc Released