Upstream information

CVE-2013-4761 at MITRE

Description

Unspecified vulnerability in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, allows remote attackers to execute arbitrary Ruby programs from the master via the resource_type service. NOTE: this vulnerability can only be exploited utilizing unspecified "local file system access" to the Puppet Master.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 835122 [ASSIGNED], 836962 [RESOLVED / INVALID], 880224 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • puppet >= 2.6.18-0.12.1
Patchnames:
sledsp2-puppet
SUSE Linux Enterprise Desktop 11 SP3
  • puppet >= 2.6.18-0.14.1
Patchnames:
sledsp3-puppet
SUSE Linux Enterprise Desktop 12
  • puppet >= 3.6.2-3.62
Patchnames:
SUSE Linux Enterprise Desktop 12 GA puppet
SUSE Linux Enterprise Desktop 12 SP1
  • puppet >= 3.6.2-3.62
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA puppet
SUSE Linux Enterprise Desktop 12 SP2
  • puppet >= 3.8.5-5.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA puppet
SUSE Linux Enterprise Desktop 12 SP3
  • puppet >= 3.8.5-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA puppet
SUSE Linux Enterprise Module for Advanced Systems Management 12
  • puppet >= 3.6.2-3.62
  • puppet-server >= 3.6.2-3.62
Patchnames:
SUSE Linux Enterprise Module for Advanced Systems Management 12 GA puppet
SUSE Linux Enterprise Server 11 SP2
  • puppet >= 2.6.18-0.12.1
  • puppet-server >= 2.6.18-0.12.1
Patchnames:
slessp2-puppet
SUSE Linux Enterprise Server 11 SP2-LTSS
  • puppet >= 2.6.18-0.14.1
  • puppet-server >= 2.6.18-0.14.1
Patchnames:
slessp2-puppet
SUSE Linux Enterprise Server 11 SP3
  • puppet >= 2.6.18-0.14.1
  • puppet-server >= 2.6.18-0.14.1
Patchnames:
slessp3-puppet
SUSE Linux Enterprise Server 11 SP4
  • puppet >= 2.7.26-0.5.1
  • puppet-server >= 2.7.26-0.5.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA puppet
SUSE Linux Enterprise Server for VMWare 11 SP2
  • puppet >= 2.6.18-0.12.1
  • puppet-server >= 2.6.18-0.12.1
Patchnames:
slessp2-puppet
SUSE Linux Enterprise Server for VMWare 11 SP3
  • puppet >= 2.6.18-0.14.1
  • puppet-server >= 2.6.18-0.14.1
Patchnames:
slessp3-puppet
SUSE Linux Enterprise Desktop 11 SP3
  • puppet >= 2.6.18-0.14.1
Builds
SAT Patch Nr: 9033
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • puppet >= 2.6.18-0.14.1
  • puppet-server >= 2.6.18-0.14.1
Builds
SAT Patch Nr: 9033
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • facter >= 1.5.2-1.22.3.1
SAT Patch Nr: 8302
SUSE Linux Enterprise Desktop 11 SP2
  • puppet >= 2.6.18-0.12.1
Builds
SAT Patch Nr: 8811
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • puppet >= 2.6.18-0.12.1
  • puppet-server >= 2.6.18-0.12.1
Builds
SAT Patch Nr: 8811
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • facter >= 1.5.2-1.22.3.1
SAT Patch Nr: 8301
SUSE Linux Enterprise Server 11 SP2 LTSS
  • puppet >= 2.6.18-0.14.1
  • puppet-server >= 2.6.18-0.14.1
Builds
SAT Patch Nr: 9034
SUSE Linux Enterprise Desktop 11 SP3
  • puppet >= 2.6.18-0.12.1
Builds
SAT Patch Nr: 8812
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • puppet >= 2.6.18-0.12.1
  • puppet-server >= 2.6.18-0.12.1
Builds
SAT Patch Nr: 8812
openSUSE Tumbleweed
  • ruby2.2-rubygem-puppet >= 3.8.7-2.2
  • ruby2.2-rubygem-puppet-doc >= 3.8.7-2.2
  • ruby2.2-rubygem-puppet-testsuite >= 3.8.7-2.2
  • ruby2.3-rubygem-puppet >= 3.8.7-2.2
  • ruby2.3-rubygem-puppet-doc >= 3.8.7-2.2
  • ruby2.3-rubygem-puppet-testsuite >= 3.8.7-2.2
  • rubygem-puppet >= 3.8.7-2.2
  • rubygem-puppet-emacs >= 3.8.7-2.2
  • rubygem-puppet-master >= 3.8.7-2.2
  • rubygem-puppet-master-unicorn >= 3.8.7-2.2
  • rubygem-puppet-vim >= 3.8.7-2.2
Patchnames:
openSUSE Tumbleweed GA ruby2.2-rubygem-puppet


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 facter Released
SUSE Linux Enterprise Desktop 11 SP3 facter Released
SUSE Linux Enterprise Server 11 SP2 facter Released
SUSE Linux Enterprise Server 11 SP2 LTSS facter Released
SUSE Linux Enterprise Server 11 SP3 facter Released