Upstream information

CVE-2013-4449 at MITRE

Description

The rwm overlay in OpenLDAP 2.4.23, 2.4.36, and earlier does not properly count references, which allows remote attackers to cause a denial of service (slapd crash) by unbinding immediately after a search request, which triggers rwm_conn_destroy to free the session context while it is being used by rwm_op_search.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 846389 [RESOLVED], 905959 [RESOLVED], 916897 [RESOLVED], 916914 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libldap-2_4-2 >= 2.4.26-0.30.1
  • libldap-2_4-2-32bit >= 2.4.26-0.30.1
  • openldap2-client >= 2.4.26-0.30.1
Patchnames:
sledsp3-openldap2-20150423
SUSE Linux Enterprise Server 11 SP3
  • compat-libldap-2_3-0 >= 2.3.37-2.30.1
  • libldap-2_4-2 >= 2.4.26-0.30.1
  • libldap-2_4-2-32bit >= 2.4.26-0.30.1
  • libldap-2_4-2-x86 >= 2.4.26-0.30.1
  • openldap2 >= 2.4.26-0.30.1
  • openldap2-back-meta >= 2.4.26-0.30.1
  • openldap2-client >= 2.4.26-0.30.1
Patchnames:
slessp3-openldap2-20150423
SUSE Linux Enterprise Server 11 SP4
  • compat-libldap-2_3-0 >= 2.3.37-2.30.1
  • libldap-2_4-2 >= 2.4.26-0.30.1
  • libldap-2_4-2-32bit >= 2.4.26-0.30.1
  • libldap-2_4-2-x86 >= 2.4.26-0.30.1
  • openldap2 >= 2.4.26-0.30.1
  • openldap2-back-meta >= 2.4.26-0.30.1
  • openldap2-client >= 2.4.26-0.30.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA compat-libldap-2_3-0
SUSE Linux Enterprise Server 11-SECURITY
  • libldap-openssl1-2_4-2 >= 2.4.26-0.30.2
  • libldap-openssl1-2_4-2-32bit >= 2.4.26-0.30.2
  • libldap-openssl1-2_4-2-x86 >= 2.4.26-0.30.2
Patchnames:
secsp3-openldap2-20150423
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • compat-libldap-2_3-0 >= 2.3.37-2.30.1
  • libldap-2_4-2 >= 2.4.26-0.30.1
  • libldap-2_4-2-32bit >= 2.4.26-0.30.1
  • libldap-2_4-2-x86 >= 2.4.26-0.30.1
  • openldap2 >= 2.4.26-0.30.1
  • openldap2-back-meta >= 2.4.26-0.30.1
  • openldap2-client >= 2.4.26-0.30.1
Patchnames:
slessp3-openldap2-20150423
SUSE Linux Enterprise Server for SAP Applications 11-SECURITY
  • libldap-openssl1-2_4-2 >= 2.4.26-0.30.2
  • libldap-openssl1-2_4-2-32bit >= 2.4.26-0.30.2
  • libldap-openssl1-2_4-2-x86 >= 2.4.26-0.30.2
Patchnames:
secsp3-openldap2-20150423
SUSE Linux Enterprise Server for VMWare 11 SP3
  • compat-libldap-2_3-0 >= 2.3.37-2.30.1
  • libldap-2_4-2 >= 2.4.26-0.30.1
  • libldap-2_4-2-32bit >= 2.4.26-0.30.1
  • libldap-2_4-2-x86 >= 2.4.26-0.30.1
  • openldap2 >= 2.4.26-0.30.1
  • openldap2-back-meta >= 2.4.26-0.30.1
  • openldap2-client >= 2.4.26-0.30.1
Patchnames:
slessp3-openldap2-20150423
SUSE Linux Enterprise Software Development Kit 11 SP3
  • openldap2 >= 2.4.26-0.30.1
  • openldap2-back-perl >= 2.4.26-0.30.1
  • openldap2-devel >= 2.4.26-0.30.1
  • openldap2-devel-32bit >= 2.4.26-0.30.1
Patchnames:
sdksp3-openldap2-20150423
SUSE Linux Enterprise Software Development Kit 11 SP4
  • openldap2 >= 2.4.26-0.30.1
  • openldap2-back-perl >= 2.4.26-0.30.1
  • openldap2-devel >= 2.4.26-0.30.1
  • openldap2-devel-32bit >= 2.4.26-0.30.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA openldap2
SUSE Linux Enterprise Software Development Kit 11 SP3
  • openldap2 >= 2.4.26-0.30.1
  • openldap2-back-perl >= 2.4.26-0.30.1
  • openldap2-devel >= 2.4.26-0.30.1
Builds
SAT Patch Nr: 10635
SUSE Linux Enterprise Software Development Kit 11 SP3
  • openldap2-back-perl >= 2.4.26-0.30.1
  • openldap2-devel >= 2.4.26-0.30.1
Builds
SAT Patch Nr: 10635
SUSE Linux Enterprise Software Development Kit 11 SP3
  • openldap2-back-perl >= 2.4.26-0.30.1
  • openldap2-devel >= 2.4.26-0.30.1
  • openldap2-devel-32bit >= 2.4.26-0.30.1
Builds
SAT Patch Nr: 10635
SUSE Linux Enterprise Software Development Kit 11 SP3
  • openldap2 >= 2.4.26-0.30.1
  • openldap2-back-perl >= 2.4.26-0.30.1
  • openldap2-devel >= 2.4.26-0.30.1
  • openldap2-devel-32bit >= 2.4.26-0.30.1
Builds
SAT Patch Nr: 10635
SUSE Linux Enterprise Desktop 11 SP3
  • libldap-2_4-2 >= 2.4.26-0.30.1
  • openldap2-client >= 2.4.26-0.30.1
Builds
SAT Patch Nr: 10635
SUSE Linux Enterprise Desktop 11 SP3
  • libldap-2_4-2 >= 2.4.26-0.30.1
  • libldap-2_4-2-32bit >= 2.4.26-0.30.1
  • openldap2-client >= 2.4.26-0.30.1
Builds
SAT Patch Nr: 10635
SUSE Linux Enterprise Security Module 11 SP3
  • libldap-openssl1-2_4-2 >= 2.4.26-0.30.2
Builds
SAT Patch Nr: 10635
SUSE Linux Enterprise Security Module 11 SP3
  • libldap-openssl1-2_4-2 >= 2.4.26-0.30.2
  • libldap-openssl1-2_4-2-x86 >= 2.4.26-0.30.2
Builds
SAT Patch Nr: 10635
SUSE Linux Enterprise Security Module 11 SP3
  • libldap-openssl1-2_4-2 >= 2.4.26-0.30.2
  • libldap-openssl1-2_4-2-32bit >= 2.4.26-0.30.2
Builds
SAT Patch Nr: 10635
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • compat-libldap-2_3-0 >= 2.3.37-2.30.1
  • libldap-2_4-2 >= 2.4.26-0.30.1
  • libldap-2_4-2-32bit >= 2.4.26-0.30.1
  • openldap2 >= 2.4.26-0.30.1
  • openldap2-back-meta >= 2.4.26-0.30.1
  • openldap2-client >= 2.4.26-0.30.1
Builds
SAT Patch Nr: 10635
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • compat-libldap-2_3-0 >= 2.3.37-2.30.1
  • libldap-2_4-2 >= 2.4.26-0.30.1
  • openldap2 >= 2.4.26-0.30.1
  • openldap2-back-meta >= 2.4.26-0.30.1
  • openldap2-client >= 2.4.26-0.30.1
Builds
SAT Patch Nr: 10635
SUSE Linux Enterprise Server 11 SP3
  • compat-libldap-2_3-0 >= 2.3.37-2.30.1
  • libldap-2_4-2 >= 2.4.26-0.30.1
  • libldap-2_4-2-x86 >= 2.4.26-0.30.1
  • openldap2 >= 2.4.26-0.30.1
  • openldap2-back-meta >= 2.4.26-0.30.1
  • openldap2-client >= 2.4.26-0.30.1
Builds
SAT Patch Nr: 10635


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Legacy Software 12 openldap2 Already fixed
SUSE Linux Enterprise SDK 11 SP3 openldap2 Already fixed
SUSE Linux Enterprise SDK 11 SP4 openldap2 Already fixed
SUSE Linux Enterprise SDK 12 GA openldap2 Already fixed
SUSE Linux Enterprise Server 11 SP3 openldap2 Already fixed
SUSE Linux Enterprise Server 11 SP4 openldap2 Already fixed
SUSE Linux Enterprise Server 12 GA openldap2 Already fixed
SUSE Linux Enterprise Server for VMWare 11 SP3 openldap2 Already fixed