Upstream information

CVE-2013-4422 at MITRE

Description

SQL injection vulnerability in Quassel IRC before 0.9.1, when Qt 4.8.5 or later and PostgreSQL 8.2 or later are used, allows remote attackers to execute arbitrary SQL commands via a \ (backslash) in a message.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 845511 [RESOLVED / UPSTREAM], 928728 [RESOLVED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • quassel-base >= 0.12.4-3.3
  • quassel-client >= 0.12.4-3.3
  • quassel-client-qt5 >= 0.12.4-3.3
  • quassel-core >= 0.12.4-3.3
  • quassel-mono >= 0.12.4-3.3
Patchnames:
openSUSE Tumbleweed GA quassel-base