CVE-2013-4324

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-4324 at MITRE

Description

spice-gtk 0.14, and possibly other versions, invokes the polkit authority using the insecure polkit_unix_process_new API function, which allows local users to bypass intended access restrictions by leveraging a PolkitUnixProcess PolkitSubject race condition via a (1) setuid process or (2) pkexec process, a related issue to CVE-2013-4288.

NVD CVSS v2 Base Score: 4.6 (AV:L/AC:L/Au:N/C:P/I:P/A:P)

SUSE information

SUSE Bugzilla entries: 844967, 864716

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • libspice-client-glib-2_0-8 >= 0.14-3.4.1
  • libspice-client-glib-2_0-8-debuginfo >= 0.14-3.4.1
  • libspice-client-gtk-2_0-4 >= 0.14-3.4.1
  • libspice-client-gtk-2_0-4-debuginfo >= 0.14-3.4.1
  • libspice-client-gtk-3_0-4 >= 0.14-3.4.1
  • libspice-client-gtk-3_0-4-debuginfo >= 0.14-3.4.1
  • libspice-controller0 >= 0.14-3.4.1
  • libspice-controller0-debuginfo >= 0.14-3.4.1
  • python-SpiceClientGtk >= 0.14-3.4.1
  • python-SpiceClientGtk-debuginfo >= 0.14-3.4.1
  • spice-gtk >= 0.14-3.4.1
  • spice-gtk-debuginfo >= 0.14-3.4.1
  • spice-gtk-debugsource >= 0.14-3.4.1
  • spice-gtk-devel >= 0.14-3.4.1
  • spice-gtk-lang >= 0.14-3.4.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.14-3.4.1
  • typelib-1_0-SpiceClientGtk-2_0 >= 0.14-3.4.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.14-3.4.1
Patchnames:
openSUSE-2013-777