Upstream information

CVE-2013-4288 at MITRE

Description

Race condition in PolicyKit (aka polkit) allows local users to bypass intended PolicyKit restrictions and gain privileges by starting a setuid or pkexec process before the authorization check is performed, related to (1) the polkit_unix_process_new API function, (2) the dbus API, or (3) the --process (unix-process) option for authorization to pkcheck.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 1070943 [IN_PROGRESS], 1099031 [RESOLVED / FIXED], 835827 [RESOLVED / FIXED], 836931 [RESOLVED / FIXED], 836932 [RESOLVED / FIXED], 836937 [RESOLVED / FIXED], 836939 [RESOLVED / FIXED], 844967 [RESOLVED / FIXED], 852368 [RESOLVED / FIXED], 854144 [RESOLVED / FIXED], 864716 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libgudev-1_0-0 >= 210-44.1
  • libgudev-1_0-0-32bit >= 210-44.1
  • libpolkit0 >= 0.112-2.189
  • libpolkit0-32bit >= 0.112-2.189
  • libudev1 >= 210-44.1
  • libudev1-32bit >= 210-44.1
  • polkit >= 0.112-2.189
  • systemd >= 210-44.1
  • systemd-32bit >= 210-44.1
  • systemd-bash-completion >= 210-44.1
  • systemd-sysvinit >= 210-44.1
  • typelib-1_0-Polkit-1_0 >= 0.112-2.189
  • udev >= 210-44.1
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libgudev-1_0-0
SUSE Linux Enterprise Desktop 12 GA libpolkit0
SUSE Linux Enterprise Desktop 12 SP1
  • libgudev-1_0-0 >= 210-83.2
  • libgudev-1_0-0-32bit >= 210-83.2
  • libpolkit0 >= 0.113-4.1
  • libpolkit0-32bit >= 0.113-4.1
  • libudev1 >= 210-83.2
  • libudev1-32bit >= 210-83.2
  • polkit >= 0.113-4.1
  • systemd >= 210-83.2
  • systemd-32bit >= 210-83.2
  • systemd-bash-completion >= 210-83.2
  • systemd-sysvinit >= 210-83.2
  • typelib-1_0-Polkit-1_0 >= 0.113-4.1
  • udev >= 210-83.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libgudev-1_0-0
SUSE Linux Enterprise Desktop 12 SP1 GA libpolkit0
SUSE Linux Enterprise Desktop 12 SP2
  • libpolkit0 >= 0.113-5.6.1
  • libpolkit0-32bit >= 0.113-5.6.1
  • libsystemd0 >= 228-117.12
  • libsystemd0-32bit >= 228-117.12
  • libudev1 >= 228-117.12
  • libudev1-32bit >= 228-117.12
  • polkit >= 0.113-5.6.1
  • systemd >= 228-117.12
  • systemd-32bit >= 228-117.12
  • systemd-bash-completion >= 228-117.12
  • systemd-sysvinit >= 228-117.12
  • typelib-1_0-Polkit-1_0 >= 0.113-5.6.1
  • udev >= 228-117.12
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libpolkit0
SUSE Linux Enterprise Desktop 12 SP2 GA libsystemd0
SUSE Linux Enterprise Desktop 12 SP3
  • libpolkit0 >= 0.113-5.6.1
  • libpolkit0-32bit >= 0.113-5.6.1
  • libsystemd0 >= 228-142.1
  • libsystemd0-32bit >= 228-142.1
  • libudev1 >= 228-142.1
  • libudev1-32bit >= 228-142.1
  • polkit >= 0.113-5.6.1
  • systemd >= 228-142.1
  • systemd-32bit >= 228-142.1
  • systemd-bash-completion >= 228-142.1
  • systemd-sysvinit >= 228-142.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.6.1
  • udev >= 228-142.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libpolkit0
SUSE Linux Enterprise Desktop 12 SP3 GA libsystemd0
SUSE Linux Enterprise Module for Basesystem 15
  • libpolkit0 >= 0.114-1.12
  • libsystemd0 >= 234-22.3
  • libsystemd0-32bit >= 234-22.3
  • libudev-devel >= 234-22.3
  • libudev1 >= 234-22.3
  • libudev1-32bit >= 234-22.3
  • polkit >= 0.114-1.12
  • polkit-devel >= 0.114-1.12
  • systemd >= 234-22.3
  • systemd-32bit >= 234-22.3
  • systemd-bash-completion >= 234-22.3
  • systemd-container >= 234-22.3
  • systemd-coredump >= 234-22.3
  • systemd-devel >= 234-22.3
  • systemd-sysvinit >= 234-22.3
  • typelib-1_0-Polkit-1_0 >= 0.114-1.12
  • udev >= 234-22.3
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libpolkit0
SUSE Linux Enterprise Module for Basesystem 15 GA libsystemd0
SUSE Linux Enterprise Server 11 SP4
  • hplip >= 3.11.10-0.6.11.1
  • hplip-hpijs >= 3.11.10-0.6.11.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA hplip
SUSE Linux Enterprise Server 12
  • libgudev-1_0-0 >= 210-44.1
  • libgudev-1_0-0-32bit >= 210-44.1
  • libpolkit0 >= 0.112-2.189
  • libudev1 >= 210-44.1
  • libudev1-32bit >= 210-44.1
  • polkit >= 0.112-2.189
  • systemd >= 210-44.1
  • systemd-32bit >= 210-44.1
  • systemd-bash-completion >= 210-44.1
  • systemd-sysvinit >= 210-44.1
  • typelib-1_0-Polkit-1_0 >= 0.112-2.189
  • udev >= 210-44.1
Patchnames:
SUSE Linux Enterprise Server 12 GA libgudev-1_0-0
SUSE Linux Enterprise Server 12 GA libpolkit0
SUSE Linux Enterprise Server 12 SP1
  • libgudev-1_0-0 >= 210-83.2
  • libgudev-1_0-0-32bit >= 210-83.2
  • libpolkit0 >= 0.113-4.1
  • libudev1 >= 210-83.2
  • libudev1-32bit >= 210-83.2
  • polkit >= 0.113-4.1
  • systemd >= 210-83.2
  • systemd-32bit >= 210-83.2
  • systemd-bash-completion >= 210-83.2
  • systemd-sysvinit >= 210-83.2
  • typelib-1_0-Polkit-1_0 >= 0.113-4.1
  • udev >= 210-83.2
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libgudev-1_0-0
SUSE Linux Enterprise Server 12 SP1 GA libpolkit0
SUSE Linux Enterprise Server 12 SP2
  • libpolkit0 >= 0.113-5.6.1
  • libsystemd0 >= 228-117.12
  • libsystemd0-32bit >= 228-117.12
  • libudev1 >= 228-117.12
  • libudev1-32bit >= 228-117.12
  • polkit >= 0.113-5.6.1
  • systemd >= 228-117.12
  • systemd-32bit >= 228-117.12
  • systemd-bash-completion >= 228-117.12
  • systemd-sysvinit >= 228-117.12
  • typelib-1_0-Polkit-1_0 >= 0.113-5.6.1
  • udev >= 228-117.12
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libpolkit0
SUSE Linux Enterprise Server 12 SP2 GA libsystemd0
SUSE Linux Enterprise Server 12 SP3
  • libpolkit0 >= 0.113-5.6.1
  • libsystemd0 >= 228-142.1
  • libsystemd0-32bit >= 228-142.1
  • libudev1 >= 228-142.1
  • libudev1-32bit >= 228-142.1
  • polkit >= 0.113-5.6.1
  • systemd >= 228-142.1
  • systemd-32bit >= 228-142.1
  • systemd-bash-completion >= 228-142.1
  • systemd-sysvinit >= 228-142.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.6.1
  • udev >= 228-142.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libpolkit0
SUSE Linux Enterprise Server 12 SP3 GA libsystemd0
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpolkit0 >= 0.113-5.6.1
  • libsystemd0 >= 228-117.12
  • libudev1 >= 228-117.12
  • polkit >= 0.113-5.6.1
  • systemd >= 228-117.12
  • systemd-bash-completion >= 228-117.12
  • systemd-sysvinit >= 228-117.12
  • typelib-1_0-Polkit-1_0 >= 0.113-5.6.1
  • udev >= 228-117.12
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libpolkit0
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libsystemd0
SUSE Linux Enterprise Software Development Kit 12
  • libgudev-1_0-devel >= 210-44.1
  • libudev-devel >= 210-44.1
  • polkit-devel >= 0.112-2.189
  • systemd-devel >= 210-44.1
  • typelib-1_0-GUdev-1_0 >= 210-44.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libgudev-1_0-devel
SUSE Linux Enterprise Software Development Kit 12 GA polkit-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libgudev-1_0-devel >= 210-83.2
  • libudev-devel >= 210-83.2
  • polkit-devel >= 0.113-4.1
  • systemd-devel >= 210-83.2
  • typelib-1_0-GUdev-1_0 >= 210-83.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libgudev-1_0-devel
SUSE Linux Enterprise Software Development Kit 12 SP1 GA polkit-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libudev-devel >= 228-117.12
  • polkit-devel >= 0.113-5.6.1
  • systemd-devel >= 228-117.12
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libudev-devel
SUSE Linux Enterprise Software Development Kit 12 SP2 GA polkit-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libudev-devel >= 228-142.1
  • polkit-devel >= 0.113-5.6.1
  • systemd-devel >= 228-142.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libudev-devel
SUSE Linux Enterprise Software Development Kit 12 SP3 GA polkit-devel
SUSE Linux Enterprise Workstation Extension 12
  • libpolkit0-32bit >= 0.112-2.189
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 GA libpolkit0-32bit
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libpolkit0-32bit >= 0.113-4.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA libpolkit0-32bit
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libpolkit0-32bit >= 0.113-5.6.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libpolkit0-32bit
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libpolkit0-32bit >= 0.113-5.6.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libpolkit0-32bit
openSUSE 12.3
  • hplip >= 3.12.11-2.5.1
  • hplip-debuginfo >= 3.12.11-2.5.1
  • hplip-debugsource >= 3.12.11-2.5.1
  • hplip-hpijs >= 3.12.11-2.5.1
  • hplip-hpijs-debuginfo >= 3.12.11-2.5.1
  • hplip-sane >= 3.12.11-2.5.1
  • hplip-sane-debuginfo >= 3.12.11-2.5.1
  • libgudev-1_0-0 >= 195-13.45.1
  • libgudev-1_0-0-32bit >= 195-13.45.1
  • libgudev-1_0-0-debuginfo >= 195-13.45.1
  • libgudev-1_0-0-debuginfo-32bit >= 195-13.45.1
  • libgudev-1_0-devel >= 195-13.45.1
  • libudev-devel >= 195-13.45.1
  • libudev-mini-devel >= 195-13.45.1
  • libudev-mini1 >= 195-13.45.1
  • libudev-mini1-debuginfo >= 195-13.45.1
  • libudev1 >= 195-13.45.1
  • libudev1-32bit >= 195-13.45.1
  • libudev1-debuginfo >= 195-13.45.1
  • libudev1-debuginfo-32bit >= 195-13.45.1
  • systemd >= 195-13.45.1
  • systemd-32bit >= 195-13.45.1
  • systemd-analyze >= 195-13.45.1
  • systemd-debuginfo >= 195-13.45.1
  • systemd-debuginfo-32bit >= 195-13.45.1
  • systemd-debugsource >= 195-13.45.1
  • systemd-devel >= 195-13.45.1
  • systemd-logger >= 195-13.45.1
  • systemd-mini >= 195-13.45.1
  • systemd-mini-analyze >= 195-13.45.1
  • systemd-mini-debuginfo >= 195-13.45.1
  • systemd-mini-debugsource >= 195-13.45.1
  • systemd-mini-devel >= 195-13.45.1
  • systemd-mini-sysvinit >= 195-13.45.1
  • systemd-sysvinit >= 195-13.45.1
  • typelib-1_0-GUdev-1_0 >= 195-13.45.1
  • udev >= 195-13.45.1
  • udev-debuginfo >= 195-13.45.1
  • udev-mini >= 195-13.45.1
  • udev-mini-debuginfo >= 195-13.45.1
Patchnames:
openSUSE-2013-737
openSUSE-2013-812
openSUSE Leap 15.0
  • libpolkit0 >= 0.114-lp150.1.6
  • libsystemd0 >= 234-lp150.19.1
  • libudev1 >= 234-lp150.19.1
  • libudev1-32bit >= 234-lp150.19.1
  • polkit >= 0.114-lp150.1.6
  • systemd >= 234-lp150.19.1
  • systemd-32bit >= 234-lp150.19.1
  • systemd-bash-completion >= 234-lp150.19.1
  • systemd-sysvinit >= 234-lp150.19.1
  • typelib-1_0-Polkit-1_0 >= 0.114-lp150.1.6
  • udev >= 234-lp150.19.1
Patchnames:
openSUSE Leap 15.0 GA libpolkit0
openSUSE Leap 15.0 GA libsystemd0
openSUSE Leap 42.1
  • libgudev-1_0-0 >= 210-84.1
  • libgudev-1_0-devel >= 210-84.1
  • libpolkit0 >= 0.112-4.2
  • libudev-devel >= 210-84.1
  • libudev1 >= 210-84.1
  • libudev1-32bit >= 210-84.1
  • polkit >= 0.112-4.2
  • polkit-devel >= 0.112-4.2
  • systemd >= 210-84.1
  • systemd-32bit >= 210-84.1
  • systemd-bash-completion >= 210-84.1
  • systemd-logger >= 210-84.1
  • systemd-sysvinit >= 210-84.1
  • typelib-1_0-GUdev-1_0 >= 210-84.1
  • typelib-1_0-Polkit-1_0 >= 0.112-4.2
  • udev >= 210-84.1
Patchnames:
openSUSE Leap 42.1 GA libgudev-1_0-0
openSUSE Leap 42.1 GA libpolkit0
openSUSE Leap 42.2
  • libpolkit0 >= 0.113-10.1
  • libsystemd0 >= 228-13.1
  • libsystemd0-32bit >= 228-13.1
  • libudev-devel >= 228-13.1
  • libudev1 >= 228-13.1
  • libudev1-32bit >= 228-13.1
  • polkit >= 0.113-10.1
  • polkit-devel >= 0.113-10.1
  • systemd >= 228-13.1
  • systemd-32bit >= 228-13.1
  • systemd-bash-completion >= 228-13.1
  • systemd-logger >= 228-13.1
  • systemd-sysvinit >= 228-13.1
  • typelib-1_0-Polkit-1_0 >= 0.113-10.1
  • udev >= 228-13.1
Patchnames:
openSUSE Leap 42.2 GA libpolkit0
openSUSE Leap 42.2 GA libsystemd0
openSUSE Leap 42.3
  • libpolkit0 >= 0.113-13.1
  • libsystemd0 >= 228-27.2
  • libsystemd0-32bit >= 228-27.2
  • libudev-devel >= 228-27.2
  • libudev1 >= 228-27.2
  • libudev1-32bit >= 228-27.2
  • polkit >= 0.113-13.1
  • polkit-devel >= 0.113-13.1
  • systemd >= 228-27.2
  • systemd-32bit >= 228-27.2
  • systemd-bash-completion >= 228-27.2
  • systemd-logger >= 228-27.2
  • systemd-sysvinit >= 228-27.2
  • typelib-1_0-Polkit-1_0 >= 0.113-13.1
  • udev >= 228-27.2
Patchnames:
openSUSE Leap 42.3 GA libpolkit0
openSUSE Leap 42.3 GA libsystemd0
openSUSE Tumbleweed
  • libpolkit0 >= 0.113-3.4
  • libpolkit0-32bit >= 0.113-3.4
  • libsystemd0 >= 228-17.1
  • libsystemd0-32bit >= 228-17.1
  • libsystemd0-mini >= 228-17.1
  • libudev-devel >= 228-17.1
  • libudev-devel-32bit >= 228-17.1
  • libudev1 >= 228-17.1
  • libudev1-32bit >= 228-17.1
  • nss-myhostname >= 228-17.1
  • nss-myhostname-32bit >= 228-17.1
  • nss-mymachines >= 228-17.1
  • nss-mymachines-32bit >= 228-17.1
  • polkit >= 0.113-3.4
  • polkit-devel >= 0.113-3.4
  • polkit-doc >= 0.113-3.4
  • systemd >= 228-17.1
  • systemd-32bit >= 228-17.1
  • systemd-bash-completion >= 228-17.1
  • systemd-devel >= 228-17.1
  • systemd-journal-remote >= 228-17.1
  • systemd-logger >= 228-17.1
  • systemd-mini-bash-completion >= 228-17.1
  • systemd-sysvinit >= 228-17.1
  • typelib-1_0-Polkit-1_0 >= 0.113-3.4
  • udev >= 228-17.1
Patchnames:
openSUSE Tumbleweed GA libpolkit0
openSUSE Tumbleweed GA libsystemd0


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 libvirt Released
SUSE Linux Enterprise Desktop 11 SP3 libvirt Released
SUSE Linux Enterprise SDK 11 SP2 libvirt Released
SUSE Linux Enterprise SDK 11 SP3 libvirt Released
SUSE Linux Enterprise Server 11 SP2 libvirt Released
SUSE Linux Enterprise Server 11 SP2 LTSS libvirt Released
SUSE Linux Enterprise Server 11 SP3 libvirt Released
SUSE Linux Enterprise Server 11 SP3 LTSS libvirt Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 libvirt Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 libvirt Released