Upstream information

CVE-2013-4143 at MITRE

Description

The (1) checkPasswd and (2) checkGroupXlockPasswds functions in xlockmore before 5.43 do not properly handle when a NULL value is returned upon an error by the crypt or dispcrypt function as implemented in glibc 2.17 and later, which allows attackers to bypass the screen lock via vectors related to invalid salts.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 829859 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • xlockmore >= 5.43-5.33
Patchnames:
SUSE Linux Enterprise Desktop 12 GA xlockmore
SUSE Linux Enterprise Desktop 12 SP1
  • xlockmore >= 5.43-5.33
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA xlockmore
SUSE Linux Enterprise Desktop 12 SP2
  • xlockmore >= 5.43-5.33
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA xlockmore
SUSE Linux Enterprise Desktop 12 SP3
  • xlockmore >= 5.43-5.33
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA xlockmore
SUSE Linux Enterprise Server 12
  • xlockmore >= 5.43-5.33
Patchnames:
SUSE Linux Enterprise Server 12 GA xlockmore
SUSE Linux Enterprise Server 12 SP1
  • xlockmore >= 5.43-5.33
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA xlockmore
SUSE Linux Enterprise Server 12 SP2
  • xlockmore >= 5.43-5.33
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA xlockmore
SUSE Linux Enterprise Server 12 SP3
  • xlockmore >= 5.43-5.33
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA xlockmore
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • xlockmore >= 5.43-5.30
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA xlockmore
openSUSE Leap 42.1
  • xlockmore >= 5.43-7.2
Patchnames:
openSUSE Leap 42.1 GA xlockmore
openSUSE Leap 42.2
  • xlockmore >= 5.43-8.3
Patchnames:
openSUSE Leap 42.2 GA xlockmore
openSUSE Leap 42.3
  • xlockmore >= 5.43-10.1
Patchnames:
openSUSE Leap 42.3 GA xlockmore
openSUSE Tumbleweed
  • xlockmore >= 5.45-3.8
Patchnames:
openSUSE Tumbleweed GA xlockmore