Upstream information

CVE-2013-4136 at MITRE

Description

ext/common/ServerInstanceDir.h in Phusion Passenger gem before 4.0.6 for Ruby allows local users to gain privileges or possibly change the ownership of arbitrary directories via a symlink attack on a directory with a predictable name in /tmp/.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 624673 [RESOLVED / FIXED], 919726 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Lifecycle Management Server 1.3
  • rubygem-passenger >= 3.0.14-0.14.1
  • rubygem-passenger-apache2 >= 3.0.14-0.14.1
  • rubygem-passenger-nginx >= 3.0.14-0.14.1
Patchnames:
sleslms13-rubygem-passenger-12303
SUSE Studio Onsite 1.3
  • rubygem-passenger >= 3.0.14-0.14.1
  • rubygem-passenger-nginx >= 3.0.14-0.14.1
Patchnames:
slestso13-rubygem-passenger-12303
SUSE WebYast 1.3
  • rubygem-passenger >= 3.0.14-0.14.1
  • rubygem-passenger-nginx >= 3.0.14-0.14.1
Patchnames:
slewyst13-rubygem-passenger-12303


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Lifecycle Management Server 1.3 rubygem-passenger Affected
SUSE Studio Onsite 1.3 rubygem-passenger Affected
WebYaST 1.3 rubygem-passenger Affected