CVE-2013-2503

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-2503 at MITRE

Description

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers in the client-server data stream, which makes it easier for remote HTTP servers to spoof the intended proxy service via a 407 (aka Proxy Authentication Required) HTTP status code.

NVD CVSS v2 Base Score: 5.8 (AV:N/AC:M/Au:N/C:P/I:P/A:N)

SUSE information

SUSE Bugzilla entry: 809123

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • privoxy >= 3.0.21-2.4.1
  • privoxy-debuginfo >= 3.0.21-2.4.1
  • privoxy-debugsource >= 3.0.21-2.4.1
  • privoxy-doc >= 3.0.21-2.4.1
Patchnames:
openSUSE-2013-242
openSUSE Evergreen 11.4
  • privoxy >= 3.0.21-7.1
  • privoxy-debuginfo >= 3.0.21-7.1
  • privoxy-debugsource >= 3.0.21-7.1
  • privoxy-doc >= 3.0.21-7.1
Patchnames:
2013-51