Upstream information

CVE-2013-2142 at MITRE

Description

userpref.c in libimobiledevice 1.1.4, when $HOME and $XDG_CONFIG_HOME are not set, allows local users to overwrite arbitrary files via a symlink attack on (1) HostCertificate.pem, (2) HostPrivateKey.pem, (3) libimobiledevicerc, (4) RootCertificate.pem, or (5) RootPrivateKey.pem in /tmp/root/.config/libimobiledevice/.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.3
Vector AV:L/AC:M/Au:N/C:N/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 823250 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • imobiledevice-tools >= 1.2.0-7.31
  • libimobiledevice6 >= 1.2.0-7.31
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA imobiledevice-tools
SUSE Linux Enterprise Desktop 12 SP3
  • imobiledevice-tools >= 1.2.0-7.31
  • libimobiledevice6 >= 1.2.0-7.31
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA imobiledevice-tools
SUSE Linux Enterprise Module for Desktop Applications 15
  • libimobiledevice-devel >= 1.2.0+git20170122.45fda81-1.44
  • libimobiledevice6 >= 1.2.0+git20170122.45fda81-1.44
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libimobiledevice-devel
SUSE Linux Enterprise Server 12 SP2
  • libimobiledevice6 >= 1.2.0-7.31
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libimobiledevice6
SUSE Linux Enterprise Server 12 SP3
  • libimobiledevice6 >= 1.2.0-7.31
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libimobiledevice6
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libimobiledevice6 >= 1.2.0-7.31
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libimobiledevice6
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libimobiledevice-devel >= 1.2.0-7.31
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libimobiledevice-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libimobiledevice-devel >= 1.2.0-7.31
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libimobiledevice-devel
SUSE Linux Enterprise Workstation Extension 12 SP2
  • imobiledevice-tools >= 1.2.0-7.31
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA imobiledevice-tools
SUSE Linux Enterprise Workstation Extension 12 SP3
  • imobiledevice-tools >= 1.2.0-7.31
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA imobiledevice-tools
SUSE Linux Enterprise Workstation Extension 15
  • imobiledevice-tools >= 1.2.0+git20170122.45fda81-1.44
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 GA imobiledevice-tools
openSUSE Leap 15.0
  • libimobiledevice6 >= 1.2.0+git20170122.45fda81-lp150.1.14
Patchnames:
openSUSE Leap 15.0 GA libimobiledevice6
openSUSE Leap 42.1
  • libimobiledevice-devel >= 1.2.0-4.7
  • libimobiledevice6 >= 1.2.0-4.7
Patchnames:
openSUSE Leap 42.1 GA libimobiledevice-devel
openSUSE Leap 42.2
  • libimobiledevice-devel >= 1.2.0-6.10
  • libimobiledevice6 >= 1.2.0-6.10
Patchnames:
openSUSE Leap 42.2 GA libimobiledevice-devel
openSUSE Leap 42.3
  • libimobiledevice-devel >= 1.2.0+git20170122.45fda81-8.6
  • libimobiledevice6 >= 1.2.0+git20170122.45fda81-8.6
Patchnames:
openSUSE Leap 42.3 GA libimobiledevice-devel
openSUSE Tumbleweed
  • imobiledevice-tools >= 1.2.0-3.4
  • libimobiledevice-devel >= 1.2.0-3.4
  • libimobiledevice-doc >= 1.2.0-3.4
  • libimobiledevice6 >= 1.2.0-3.4
  • libimobiledevice6-32bit >= 1.2.0-3.4
  • python-imobiledevice >= 1.2.0-3.4
Patchnames:
openSUSE Tumbleweed GA imobiledevice-tools


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 libimobiledevice Affected
SUSE Linux Enterprise Desktop 11 SP3 libimobiledevice Affected