Upstream information

CVE-2013-2131 at MITRE

Description

Format string vulnerability in the rrdtool module 1.4.7 for Python, as used in Zenoss, allows context-dependent attackers to cause a denial of service (crash) via format string specifiers to the rrdtool.graph function.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial

Note from the SUSE Security Team

The SUSE Security team does not consider this a security issue.

SUSE Bugzilla entry: 828003 [RESOLVED / FEATURE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • rrdtool >= 1.4.7-20.1
  • rrdtool-cached >= 1.4.7-20.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-45
SUSE Linux Enterprise Desktop 12 SP2
  • rrdtool >= 1.4.7-20.1
  • rrdtool-cached >= 1.4.7-20.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-45
SUSE Linux Enterprise Desktop 12 SP3
  • rrdtool >= 1.4.7-20.1
  • rrdtool-cached >= 1.4.7-20.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA rrdtool
SUSE Linux Enterprise Module for Basesystem 15
  • librrd8 >= 1.7.0-4.34
  • rrdtool >= 1.7.0-4.34
  • rrdtool-devel >= 1.7.0-4.34
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA librrd8
SUSE Linux Enterprise Server 12 SP1
  • rrdtool >= 1.4.7-20.1
  • rrdtool-cached >= 1.4.7-20.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-45
SUSE Linux Enterprise Server 12 SP2
  • rrdtool >= 1.4.7-20.1
  • rrdtool-cached >= 1.4.7-20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-45
SUSE Linux Enterprise Server 12 SP3
  • rrdtool >= 1.4.7-20.1
  • rrdtool-cached >= 1.4.7-20.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA rrdtool
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • rrdtool >= 1.4.7-20.1
  • rrdtool-cached >= 1.4.7-20.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-45
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • rrdtool >= 1.4.7-20.1
  • rrdtool-cached >= 1.4.7-20.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-45
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • rrdtool >= 1.4.7-20.1
  • rrdtool-cached >= 1.4.7-20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-45
SUSE Linux Enterprise Software Development Kit 12 SP1
  • rrdtool >= 1.4.7-20.1
  • rrdtool-devel >= 1.4.7-20.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-45
SUSE Linux Enterprise Software Development Kit 12 SP2
  • rrdtool >= 1.4.7-20.1
  • rrdtool-devel >= 1.4.7-20.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-45
SUSE Linux Enterprise Software Development Kit 12 SP3
  • rrdtool-devel >= 1.4.7-20.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA rrdtool-devel
openSUSE 13.1
  • lua-rrdtool >= 1.4.7-13.4.1
  • lua-rrdtool-debuginfo >= 1.4.7-13.4.1
  • python-rrdtool >= 1.4.7-13.4.1
  • python-rrdtool-debuginfo >= 1.4.7-13.4.1
  • rrdtool >= 1.4.7-13.4.1
  • rrdtool-debuginfo >= 1.4.7-13.4.1
  • rrdtool-debugsource >= 1.4.7-13.4.1
  • rrdtool-devel >= 1.4.7-13.4.1
  • ruby-rrdtool >= 1.4.7-13.4.1
  • ruby-rrdtool-debuginfo >= 1.4.7-13.4.1
  • tcl-rrdtool >= 1.4.7-13.4.1
  • tcl-rrdtool-debuginfo >= 1.4.7-13.4.1
Patchnames:
openSUSE-2014-778
openSUSE Leap 42.3
  • lua-rrdtool >= 1.4.7-26.3.1
  • lua-rrdtool-debuginfo >= 1.4.7-26.3.1
  • python-rrdtool >= 1.4.7-26.3.1
  • python-rrdtool-debuginfo >= 1.4.7-26.3.1
  • rrdtool >= 1.4.7-26.3.1
  • rrdtool-cached >= 1.4.7-26.3.1
  • rrdtool-cached-debuginfo >= 1.4.7-26.3.1
  • rrdtool-debuginfo >= 1.4.7-26.3.1
  • rrdtool-debugsource >= 1.4.7-26.3.1
  • rrdtool-devel >= 1.4.7-26.3.1
  • ruby-rrdtool >= 1.4.7-26.3.1
  • ruby-rrdtool-debuginfo >= 1.4.7-26.3.1
  • tcl-rrdtool >= 1.4.7-26.3.1
  • tcl-rrdtool-debuginfo >= 1.4.7-26.3.1
Patchnames:
openSUSE-2018-175
openSUSE Tumbleweed
  • lua-rrdtool >= 1.6.0-1.1
  • perl-rrdtool >= 1.6.0-1.1
  • python-rrdtool >= 1.6.0-1.1
  • rrdtool >= 1.6.0-1.1
  • rrdtool-cached >= 1.6.0-1.1
  • rrdtool-devel >= 1.6.0-1.1
  • rrdtool-doc >= 1.6.0-1.1
  • ruby-rrdtool >= 1.6.0-1.1
  • tcl-rrdtool >= 1.6.0-1.1
Patchnames:
openSUSE Tumbleweed GA lua-rrdtool


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 rrdtool Affected
SUSE Linux Enterprise Desktop 11 SP3 rrdtool Affected
SUSE Linux Enterprise Desktop 11 SP4 rrdtool Affected
SUSE Linux Enterprise Desktop 12 GA rrdtool Affected
SUSE Linux Enterprise Desktop 12 SP1 rrdtool Released
SUSE Linux Enterprise Desktop 12 SP2 rrdtool Released
SUSE Linux Enterprise SDK 11 SP2 rrdtool Affected
SUSE Linux Enterprise SDK 11 SP3 rrdtool Affected
SUSE Linux Enterprise SDK 11 SP4 rrdtool Affected
SUSE Linux Enterprise SDK 12 GA rrdtool Affected
SUSE Linux Enterprise SDK 12 SP1 rrdtool Released
SUSE Linux Enterprise SDK 12 SP2 rrdtool Released
SUSE Linux Enterprise Server 10 SP4 LTSS rrdtool Affected
SUSE Linux Enterprise Server 11 SP2 rrdtool Affected
SUSE Linux Enterprise Server 11 SP2 LTSS rrdtool Affected
SUSE Linux Enterprise Server 11 SP3 rrdtool Affected
SUSE Linux Enterprise Server 11 SP4 rrdtool Affected
SUSE Linux Enterprise Server 12 GA rrdtool Affected
SUSE Linux Enterprise Server 12 SP1 rrdtool Released
SUSE Linux Enterprise Server 12 SP2 rrdtool Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI rrdtool Released
SUSE Linux Enterprise Server for VMWare 11 SP2 rrdtool Affected
SUSE Linux Enterprise Server for VMWare 11 SP3 rrdtool Affected