Upstream information

CVE-2013-2126 at MITRE

Description

Multiple double free vulnerabilities in the LibRaw::unpack function in libraw_cxx.cpp in LibRaw before 0.15.2 allow context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a malformed full-color (1) Foveon or (2) sRAW image file.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.48
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 822665 [RESOLVED / FIXED], 823113 [RESOLVED / FIXED], 823114 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libraw9
SUSE Linux Enterprise Desktop 12 SP1
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libraw9
SUSE Linux Enterprise Desktop 12 SP2
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libraw9
SUSE Linux Enterprise Software Development Kit 12
  • libraw-devel >= 0.15.4-3.88
  • libraw-devel-static >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libraw-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libraw-devel >= 0.15.4-3.88
  • libraw-devel-static >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libraw-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libraw-devel >= 0.15.4-3.89
  • libraw-devel-static >= 0.15.4-3.89
  • libraw9 >= 0.15.4-3.89
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libraw-devel
SUSE Linux Enterprise Workstation Extension 12
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 GA libraw9
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA libraw9
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libraw9
openSUSE 13.2
  • libraw-devel >= 0.16.0-2.1.2
  • libraw10 >= 0.16.0-2.1.2
Patchnames:
openSUSE 13.2 GA libraw-devel
openSUSE Leap 42.1
  • libraw-devel >= 0.16.2-2.6
  • libraw10 >= 0.16.2-2.6
Patchnames:
openSUSE Leap 42.1 GA libraw-devel
openSUSE Leap 42.2
  • libraw-devel >= 0.17.1-1.2
  • libraw15 >= 0.17.1-1.2
Patchnames:
openSUSE Leap 42.2 GA libraw-devel
openSUSE Tumbleweed
  • libraw-devel >= 0.17.2-1.4
  • libraw-devel-static >= 0.17.2-1.4
  • libraw-tools >= 0.17.2-1.4
  • libraw15 >= 0.17.2-1.4
Patchnames:
openSUSE Tumbleweed GA libraw-devel