Upstream information

CVE-2013-1864 at MITRE

Description

The Portable Tool Library (aka PTLib) before 2.10.10, as used in Ekiga before 4.0.1, does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted PXML document containing a large number of nested entity references, aka a "billion laughs attack."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 809917 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • pwlib >= 1.10.10-120.35.1
  • pwlib-plugins-avc >= 1.10.10-120.35.1
  • pwlib-plugins-dc >= 1.10.10-120.35.1
  • pwlib-plugins-v4l2 >= 1.10.10-120.35.1
Patchnames:
sledsp3-pwlib
SUSE Linux Enterprise Software Development Kit 11 SP3
  • pwlib >= 1.10.10-120.35.1
  • pwlib-devel >= 1.10.10-120.35.1
Patchnames:
sdksp3-pwlib
SUSE Linux Enterprise Software Development Kit 11 SP4
  • pwlib >= 1.10.10-120.35.1
  • pwlib-devel >= 1.10.10-120.35.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA pwlib
SUSE Linux Enterprise Software Development Kit 11 SP3
  • pwlib >= 1.10.10-120.35.1
  • pwlib-devel >= 1.10.10-120.35.1
Builds
SAT Patch Nr: 8838
SUSE Linux Enterprise Desktop 11 SP3
  • pwlib >= 1.10.10-120.35.1
  • pwlib-plugins-avc >= 1.10.10-120.35.1
  • pwlib-plugins-dc >= 1.10.10-120.35.1
  • pwlib-plugins-v4l2 >= 1.10.10-120.35.1
Builds
SAT Patch Nr: 8838


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 libpt2 Affected
SUSE Linux Enterprise Desktop 11 SP2 pwlib Affected
SUSE Linux Enterprise Desktop 11 SP3 libpt2 Affected
SUSE Linux Enterprise Desktop 11 SP3 pwlib Released
SUSE Linux Enterprise Desktop 11 SP4 libpt2 Affected
SUSE Linux Enterprise Desktop 11 SP4 pwlib Already fixed
SUSE Linux Enterprise SDK 11 SP2 libpt2 Affected
SUSE Linux Enterprise SDK 11 SP2 pwlib Affected
SUSE Linux Enterprise SDK 11 SP3 libpt2 Affected
SUSE Linux Enterprise SDK 11 SP3 pwlib Released
SUSE Linux Enterprise SDK 11 SP4 libpt2 Affected
SUSE Linux Enterprise SDK 11 SP4 pwlib Already fixed