Upstream information

CVE-2013-1788 at MITRE

Description

poppler before 0.22.1 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors that trigger an "invalid memory access" in (1) splash/Splash.cc, (2) poppler/Function.cc, and (3) poppler/Stream.cc.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.82
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 806793 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • libpoppler-glib4 >= 0.12.3-1.8.1
  • libpoppler-qt4-3 >= 0.12.3-1.8.1
  • libpoppler5 >= 0.12.3-1.8.1
  • poppler-tools >= 0.12.3-1.8.1
Patchnames:
sledsp2-libpoppler-devel
SUSE Linux Enterprise Desktop 12
  • libpoppler-glib8 >= 0.24.4-3.14
  • libpoppler-qt4-4 >= 0.24.4-3.13
  • libpoppler44 >= 0.24.4-3.14
  • poppler-tools >= 0.24.4-3.14
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libpoppler-glib8
SUSE Linux Enterprise Desktop 12 SP1
  • libpoppler-glib8 >= 0.24.4-3.14
  • libpoppler-qt4-4 >= 0.24.4-3.13
  • libpoppler44 >= 0.24.4-3.14
  • poppler-tools >= 0.24.4-3.14
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libpoppler-glib8
SUSE Linux Enterprise Desktop 12 SP2
  • libpoppler-glib8 >= 0.43.0-15.1
  • libpoppler-qt4-4 >= 0.43.0-15.1
  • libpoppler44 >= 0.24.4-12.1
  • libpoppler60 >= 0.43.0-15.1
  • poppler-tools >= 0.43.0-15.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libpoppler-glib8
SUSE Linux Enterprise Desktop 12 SP2 GA libpoppler44
SUSE Linux Enterprise Server 11 SP2
  • libpoppler-glib4 >= 0.12.3-1.8.1
  • libpoppler-qt4-3 >= 0.12.3-1.8.1
  • libpoppler5 >= 0.12.3-1.8.1
  • poppler-tools >= 0.12.3-1.8.1
Patchnames:
slessp2-libpoppler-devel
SUSE Linux Enterprise Server 12
  • libpoppler-glib8 >= 0.24.4-3.8
  • libpoppler-qt4-4 >= 0.24.4-3.9
  • libpoppler44 >= 0.24.4-3.8
  • poppler-tools >= 0.24.4-3.8
Patchnames:
SUSE Linux Enterprise Server 12 GA libpoppler-glib8
SUSE Linux Enterprise Server 12 SP1
  • libpoppler-glib8 >= 0.24.4-3.8
  • libpoppler-qt4-4 >= 0.24.4-3.9
  • libpoppler44 >= 0.24.4-3.8
  • poppler-tools >= 0.24.4-3.8
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libpoppler-glib8
SUSE Linux Enterprise Server 12 SP2
  • libpoppler-glib8 >= 0.43.0-15.1
  • libpoppler-qt4-4 >= 0.43.0-15.1
  • libpoppler44 >= 0.24.4-12.1
  • libpoppler60 >= 0.43.0-15.1
  • poppler-tools >= 0.43.0-15.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libpoppler-glib8
SUSE Linux Enterprise Server 12 SP2 GA libpoppler44
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpoppler-glib8 >= 0.43.0-15.1
  • libpoppler-qt4-4 >= 0.43.0-15.1
  • libpoppler44 >= 0.24.4-12.1
  • libpoppler60 >= 0.43.0-15.1
  • poppler-tools >= 0.43.0-15.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libpoppler-glib8
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libpoppler44
SUSE Linux Enterprise Server for VMWare 11 SP2
  • libpoppler-glib4 >= 0.12.3-1.8.1
  • libpoppler-qt4-3 >= 0.12.3-1.8.1
  • libpoppler5 >= 0.12.3-1.8.1
  • poppler-tools >= 0.12.3-1.8.1
Patchnames:
slessp2-libpoppler-devel
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libpoppler-devel >= 0.12.3-1.8.1
  • libpoppler-glib-devel >= 0.12.3-1.8.1
  • libpoppler-qt2 >= 0.12.3-1.8.1
  • libpoppler-qt3-devel >= 0.12.3-1.8.1
  • libpoppler-qt4-devel >= 0.12.3-1.8.1
  • poppler-tools >= 0.12.3-1.8.1
Patchnames:
sdksp2-libpoppler-devel
SUSE Linux Enterprise Software Development Kit 12
  • libpoppler-devel >= 0.24.4-3.14
  • libpoppler-glib-devel >= 0.24.4-3.14
  • libpoppler-qt4-devel >= 0.24.4-3.13
  • typelib-1_0-Poppler-0_18 >= 0.24.4-3.14
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libpoppler-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libpoppler-devel >= 0.24.4-3.14
  • libpoppler-glib-devel >= 0.24.4-3.14
  • libpoppler-qt4-devel >= 0.24.4-3.13
  • typelib-1_0-Poppler-0_18 >= 0.24.4-3.14
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libpoppler-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpoppler-cpp0 >= 0.43.0-15.1
  • libpoppler-devel >= 0.43.0-15.1
  • libpoppler-glib-devel >= 0.43.0-15.1
  • libpoppler-qt4-devel >= 0.43.0-15.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-15.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libpoppler-cpp0
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libpoppler-devel >= 0.12.3-1.8.1
  • libpoppler-glib-devel >= 0.12.3-1.8.1
  • libpoppler-qt2 >= 0.12.3-1.8.1
  • libpoppler-qt3-devel >= 0.12.3-1.8.1
  • libpoppler-qt4-devel >= 0.12.3-1.8.1
  • poppler-tools >= 0.12.3-1.8.1
Builds
SAT Patch Nr: 7560
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libpoppler-devel >= 0.12.3-1.8.1
  • libpoppler-glib-devel >= 0.12.3-1.8.1
  • libpoppler-qt2 >= 0.12.3-1.8.1
  • libpoppler-qt3-devel >= 0.12.3-1.8.1
  • libpoppler-qt4-devel >= 0.12.3-1.8.1
Builds
SAT Patch Nr: 7560
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • libpoppler-glib4 >= 0.12.3-1.8.1
  • libpoppler-qt4-3 >= 0.12.3-1.8.1
  • libpoppler5 >= 0.12.3-1.8.1
  • poppler-tools >= 0.12.3-1.8.1
Builds
SAT Patch Nr: 7560
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • poppler >= 0.4.4-19.29.1
  • poppler-devel >= 0.4.4-19.29.1
  • poppler-glib >= 0.4.4-19.29.1
  • poppler-qt >= 0.4.4-19.29.1
Builds
ZYPP Patch Nr: 8523
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • poppler-devel >= 0.4.4-19.29.1
Builds
ZYPP Patch Nr: 8523
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 for IPF
SUSE Linux Enterprise Server 10 SP4 for x86
  • poppler >= 0.4.4-19.29.1
  • poppler-glib >= 0.4.4-19.29.1
  • poppler-qt >= 0.4.4-19.29.1
Builds
ZYPP Patch Nr: 8523
openSUSE 13.2
  • libpoppler-cpp0 >= 0.26.5-1.1
  • libpoppler-devel >= 0.26.5-1.1
  • libpoppler-glib8 >= 0.26.5-1.1
  • libpoppler-qt4-4 >= 0.26.5-1.1
  • libpoppler-qt4-devel >= 0.26.5-1.1
  • libpoppler46 >= 0.26.5-1.1
  • poppler-tools >= 0.26.5-1.1
Patchnames:
openSUSE 13.2 GA libpoppler-cpp0
openSUSE Evergreen 11.4
  • libpoppler-cpp0 >= 0.14.4-13.1
  • libpoppler-cpp0-debuginfo >= 0.14.4-13.1
  • libpoppler-devel >= 0.14.4-13.1
  • libpoppler-doc >= 0.14.4-13.1
  • libpoppler-glib-devel >= 0.14.4-13.1
  • libpoppler-glib5 >= 0.14.4-13.1
  • libpoppler-glib5-debuginfo >= 0.14.4-13.1
  • libpoppler7 >= 0.14.4-13.1
  • libpoppler7-debuginfo >= 0.14.4-13.1
  • poppler >= 0.14.4-13.1
  • poppler-debugsource >= 0.14.4-13.1
  • poppler-tools >= 0.14.4-13.1
  • poppler-tools-debuginfo >= 0.14.4-13.1
Patchnames:
2014-19
openSUSE Leap 42.1
  • libpoppler-devel >= 0.24.4-5.3
  • libpoppler-glib8 >= 0.24.4-5.3
  • libpoppler-qt4-4 >= 0.24.4-5.2
  • libpoppler44 >= 0.24.4-5.3
  • poppler-tools >= 0.24.4-5.3
Patchnames:
openSUSE Leap 42.1 GA libpoppler-devel
openSUSE Leap 42.2
  • libpoppler-cpp0 >= 0.43.0-1.3
  • libpoppler-devel >= 0.43.0-1.3
  • libpoppler-glib8 >= 0.43.0-1.3
  • libpoppler-qt4-4 >= 0.43.0-1.1
  • libpoppler-qt5-1 >= 0.43.0-1.3
  • libpoppler-qt5-devel >= 0.43.0-1.3
  • libpoppler60 >= 0.43.0-1.3
  • poppler-tools >= 0.43.0-1.3
Patchnames:
openSUSE Leap 42.2 GA libpoppler-cpp0
openSUSE Tumbleweed
  • libpoppler-cpp0 >= 0.49.0-1.1
  • libpoppler-cpp0-32bit >= 0.49.0-1.1
  • libpoppler-devel >= 0.49.0-1.1
  • libpoppler-glib-devel >= 0.49.0-1.1
  • libpoppler-glib8 >= 0.49.0-1.1
  • libpoppler-glib8-32bit >= 0.49.0-1.1
  • libpoppler-qt4-4 >= 0.49.0-1.1
  • libpoppler-qt4-4-32bit >= 0.49.0-1.1
  • libpoppler-qt4-devel >= 0.49.0-1.1
  • libpoppler-qt5-1 >= 0.49.0-1.1
  • libpoppler-qt5-1-32bit >= 0.49.0-1.1
  • libpoppler-qt5-devel >= 0.49.0-1.1
  • libpoppler65 >= 0.49.0-1.1
  • libpoppler65-32bit >= 0.49.0-1.1
  • poppler-tools >= 0.49.0-1.1
  • typelib-1_0-Poppler-0_18 >= 0.49.0-1.1
Patchnames:
openSUSE Tumbleweed GA libpoppler-cpp0