Upstream information

CVE-2013-1655 at MITRE

Description

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.48
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 809839 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • puppet >= 2.6.18-0.4.2
Patchnames:
sledsp2-puppet
SUSE Linux Enterprise Server 11 SP2
  • puppet >= 2.6.18-0.4.2
  • puppet-server >= 2.6.18-0.4.2
Patchnames:
slessp2-puppet
SUSE Linux Enterprise Server for VMWare 11 SP2
  • puppet >= 2.6.18-0.4.2
  • puppet-server >= 2.6.18-0.4.2
Patchnames:
slessp2-puppet
SUSE Linux Enterprise Desktop 11 SP2
  • puppet >= 2.6.18-0.4.2
Builds
SAT Patch Nr: 7526
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • puppet >= 2.6.18-0.4.2
  • puppet-server >= 2.6.18-0.4.2
Builds
SAT Patch Nr: 7526
openSUSE 12.3
  • puppet >= 3.0.2-2.5.1
  • puppet-server >= 3.0.2-2.5.1
Patchnames:
openSUSE-2013-295
openSUSE Evergreen 11.4
  • puppet >= 2.6.17-29.1
  • puppet-server >= 2.6.17-29.1
Patchnames:
2013-62