Upstream information

CVE-2013-0773 at MITRE

Description

The Chrome Object Wrapper (COW) and System Only Wrapper (SOW) implementations in Mozilla Firefox before 19.0, Firefox ESR 17.x before 17.0.3, Thunderbird before 17.0.3, Thunderbird ESR 17.x before 17.0.3, and SeaMonkey before 2.16 do not prevent modifications to a prototype, which allows remote attackers to obtain sensitive information from chrome objects or possibly execute arbitrary JavaScript code with chrome privileges via a crafted web site.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 804248 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • MozillaFirefox >= 17.0.3esr-0.4.4.1
  • MozillaFirefox-branding-SLED >= 7-0.6.9.5
  • MozillaFirefox-translations >= 17.0.3esr-0.4.4.1
  • beagle >= 0.3.8-56.51.1
  • beagle-evolution >= 0.3.8-56.51.1
  • beagle-firefox >= 0.3.8-56.51.1
  • beagle-gui >= 0.3.8-56.51.1
  • beagle-lang >= 0.3.8-56.51.1
  • libfreebl3 >= 3.14.2-0.4.3.2
  • libfreebl3-32bit >= 3.14.2-0.4.3.2
  • mhtml-firefox >= 0.5-1.47.51.5
  • mozilla-nspr >= 4.9.5-0.3.2
  • mozilla-nspr-32bit >= 4.9.5-0.3.2
  • mozilla-nss >= 3.14.2-0.4.3.2
  • mozilla-nss-32bit >= 3.14.2-0.4.3.2
  • mozilla-nss-tools >= 3.14.2-0.4.3.2
Patchnames:
sledsp2-firefox-201303
SUSE Linux Enterprise Desktop 12
  • MozillaFirefox >= 31.1.0esr-1.20
  • MozillaFirefox-translations >= 31.1.0esr-1.20
Patchnames:
SUSE Linux Enterprise Desktop 12 GA MozillaFirefox
SUSE Linux Enterprise Desktop 12 SP1
  • MozillaFirefox >= 38.4.0esr-51.1
  • MozillaFirefox-translations >= 38.4.0esr-51.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA MozillaFirefox
SUSE Linux Enterprise Desktop 12 SP2
  • MozillaFirefox >= 45.4.0esr-81.1
  • MozillaFirefox-translations >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA MozillaFirefox
SUSE Linux Enterprise Desktop 12 SP3
  • MozillaFirefox >= 52.2.0esr-108.3
  • MozillaFirefox-translations >= 52.2.0esr-108.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA MozillaFirefox
SUSE Linux Enterprise Server 11 SP2
  • MozillaFirefox >= 17.0.3esr-0.4.4.1
  • MozillaFirefox-branding-SLED >= 7-0.6.9.5
  • MozillaFirefox-translations >= 17.0.3esr-0.4.4.1
  • libfreebl3 >= 3.14.2-0.4.3.2
  • libfreebl3-32bit >= 3.14.2-0.4.3.2
  • libfreebl3-x86 >= 3.14.2-0.4.3.2
  • mozilla-nspr >= 4.9.5-0.3.2
  • mozilla-nspr-32bit >= 4.9.5-0.3.2
  • mozilla-nspr-x86 >= 4.9.5-0.3.2
  • mozilla-nss >= 3.14.2-0.4.3.2
  • mozilla-nss-32bit >= 3.14.2-0.4.3.2
  • mozilla-nss-tools >= 3.14.2-0.4.3.2
  • mozilla-nss-x86 >= 3.14.2-0.4.3.2
Patchnames:
slessp2-firefox-201303
SUSE Linux Enterprise Server 11 SP3
  • MozillaFirefox >= 17.0.4esr-0.10.42
  • MozillaFirefox-translations >= 17.0.4esr-0.10.42
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA MozillaFirefox
SUSE Linux Enterprise Server 11 SP4
  • MozillaFirefox >= 31.7.0esr-0.8.1
  • MozillaFirefox-translations >= 31.7.0esr-0.8.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA MozillaFirefox
SUSE Linux Enterprise Server 12
  • MozillaFirefox >= 31.1.0esr-1.20
  • MozillaFirefox-translations >= 31.1.0esr-1.20
Patchnames:
SUSE Linux Enterprise Server 12 GA MozillaFirefox
SUSE Linux Enterprise Server 12 SP1
  • MozillaFirefox >= 38.4.0esr-51.1
  • MozillaFirefox-translations >= 38.4.0esr-51.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA MozillaFirefox
SUSE Linux Enterprise Server 12 SP2
  • MozillaFirefox >= 45.4.0esr-81.1
  • MozillaFirefox-translations >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA MozillaFirefox
SUSE Linux Enterprise Server 12 SP3
  • MozillaFirefox >= 52.2.0esr-108.3
  • MozillaFirefox-translations >= 52.2.0esr-108.3
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA MozillaFirefox
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • MozillaFirefox >= 45.4.0esr-81.1
  • MozillaFirefox-translations >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA MozillaFirefox
SUSE Linux Enterprise Server for VMWare 11 SP2
  • MozillaFirefox >= 17.0.3esr-0.4.4.1
  • MozillaFirefox-branding-SLED >= 7-0.6.9.5
  • MozillaFirefox-translations >= 17.0.3esr-0.4.4.1
  • libfreebl3 >= 3.14.2-0.4.3.2
  • libfreebl3-32bit >= 3.14.2-0.4.3.2
  • libfreebl3-x86 >= 3.14.2-0.4.3.2
  • mozilla-nspr >= 4.9.5-0.3.2
  • mozilla-nspr-32bit >= 4.9.5-0.3.2
  • mozilla-nspr-x86 >= 4.9.5-0.3.2
  • mozilla-nss >= 3.14.2-0.4.3.2
  • mozilla-nss-32bit >= 3.14.2-0.4.3.2
  • mozilla-nss-tools >= 3.14.2-0.4.3.2
  • mozilla-nss-x86 >= 3.14.2-0.4.3.2
Patchnames:
slessp2-firefox-201303
SUSE Linux Enterprise Software Development Kit 11 SP2
  • beagle >= 0.3.8-56.51.1
  • beagle-devel >= 0.3.8-56.51.1
  • beagle-lang >= 0.3.8-56.44.45.129
  • mozilla-nspr-devel >= 4.9.5-0.3.2
  • mozilla-nss-devel >= 3.14.2-0.4.3.2
Patchnames:
sdksp2-firefox-201303
SUSE Linux Enterprise Software Development Kit 11 SP4
  • MozillaFirefox-devel >= 31.7.0esr-0.8.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA MozillaFirefox-devel
SUSE Linux Enterprise Software Development Kit 12
  • MozillaFirefox-devel >= 31.1.0esr-1.20
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA MozillaFirefox-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • MozillaFirefox-devel >= 38.4.0esr-51.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA MozillaFirefox-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • MozillaFirefox-devel >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA MozillaFirefox-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • MozillaFirefox-devel >= 52.2.0esr-108.3
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA MozillaFirefox-devel
SUSE Linux Enterprise Software Development Kit 11 SP2
  • beagle >= 0.3.8-56.51.1
  • beagle-devel >= 0.3.8-56.51.1
  • beagle-lang >= 0.3.8-56.44.45.129
  • mozilla-nspr-devel >= 4.9.5-0.3.2
  • mozilla-nss-devel >= 3.14.2-0.4.3.2
Builds
SAT Patch Nr: 7447
SUSE Linux Enterprise Software Development Kit 11 SP2
  • beagle >= 0.3.8-56.51.1
  • beagle-lang >= 0.3.8-56.44.45.129
  • mozilla-nspr-devel >= 4.9.5-0.3.2
  • mozilla-nss-devel >= 3.14.2-0.4.3.2
Builds
SAT Patch Nr: 7447
SUSE Linux Enterprise Software Development Kit 11 SP2
  • mozilla-nspr-devel >= 4.9.5-0.3.2
  • mozilla-nss-devel >= 3.14.2-0.4.3.2
Builds
SAT Patch Nr: 7447
SUSE Linux Enterprise Desktop 11 SP2
  • MozillaFirefox >= 17.0.3esr-0.4.4.1
  • MozillaFirefox-branding-SLED >= 7-0.6.9.5
  • MozillaFirefox-translations >= 17.0.3esr-0.4.4.1
  • beagle >= 0.3.8-56.51.1
  • beagle-evolution >= 0.3.8-56.51.1
  • beagle-firefox >= 0.3.8-56.51.1
  • beagle-gui >= 0.3.8-56.51.1
  • beagle-lang >= 0.3.8-56.51.1
  • libfreebl3 >= 3.14.2-0.4.3.2
  • mhtml-firefox >= 0.5-1.47.51.5
  • mozilla-nspr >= 4.9.5-0.3.2
  • mozilla-nss >= 3.14.2-0.4.3.2
  • mozilla-nss-tools >= 3.14.2-0.4.3.2
Builds
SAT Patch Nr: 7447
SUSE Linux Enterprise Desktop 11 SP2
  • MozillaFirefox >= 17.0.3esr-0.4.4.1
  • MozillaFirefox-branding-SLED >= 7-0.6.9.5
  • MozillaFirefox-translations >= 17.0.3esr-0.4.4.1
  • beagle >= 0.3.8-56.51.1
  • beagle-evolution >= 0.3.8-56.51.1
  • beagle-firefox >= 0.3.8-56.51.1
  • beagle-gui >= 0.3.8-56.51.1
  • beagle-lang >= 0.3.8-56.51.1
  • libfreebl3 >= 3.14.2-0.4.3.2
  • libfreebl3-32bit >= 3.14.2-0.4.3.2
  • mhtml-firefox >= 0.5-1.47.51.5
  • mozilla-nspr >= 4.9.5-0.3.2
  • mozilla-nspr-32bit >= 4.9.5-0.3.2
  • mozilla-nss >= 3.14.2-0.4.3.2
  • mozilla-nss-32bit >= 3.14.2-0.4.3.2
  • mozilla-nss-tools >= 3.14.2-0.4.3.2
Builds
SAT Patch Nr: 7447
SUSE Linux Enterprise Server 11 SP2 for VMware
  • MozillaFirefox >= 17.0.3esr-0.4.4.1
  • MozillaFirefox-translations >= 17.0.3esr-0.4.4.1
  • libfreebl3 >= 3.14.2-0.4.3.2
  • mozilla-nspr >= 4.9.5-0.3.2
  • mozilla-nss >= 3.14.2-0.4.3.2
  • mozilla-nss-tools >= 3.14.2-0.4.3.2
Builds
SAT Patch Nr: 7447
SUSE Linux Enterprise Server 11 SP2 for VMware
  • MozillaFirefox >= 17.0.3esr-0.4.4.1
  • MozillaFirefox-translations >= 17.0.3esr-0.4.4.1
  • libfreebl3 >= 3.14.2-0.4.3.2
  • libfreebl3-32bit >= 3.14.2-0.4.3.2
  • mozilla-nspr >= 4.9.5-0.3.2
  • mozilla-nspr-32bit >= 4.9.5-0.3.2
  • mozilla-nss >= 3.14.2-0.4.3.2
  • mozilla-nss-32bit >= 3.14.2-0.4.3.2
  • mozilla-nss-tools >= 3.14.2-0.4.3.2
Builds
SAT Patch Nr: 7447
SUSE Linux Enterprise Server 11 SP2
  • MozillaFirefox >= 17.0.3esr-0.4.4.1
  • MozillaFirefox-branding-SLED >= 7-0.6.9.5
  • MozillaFirefox-translations >= 17.0.3esr-0.4.4.1
  • libfreebl3 >= 3.14.2-0.4.3.2
  • mozilla-nspr >= 4.9.5-0.3.2
  • mozilla-nss >= 3.14.2-0.4.3.2
  • mozilla-nss-tools >= 3.14.2-0.4.3.2
Builds
SAT Patch Nr: 7447
SUSE Linux Enterprise Server 11 SP2
  • MozillaFirefox >= 17.0.3esr-0.4.4.1
  • MozillaFirefox-branding-SLED >= 7-0.6.9.5
  • MozillaFirefox-translations >= 17.0.3esr-0.4.4.1
  • libfreebl3 >= 3.14.2-0.4.3.2
  • libfreebl3-x86 >= 3.14.2-0.4.3.2
  • mozilla-nspr >= 4.9.5-0.3.2
  • mozilla-nspr-x86 >= 4.9.5-0.3.2
  • mozilla-nss >= 3.14.2-0.4.3.2
  • mozilla-nss-tools >= 3.14.2-0.4.3.2
  • mozilla-nss-x86 >= 3.14.2-0.4.3.2
Builds
SAT Patch Nr: 7447
SUSE Linux Enterprise Server 11 SP2
  • MozillaFirefox >= 17.0.3esr-0.4.4.1
  • MozillaFirefox-branding-SLED >= 7-0.6.9.5
  • MozillaFirefox-translations >= 17.0.3esr-0.4.4.1
  • libfreebl3 >= 3.14.2-0.4.3.2
  • libfreebl3-32bit >= 3.14.2-0.4.3.2
  • mozilla-nspr >= 4.9.5-0.3.2
  • mozilla-nspr-32bit >= 4.9.5-0.3.2
  • mozilla-nss >= 3.14.2-0.4.3.2
  • mozilla-nss-32bit >= 3.14.2-0.4.3.2
  • mozilla-nss-tools >= 3.14.2-0.4.3.2
Builds
SAT Patch Nr: 7447
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • MozillaFirefox >= 17.0.4esr-0.7.1
  • MozillaFirefox-branding-SLED >= 7-0.10.4
  • MozillaFirefox-translations >= 17.0.4esr-0.7.1
  • mhtml-firefox >= 0.5-1.13.4
  • mozilla-nspr >= 4.9.4-0.6.3
  • mozilla-nspr-devel >= 4.9.4-0.6.3
  • mozilla-nss >= 3.14.1-0.6.3
  • mozilla-nss-devel >= 3.14.1-0.6.3
  • mozilla-nss-tools >= 3.14.1-0.6.3
Builds
ZYPP Patch Nr: 8506
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
  • MozillaFirefox >= 17.0.4esr-0.7.1
  • MozillaFirefox-branding-SLED >= 7-0.10.4
  • MozillaFirefox-translations >= 17.0.4esr-0.7.1
  • mhtml-firefox >= 0.5-1.13.4
  • mozilla-nspr >= 4.9.4-0.6.3
  • mozilla-nspr-32bit >= 4.9.4-0.6.3
  • mozilla-nspr-devel >= 4.9.4-0.6.3
  • mozilla-nss >= 3.14.1-0.6.3
  • mozilla-nss-32bit >= 3.14.1-0.6.3
  • mozilla-nss-devel >= 3.14.1-0.6.3
  • mozilla-nss-tools >= 3.14.1-0.6.3
Builds
ZYPP Patch Nr: 8506
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • MozillaFirefox-branding-upstream >= 17.0.4esr-0.7.1
  • firefox3-python-base >= 2.6.8-0.9.1
  • mozilla-nss-tools >= 3.14.1-0.6.3
Builds
ZYPP Patch Nr: 8506
SUSE Linux Enterprise Server 10 SP4 for x86
  • MozillaFirefox >= 17.0.4esr-0.7.1
  • MozillaFirefox-branding-SLED >= 7-0.10.4
  • MozillaFirefox-translations >= 17.0.4esr-0.7.1
  • mozilla-nspr >= 4.9.4-0.6.3
  • mozilla-nspr-devel >= 4.9.4-0.6.3
  • mozilla-nss >= 3.14.1-0.6.3
  • mozilla-nss-devel >= 3.14.1-0.6.3
  • mozilla-nss-tools >= 3.14.1-0.6.3
Builds
ZYPP Patch Nr: 8506
SUSE Linux Enterprise Server 10 SP4 for IPF
  • MozillaFirefox >= 17.0.4esr-0.7.1
  • MozillaFirefox-branding-SLED >= 7-0.10.4
  • MozillaFirefox-translations >= 17.0.4esr-0.7.1
  • mozilla-nspr >= 4.9.4-0.6.3
  • mozilla-nspr-devel >= 4.9.4-0.6.3
  • mozilla-nspr-x86 >= 4.9.4-0.6.3
  • mozilla-nss >= 3.14.1-0.6.3
  • mozilla-nss-devel >= 3.14.1-0.6.3
  • mozilla-nss-tools >= 3.14.1-0.6.3
  • mozilla-nss-x86 >= 3.14.1-0.6.3
Builds
ZYPP Patch Nr: 8506
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • MozillaFirefox >= 17.0.4esr-0.7.1
  • MozillaFirefox-branding-SLED >= 7-0.10.4
  • MozillaFirefox-translations >= 17.0.4esr-0.7.1
  • mozilla-nspr >= 4.9.4-0.6.3
  • mozilla-nspr-64bit >= 4.9.4-0.6.3
  • mozilla-nspr-devel >= 4.9.4-0.6.3
  • mozilla-nss >= 3.14.1-0.6.3
  • mozilla-nss-64bit >= 3.14.1-0.6.3
  • mozilla-nss-devel >= 3.14.1-0.6.3
  • mozilla-nss-tools >= 3.14.1-0.6.3
Builds
ZYPP Patch Nr: 8506
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • MozillaFirefox >= 17.0.4esr-0.7.1
  • MozillaFirefox-branding-SLED >= 7-0.10.4
  • MozillaFirefox-translations >= 17.0.4esr-0.7.1
  • mozilla-nspr >= 4.9.4-0.6.3
  • mozilla-nspr-32bit >= 4.9.4-0.6.3
  • mozilla-nspr-devel >= 4.9.4-0.6.3
  • mozilla-nss >= 3.14.1-0.6.3
  • mozilla-nss-32bit >= 3.14.1-0.6.3
  • mozilla-nss-devel >= 3.14.1-0.6.3
  • mozilla-nss-tools >= 3.14.1-0.6.3
Builds
ZYPP Patch Nr: 8506
openSUSE Leap 42.1
  • MozillaFirefox >= 41.0.2-1.2
  • MozillaFirefox-translations-common >= 41.0.2-1.2
  • MozillaThunderbird >= 38.3.0-2.2
  • MozillaThunderbird-translations-common >= 38.3.0-2.2
Patchnames:
openSUSE Leap 42.1 GA MozillaFirefox
openSUSE Leap 42.1 GA MozillaThunderbird
openSUSE Leap 42.2
  • MozillaFirefox >= 49.0.2-37.1
  • MozillaFirefox-translations-common >= 49.0.2-37.1
  • MozillaThunderbird >= 45.4.0-23.1
  • MozillaThunderbird-translations-common >= 45.4.0-23.1
Patchnames:
openSUSE Leap 42.2 GA MozillaFirefox
openSUSE Leap 42.2 GA MozillaThunderbird
openSUSE Leap 42.3
  • MozillaFirefox >= 52.2-58.2
  • MozillaFirefox-translations-common >= 52.2-58.2
  • MozillaThunderbird >= 52.2.1-42.1
  • MozillaThunderbird-translations-common >= 52.2.1-42.1
Patchnames:
openSUSE Leap 42.3 GA MozillaFirefox
openSUSE Leap 42.3 GA MozillaThunderbird
openSUSE Tumbleweed
  • MozillaFirefox >= 50.1.0-1.1
  • MozillaFirefox-branding-upstream >= 50.1.0-1.1
  • MozillaFirefox-buildsymbols >= 50.1.0-1.1
  • MozillaFirefox-devel >= 50.1.0-1.1
  • MozillaFirefox-translations-common >= 50.1.0-1.1
  • MozillaFirefox-translations-other >= 50.1.0-1.1
  • MozillaThunderbird >= 45.5.1-1.1
  • MozillaThunderbird-buildsymbols >= 45.5.1-1.1
  • MozillaThunderbird-devel >= 45.5.1-1.1
  • MozillaThunderbird-translations-common >= 45.5.1-1.1
  • MozillaThunderbird-translations-other >= 45.5.1-1.1
  • seamonkey >= 2.40-6.1
  • seamonkey-dom-inspector >= 2.40-6.1
  • seamonkey-irc >= 2.40-6.1
  • seamonkey-translations-common >= 2.40-6.1
  • seamonkey-translations-other >= 2.40-6.1
Patchnames:
openSUSE Tumbleweed GA MozillaFirefox
openSUSE Tumbleweed GA MozillaThunderbird
openSUSE Tumbleweed GA seamonkey


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 MozillaFirefox Affected
SUSE Linux Enterprise Desktop 10 SP4 MozillaFirefox Affected
SUSE Linux Enterprise Desktop 11 SP1 MozillaFirefox Released
SUSE Linux Enterprise Desktop 11 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server 10 SP3 MozillaFirefox Affected
SUSE Linux Enterprise Server 10 SP4 MozillaFirefox Affected
SUSE Linux Enterprise Server 10 SP4 LTSS MozillaFirefox Affected
SUSE Linux Enterprise Server 11 SP1 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP1 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP2 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 MozillaFirefox Released
SUSE Linux Enterprise Server for VMWare 11 SP2 MozillaFirefox Released