Upstream information

CVE-2013-0292 at MITRE

Description

The dbus_g_proxy_manager_filter function in dbus-gproxy in Dbus-glib before 0.100.1 does not properly verify the sender of NameOwnerChanged signals, which allows local users to gain privileges via a spoofed signal.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 792095 [RESOLVED / FIXED], 804392 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • dbus-1-glib >= 0.100.2-3.58
  • dbus-1-glib-32bit >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Desktop 12 GA dbus-1-glib
SUSE Linux Enterprise Desktop 12 SP1
  • dbus-1-glib >= 0.100.2-3.58
  • dbus-1-glib-32bit >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA dbus-1-glib
SUSE Linux Enterprise Desktop 12 SP2
  • dbus-1-glib >= 0.100.2-3.58
  • dbus-1-glib-32bit >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA dbus-1-glib
SUSE Linux Enterprise Desktop 12 SP3
  • dbus-1-glib >= 0.100.2-3.58
  • dbus-1-glib-32bit >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA dbus-1-glib
SUSE Linux Enterprise Module for Basesystem 15
  • dbus-1-glib >= 0.108-1.29
  • dbus-1-glib-32bit >= 0.108-1.29
  • dbus-1-glib-devel >= 0.108-1.29
  • dbus-1-glib-tool >= 0.108-1.29
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA dbus-1-glib
SUSE Linux Enterprise Server 12
  • dbus-1-glib >= 0.100.2-3.58
  • dbus-1-glib-32bit >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Server 12 GA dbus-1-glib
SUSE Linux Enterprise Server 12 SP1
  • dbus-1-glib >= 0.100.2-3.58
  • dbus-1-glib-32bit >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA dbus-1-glib
SUSE Linux Enterprise Server 12 SP2
  • dbus-1-glib >= 0.100.2-3.58
  • dbus-1-glib-32bit >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA dbus-1-glib
SUSE Linux Enterprise Server 12 SP3
  • dbus-1-glib >= 0.100.2-3.58
  • dbus-1-glib-32bit >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA dbus-1-glib
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • dbus-1-glib >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA dbus-1-glib
SUSE Linux Enterprise Software Development Kit 12
  • dbus-1-glib-devel >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA dbus-1-glib-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • dbus-1-glib-devel >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA dbus-1-glib-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • dbus-1-glib-devel >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA dbus-1-glib-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • dbus-1-glib-devel >= 0.100.2-3.58
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA dbus-1-glib-devel
openSUSE Leap 15.0
  • dbus-1-glib >= 0.108-lp150.1.6
  • dbus-1-glib-tool >= 0.108-lp150.1.6
Patchnames:
openSUSE Leap 15.0 GA dbus-1-glib
openSUSE Leap 42.1
  • dbus-1-glib >= 0.100.2-3.2
  • dbus-1-glib-32bit >= 0.100.2-3.2
  • dbus-1-glib-devel >= 0.100.2-3.2
Patchnames:
openSUSE Leap 42.1 GA dbus-1-glib
openSUSE Leap 42.2
  • dbus-1-glib >= 0.100.2-4.7
  • dbus-1-glib-32bit >= 0.100.2-4.7
  • dbus-1-glib-devel >= 0.100.2-4.7
Patchnames:
openSUSE Leap 42.2 GA dbus-1-glib
openSUSE Leap 42.3
  • dbus-1-glib >= 0.100.2-6.3
  • dbus-1-glib-32bit >= 0.100.2-6.3
  • dbus-1-glib-devel >= 0.100.2-6.3
Patchnames:
openSUSE Leap 42.3 GA dbus-1-glib
openSUSE Tumbleweed
  • dbus-1-glib >= 0.108-2.1
  • dbus-1-glib-32bit >= 0.108-2.1
  • dbus-1-glib-devel >= 0.108-2.1
  • dbus-1-glib-devel-32bit >= 0.108-2.1
  • dbus-1-glib-doc >= 0.108-2.1
  • dbus-1-glib-tool >= 0.108-2.1
Patchnames:
openSUSE Tumbleweed GA dbus-1-glib