Upstream information

CVE-2012-6684 at MITRE

Description

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 912212 [RESOLVED], 912316

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • rubygem-RedCloth >= 4.2.9-4.3.1
  • rubygem-RedCloth-debuginfo >= 4.2.9-4.3.1
  • rubygem-RedCloth-debugsource >= 4.2.9-4.3.1
  • rubygem-RedCloth-doc >= 4.2.9-4.3.1
  • rubygem-RedCloth-testsuite >= 4.2.9-4.3.1
Patchnames:
openSUSE-2015-457
openSUSE Tumbleweed
  • ruby2.2-rubygem-RedCloth >= 4.3.2-1.5
  • ruby2.2-rubygem-RedCloth-doc >= 4.3.2-1.5
  • ruby2.2-rubygem-RedCloth-testsuite >= 4.3.2-1.5
  • ruby2.3-rubygem-RedCloth >= 4.3.2-1.5
  • ruby2.3-rubygem-RedCloth-doc >= 4.3.2-1.5
  • ruby2.3-rubygem-RedCloth-testsuite >= 4.3.2-1.5
Patchnames:
openSUSE Tumbleweed GA ruby2.2-rubygem-RedCloth