Upstream information

CVE-2012-4433 at MITRE

Description

Multiple integer overflows in operations/external/ppm-load.c in GEGL (Generic Graphics Library) 0.2.0 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a large (1) width or (2) height value in a Portable Pixel Map (ppm) image, which triggers a heap-based buffer overflow.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.48 6.82
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
SUSE Bugzilla entries: 1023636 [RESOLVED / DUPLICATE], 1028070 [RESOLVED / FIXED], 789835 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • gegl >= 0.2.0-10.3.3
  • gegl-0_2 >= 0.2.0-10.3.3
  • gegl-0_2-lang >= 0.2.0-10.3.3
  • libgegl-0_2-0 >= 0.2.0-10.3.3
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-377
SUSE Linux Enterprise Desktop 12 SP2
  • gegl >= 0.2.0-14.3
  • gegl-0_2 >= 0.2.0-14.3
  • gegl-0_2-lang >= 0.2.0-14.3
  • libgegl-0_2-0 >= 0.2.0-14.3
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-378
SUSE Linux Enterprise Software Development Kit 12 SP1
  • gegl >= 0.2.0-10.3.3
  • gegl-devel >= 0.2.0-10.3.3
  • libgegl-0_2-0 >= 0.2.0-10.3.3
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-377
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gegl >= 0.2.0-14.3
  • gegl-devel >= 0.2.0-14.3
  • libgegl-0_2-0 >= 0.2.0-14.3
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-378
SUSE Linux Enterprise Workstation Extension 12 SP1
  • gegl >= 0.2.0-10.3.3
  • gegl-0_2 >= 0.2.0-10.3.3
  • gegl-0_2-lang >= 0.2.0-10.3.3
  • libgegl-0_2-0 >= 0.2.0-10.3.3
Patchnames:
SUSE-SLE-WE-12-SP1-2017-377
SUSE Linux Enterprise Workstation Extension 12 SP2
  • gegl >= 0.2.0-14.3
  • gegl-0_2 >= 0.2.0-14.3
  • gegl-0_2-lang >= 0.2.0-14.3
  • libgegl-0_2-0 >= 0.2.0-14.3
Patchnames:
SUSE-SLE-WE-12-SP2-2017-378
openSUSE Evergreen 11.4
  • gegl >= 0.1.2-10.1
  • gegl-0_1 >= 0.1.2-10.1
  • gegl-0_1-debuginfo >= 0.1.2-10.1
  • gegl-debuginfo >= 0.1.2-10.1
  • gegl-debugsource >= 0.1.2-10.1
  • gegl-devel >= 0.1.2-10.1
  • gegl-doc >= 0.1.2-10.1
  • libgegl-0_1-0 >= 0.1.2-10.1
  • libgegl-0_1-0-debuginfo >= 0.1.2-10.1
Patchnames:
2012-16