Upstream information

CVE-2012-3866 at MITRE

Description

lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 770827 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • puppet >= 3.6.2-3.62
Patchnames:
SUSE Linux Enterprise Desktop 12 GA puppet
SUSE Linux Enterprise Desktop 12 SP1
  • puppet >= 3.6.2-3.62
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA puppet
SUSE Linux Enterprise Desktop 12 SP2
  • puppet >= 3.8.5-5.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA puppet
SUSE Linux Enterprise Desktop 12 SP3
  • puppet >= 3.8.5-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA puppet
SUSE Linux Enterprise Module for Advanced Systems Management 12
  • puppet >= 3.6.2-3.62
  • puppet-server >= 3.6.2-3.62
Patchnames:
SUSE Linux Enterprise Module for Advanced Systems Management 12 GA puppet
openSUSE 11.4
  • puppet >= 2.6.17-26.1
  • puppet-server >= 2.6.17-26.1
Patchnames:
openSUSE-2012-407
openSUSE Tumbleweed
  • ruby2.2-rubygem-puppet >= 3.8.7-2.2
  • ruby2.2-rubygem-puppet-doc >= 3.8.7-2.2
  • ruby2.2-rubygem-puppet-testsuite >= 3.8.7-2.2
  • ruby2.3-rubygem-puppet >= 3.8.7-2.2
  • ruby2.3-rubygem-puppet-doc >= 3.8.7-2.2
  • ruby2.3-rubygem-puppet-testsuite >= 3.8.7-2.2
  • rubygem-puppet >= 3.8.7-2.2
  • rubygem-puppet-emacs >= 3.8.7-2.2
  • rubygem-puppet-master >= 3.8.7-2.2
  • rubygem-puppet-master-unicorn >= 3.8.7-2.2
  • rubygem-puppet-vim >= 3.8.7-2.2
Patchnames:
openSUSE Tumbleweed GA ruby2.2-rubygem-puppet


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 puppet Released
SUSE Linux Enterprise Server 11 SP1 puppet Released
SUSE Linux Enterprise Server 11 SP1 LTSS puppet Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 puppet Released