Upstream information

CVE-2012-3535 at MITRE

Description

Heap-based buffer overflow in OpenJPEG 1.5.0 and earlier allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted JPEG2000 file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 777445 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • libopenjpeg1 >= 1.5.2-3.4
Patchnames:
openSUSE Leap 42.1 GA libopenjpeg1
openSUSE Leap 42.2
  • libopenjpeg1 >= 1.5.2-6.1
Patchnames:
openSUSE Leap 42.2 GA libopenjpeg1
openSUSE Leap 42.3
  • libopenjpeg1 >= 1.5.2-8.3
Patchnames:
openSUSE Leap 42.3 GA libopenjpeg1
openSUSE Tumbleweed
  • libopenjpeg1 >= 1.5.2-4.7
  • libopenjpeg1-32bit >= 1.5.2-4.7
  • openjpeg >= 1.5.2-4.7
  • openjpeg-devel >= 1.5.2-4.7
  • openjpeg-devel-32bit >= 1.5.2-4.7
Patchnames:
openSUSE Tumbleweed GA libopenjpeg1