Upstream information

CVE-2012-3423 at MITRE

Description

The IcedTea-Web plugin before 1.2.1 does not properly handle NPVariant NPStrings without NUL terminators, which allows remote attackers to cause a denial of service (crash), obtain sensitive information from memory, or execute arbitrary code via a crafted Java applet.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 773458 [RESOLVED / FIXED], 818768 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • icedtea-web >= 1.4-0.5.1
Patchnames:
sledsp2-icedtea-web
SUSE Linux Enterprise Desktop 11 SP3
  • icedtea-web >= 1.4-0.10.1
Patchnames:
sledsp3-icedtea-web
SUSE Linux Enterprise Desktop 12
  • java-1_7_0-openjdk-plugin >= 1.5.1-1.13
Patchnames:
SUSE Linux Enterprise Desktop 12 GA java-1_7_0-openjdk-plugin
SUSE Linux Enterprise Desktop 12 SP1
  • java-1_7_0-openjdk-plugin >= 1.6.1-2.3.1
  • java-1_8_0-openjdk-plugin >= 1.6.1-2.4.21
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA java-1_7_0-openjdk-plugin
SUSE Linux Enterprise Desktop 12 SP2
  • java-1_7_0-openjdk-plugin >= 1.6.1-2.3.1
  • java-1_8_0-openjdk-plugin >= 1.6.1-2.4.21
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA java-1_7_0-openjdk-plugin
SUSE Linux Enterprise Desktop 12 SP3
  • java-1_7_0-openjdk-plugin >= 1.6.2-2.8.3
  • java-1_8_0-openjdk-plugin >= 1.6.2-2.10.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA java-1_7_0-openjdk-plugin
SUSE Linux Enterprise Workstation Extension 12
  • java-1_7_0-openjdk-plugin >= 1.5.1-1.13
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 GA java-1_7_0-openjdk-plugin
SUSE Linux Enterprise Workstation Extension 12 SP1
  • java-1_7_0-openjdk-plugin >= 1.6.1-2.3.1
  • java-1_8_0-openjdk-plugin >= 1.6.1-2.4.21
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA java-1_7_0-openjdk-plugin
SUSE Linux Enterprise Workstation Extension 12 SP2
  • java-1_7_0-openjdk-plugin >= 1.6.1-2.3.1
  • java-1_8_0-openjdk-plugin >= 1.6.1-2.4.21
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA java-1_7_0-openjdk-plugin
SUSE Linux Enterprise Workstation Extension 12 SP3
  • java-1_7_0-openjdk-plugin >= 1.6.2-2.8.3
  • java-1_8_0-openjdk-plugin >= 1.6.2-2.10.3
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA java-1_7_0-openjdk-plugin
SUSE Linux Enterprise Desktop 11 SP2
  • icedtea-web >= 1.4-0.5.1
Builds
SAT Patch Nr: 7742
SUSE Linux Enterprise Desktop 11 SP1
  • icedtea-web >= 1.2.1-0.2.1
sled11-sp1.x86-64
sled11-sp1.x86
SAT Patch Nr: 6621
SUSE Linux Enterprise Desktop 11 SP2
  • icedtea-web >= 1.2.1-0.7.1
sled11-sp2.x86
sled11-sp2.x86-64
SAT Patch Nr: 6626
SUSE Linux Enterprise Desktop 11 SP3
  • icedtea-web >= 1.4-0.10.1
Builds
SAT Patch Nr: 7981
openSUSE 11.4
  • icedtea-web >= 1.2.1-0.17.1
  • icedtea-web-debuginfo >= 1.2.1-0.17.1
  • icedtea-web-debugsource >= 1.2.1-0.17.1
  • icedtea-web-javadoc >= 1.2.1-0.17.1
Patchnames:
openSUSE-2012-512
openSUSE-2012-513
openSUSE 12.3
  • icedtea-web >= 1.4-4.14.1
  • icedtea-web-debuginfo >= 1.4-4.14.1
  • icedtea-web-debugsource >= 1.4-4.14.1
  • icedtea-web-javadoc >= 1.4-4.14.1
Patchnames:
openSUSE-2013-439
openSUSE Leap 42.1
  • icedtea-web-javadoc >= 1.6.1-1.2
  • java-1_8_0-openjdk-plugin >= 1.6.1-1.2
Patchnames:
openSUSE Leap 42.1 GA icedtea-web-javadoc
openSUSE Leap 42.2
  • icedtea-web-javadoc >= 1.6.1-2.37
  • java-1_8_0-openjdk-plugin >= 1.6.1-2.35
Patchnames:
openSUSE Leap 42.2 GA icedtea-web-javadoc
openSUSE Leap 42.3
  • icedtea-web-javadoc >= 1.6.2-4.1
  • java-1_8_0-openjdk-plugin >= 1.6.2-4.1
Patchnames:
openSUSE Leap 42.3 GA icedtea-web-javadoc
openSUSE Tumbleweed
  • icedtea-web-javadoc >= 1.6.2-3.3
  • java-1_7_0-openjdk-plugin >= 1.6.2-3.3
  • java-1_8_0-openjdk-plugin >= 1.6.2-3.3
Patchnames:
openSUSE Tumbleweed GA icedtea-web-javadoc


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 icedtea-web Affected
SUSE Linux Enterprise Desktop 11 SP2 icedtea-web Released
SUSE Linux Enterprise Desktop 11 SP3 icedtea-web Released