Upstream information

CVE-2012-2934 at MITRE

Description

Xen 4.0, and 4.1, when running a 64-bit PV guest on "older" AMD CPUs, does not properly protect against a certain AMD processor bug, which allows local guest OS users to cause a denial of service (host hang) via sequential execution of instructions across a non-canonical boundary, a different vulnerability than CVE-2012-0217.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 1.9
Vector AV:L/AC:M/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 764077 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • libvirt >= 0.9.6-0.15.71
  • libvirt-client >= 0.9.6-0.15.71
  • libvirt-client-32bit >= 0.9.6-0.15.71
  • libvirt-doc >= 0.9.6-0.15.71
  • libvirt-python >= 0.9.6-0.15.71
  • virt-manager >= 0.9.0-3.17.26
  • virt-utils >= 1.1.7-0.11.15
  • vm-install >= 0.5.9-0.7.13
  • xen >= 4.1.2_18-0.9.1
  • xen-doc-html >= 4.1.2_18-0.9.1
  • xen-doc-pdf >= 4.1.2_18-0.9.1
  • xen-kmp-default >= 4.1.2_18_3.0.31_0.9-0.9.1
  • xen-kmp-pae >= 4.1.2_18_3.0.31_0.9-0.9.1
  • xen-kmp-trace >= 4.1.2_18_3.0.31_0.9-0.9.1
  • xen-libs >= 4.1.2_18-0.9.1
  • xen-libs-32bit >= 4.1.2_18-0.9.1
  • xen-tools >= 4.1.2_18-0.9.1
  • xen-tools-domU >= 4.1.2_18-0.9.1
  • yast2-vm >= 2.17.10-0.5.42
Patchnames:
sledsp2-xen-201206
SUSE Linux Enterprise Server 11 SP1
  • xen >= 4.0.3_21548_04-0.9.1
  • xen-doc-html >= 4.0.3_21548_04-0.9.1
  • xen-doc-pdf >= 4.0.3_21548_04-0.9.1
  • xen-kmp-default >= 4.0.3_21548_04_2.6.32.59_0.5-0.9.1
  • xen-kmp-pae >= 4.0.3_21548_04_2.6.32.59_0.5-0.9.1
  • xen-kmp-trace >= 4.0.3_21548_04_2.6.32.59_0.5-0.9.1
  • xen-libs >= 4.0.3_21548_04-0.9.1
  • xen-tools >= 4.0.3_21548_04-0.9.1
  • xen-tools-domU >= 4.0.3_21548_04-0.9.1
Patchnames:
slessp1-xen-201206
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server for SAP Applications 11 SP2
  • libvirt >= 0.9.6-0.15.71
  • libvirt-client >= 0.9.6-0.15.71
  • libvirt-client-32bit >= 0.9.6-0.15.71
  • libvirt-doc >= 0.9.6-0.15.71
  • libvirt-python >= 0.9.6-0.15.71
  • virt-manager >= 0.9.0-3.17.26
  • virt-utils >= 1.1.7-0.11.15
  • vm-install >= 0.5.9-0.7.13
  • xen >= 4.1.2_18-0.9.1
  • xen-doc-html >= 4.1.2_18-0.9.1
  • xen-doc-pdf >= 4.1.2_18-0.9.1
  • xen-kmp-default >= 4.1.2_18_3.0.31_0.9-0.9.1
  • xen-kmp-pae >= 4.1.2_18_3.0.31_0.9-0.9.1
  • xen-kmp-trace >= 4.1.2_18_3.0.31_0.9-0.9.1
  • xen-libs >= 4.1.2_18-0.9.1
  • xen-libs-32bit >= 4.1.2_18-0.9.1
  • xen-tools >= 4.1.2_18-0.9.1
  • xen-tools-domU >= 4.1.2_18-0.9.1
  • yast2-vm >= 2.17.10-0.5.42
Patchnames:
slessp2-xen-201206
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libvirt-devel >= 0.9.6-0.15.71
  • libvirt-devel-32bit >= 0.9.6-0.15.71
  • xen-devel >= 4.1.2_18-0.9.1
Patchnames:
sdksp2-xen-201206
openSUSE 11.4
  • xen >= 4.0.3_04-42.4
  • xen-debugsource >= 4.0.3_04-42.4
  • xen-devel >= 4.0.3_04-42.4
  • xen-doc-html >= 4.0.3_04-42.4
  • xen-doc-pdf >= 4.0.3_04-42.4
  • xen-kmp-default >= 4.0.3_04_k2.6.37.6_0.20-42.4
  • xen-kmp-default-debuginfo >= 4.0.3_04_k2.6.37.6_0.20-42.4
  • xen-kmp-desktop >= 4.0.3_04_k2.6.37.6_0.20-42.4
  • xen-kmp-desktop-debuginfo >= 4.0.3_04_k2.6.37.6_0.20-42.4
  • xen-kmp-pae >= 4.0.3_04_k2.6.37.6_0.20-42.4
  • xen-kmp-pae-debuginfo >= 4.0.3_04_k2.6.37.6_0.20-42.4
  • xen-libs >= 4.0.3_04-42.4
  • xen-libs-debuginfo >= 4.0.3_04-42.4
  • xen-tools >= 4.0.3_04-42.4
  • xen-tools-debuginfo >= 4.0.3_04-42.4
  • xen-tools-domU >= 4.0.3_04-42.4
  • xen-tools-domU-debuginfo >= 4.0.3_04-42.4
Patchnames:
openSUSE-2012-404


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 xen Released
SLED-10-SP4 xen Released
SLES-10-SP3 xen Released
SLES-10-SP4 xen Released
SLES_LTSS-10-SP4 xen Released
SUSE Linux Enterprise Desktop 11 SP1 xen Released
SUSE Linux Enterprise Desktop 11 SP2 xen Affected
SUSE Linux Enterprise Server 11 SP1 xen Released
SUSE Linux Enterprise Server 11 SP1 LTSS xen Released
SUSE Linux Enterprise Server 11 SP2 xen Affected
SUSE Linux Enterprise Server 11 SP2 LTSS xen Affected
SUSE Linux Enterprise Server 11 SP2 for VMware xen Affected
SUSE Linux Enterprise Server for SAP Business All-in-One xen Released
SUSE Linux Enterprise Software Development Kit 11 SP1 xen Released
SUSE Linux Enterprise Software Development Kit 11 SP2 xen Affected