Upstream information

CVE-2012-2118 at MITRE

Description

Format string vulnerability in the LogVHdrMessageVerb function in os/log.c in X.Org X11 1.11 allows attackers to cause a denial of service or possibly execute arbitrary code via format string specifiers in an input device name.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete

Note from the SUSE Security Team

This issue was introduced during X.Org XServer 1.11 development and only affects this and later versions. We did not ship this in our products yet, so we are not affected by this problem.

SUSE Bugzilla entry: 758223 [RESOLVED / FIXED]

SUSE Security Advisories:
  • TID7021676, published Sa 3. Mär 10:24:18 CET 2018
  • TID7021823, published Sa 3. Mär 10:24:20 CET 2018