Upstream information

CVE-2012-1571 at MITRE

Description

file before 5.11 and libmagic allow remote attackers to cause a denial of service (crash) via a crafted Composite Document File (CDF) file that triggers (1) an out-of-bounds read or (2) an invalid pointer dereference.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 753303 [RESOLVED / FIXED], 883306 [RESOLVED], 884986 [RESOLVED / FIXED], 987530 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • file >= 5.19-2.149
  • file-magic >= 5.19-2.149
  • libmagic1 >= 5.19-2.149
  • libmagic1-32bit >= 5.19-2.149
Patchnames:
SUSE Linux Enterprise Desktop 12 GA file
SUSE Linux Enterprise Desktop 12 SP1
  • file >= 5.19-9.1
  • file-magic >= 5.19-9.1
  • libmagic1 >= 5.19-9.1
  • libmagic1-32bit >= 5.19-9.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA file
SUSE Linux Enterprise Desktop 12 SP2
  • file >= 5.19-9.1
  • file-magic >= 5.19-9.1
  • libmagic1 >= 5.19-9.1
  • libmagic1-32bit >= 5.19-9.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA file
SUSE Linux Enterprise Desktop 12 SP3
  • file >= 5.19-9.1
  • file-magic >= 5.19-9.1
  • libmagic1 >= 5.19-9.1
  • libmagic1-32bit >= 5.19-9.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA file
SUSE Linux Enterprise Module for Basesystem 15
  • file >= 5.32-5.22
  • file-devel >= 5.32-5.22
  • file-magic >= 5.32-5.22
  • libmagic1 >= 5.32-5.22
  • libmagic1-32bit >= 5.32-5.22
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA file
SUSE Linux Enterprise Server 12
  • file >= 5.19-2.32
  • file-magic >= 5.19-2.32
  • libmagic1 >= 5.19-2.32
  • libmagic1-32bit >= 5.19-2.149
Patchnames:
SUSE Linux Enterprise Server 12 GA file
SUSE Linux Enterprise Server 12 SP1
  • file >= 5.19-9.1
  • file-magic >= 5.19-9.1
  • libmagic1 >= 5.19-9.1
  • libmagic1-32bit >= 5.19-9.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA file
SUSE Linux Enterprise Server 12 SP2
  • file >= 5.19-9.1
  • file-magic >= 5.19-9.1
  • libmagic1 >= 5.19-9.1
  • libmagic1-32bit >= 5.19-9.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA file
SUSE Linux Enterprise Server 12 SP3
  • file >= 5.19-9.1
  • file-magic >= 5.19-9.1
  • libmagic1 >= 5.19-9.1
  • libmagic1-32bit >= 5.19-9.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA file
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • file >= 5.19-9.1
  • file-magic >= 5.19-9.1
  • libmagic1 >= 5.19-9.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA file
SUSE Linux Enterprise Software Development Kit 12
  • file-devel >= 5.19-2.149
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA file-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • file-devel >= 5.19-9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA file-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • file-devel >= 5.19-9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA file-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • file-devel >= 5.19-9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA file-devel
openSUSE 11.4
  • file >= 5.04-13.1
  • file-32bit >= 5.04-13.1
  • file-debuginfo >= 5.04-13.1
  • file-debuginfo-32bit >= 5.04-13.1
  • file-debugsource >= 5.04-13.1
  • file-devel >= 5.04-13.1
  • python-magic >= 5.04-13.1
  • python-magic-debuginfo >= 5.04-13.1
  • python-magic-debugsource >= 5.04-13.1
Patchnames:
openSUSE-2012-221
openSUSE Leap 15.0
  • file >= 5.32-lp150.5.17
  • file-magic >= 5.32-lp150.5.17
  • libmagic1 >= 5.32-lp150.5.17
  • libmagic1-32bit >= 5.32-lp150.5.17
Patchnames:
openSUSE Leap 15.0 GA file
openSUSE Leap 42.1
  • file >= 5.19-5.5
  • file-devel >= 5.19-5.5
  • file-magic >= 5.19-5.5
  • libmagic1 >= 5.19-5.5
  • libmagic1-32bit >= 5.19-5.5
Patchnames:
openSUSE Leap 42.1 GA file
openSUSE Leap 42.2
  • file >= 5.19-6.53
  • file-devel >= 5.19-6.53
  • file-magic >= 5.19-6.53
  • libmagic1 >= 5.19-6.53
  • libmagic1-32bit >= 5.19-6.53
Patchnames:
openSUSE Leap 42.2 GA file
openSUSE Leap 42.3
  • file >= 5.19-8.15
  • file-devel >= 5.19-8.15
  • file-magic >= 5.19-8.15
  • libmagic1 >= 5.19-8.15
  • libmagic1-32bit >= 5.19-8.15
Patchnames:
openSUSE Leap 42.3 GA file
openSUSE Tumbleweed
  • file >= 5.29-2.1
  • file-devel >= 5.29-2.1
  • file-devel-32bit >= 5.29-2.1
  • file-magic >= 5.29-2.1
  • libmagic1 >= 5.29-2.1
  • libmagic1-32bit >= 5.29-2.1
Patchnames:
openSUSE Tumbleweed GA file


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP2 php53 Released
SUSE Linux Enterprise SDK 11 SP3 php53 Released
SUSE Linux Enterprise SDK 11 SP4 php53 Released
SUSE Linux Enterprise Server 11 SP2 php53 Released
SUSE Linux Enterprise Server 11 SP2 LTSS php53 Released
SUSE Linux Enterprise Server 11 SP3 php53 Released
SUSE Linux Enterprise Server 11 SP3 LTSS php53 Released
SUSE Linux Enterprise Server 11 SP4 php53 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 php53 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 php53 Affected
SUSE Linux Enterprise Server for VMWare 11 SP2 php53 Released
SUSE Linux Enterprise Server for VMWare 11 SP3 php53 Released