Upstream information

CVE-2012-1162 at MITRE

Description

Heap-based buffer overflow in the _zip_readcdir function in zip_open.c in libzip 0.10 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a zip archive with the number of directories set to 0, related to an "incorrect loop construct."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 751829 [RESOLVED / FIXED], 751830 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server 12 SP1
  • libzip2 >= 0.11.1-9.1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libzip2 >= 0.11.1-12.1
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • libzip2 >= 0.11.1-13.3.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Server 12
  • libzip2 >= 0.11.1-4.62
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libzip-devel >= 1.5.1-1.9
  • libzip5 >= 1.5.1-1.9
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libzip-devel >= 0.11.1-9.1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libzip-devel >= 0.11.1-12.1
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libzip-devel >= 0.11.1-13.3.1
SUSE Linux Enterprise Software Development Kit 12
  • libzip-devel >= 0.11.1-4.62
openSUSE Leap 15.0
  • libzip5 >= 1.5.1-lp150.1.2
Patchnames:
openSUSE Leap 15.0 GA libzip5
openSUSE Leap 42.1
  • libzip-devel >= 0.11.1-3.1
  • libzip2 >= 0.11.1-3.1
Patchnames:
openSUSE Leap 42.1 GA libzip-devel
openSUSE Leap 42.2
  • libzip-devel >= 0.11.1-5.5
  • libzip2 >= 0.11.1-5.5
Patchnames:
openSUSE Leap 42.2 GA libzip-devel
openSUSE Leap 42.3
  • libzip-devel >= 0.11.1-7.3
  • libzip2 >= 0.11.1-7.3
Patchnames:
openSUSE Leap 42.3 GA libzip-devel
openSUSE Tumbleweed
  • libzip-devel >= 1.1.3-1.4
  • libzip-tools >= 1.1.3-1.4
  • libzip4 >= 1.1.3-1.4
  • libzip4-32bit >= 1.1.3-1.4
Patchnames:
openSUSE Tumbleweed GA libzip-devel