Upstream information

CVE-2012-1014 at MITRE

Description

The process_as_req function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.10.x before 1.10.3 does not initialize a certain structure member, which allows remote attackers to cause a denial of service (uninitialized pointer dereference and daemon crash) or possibly execute arbitrary code via a malformed AS-REQ request.

SUSE information

Overall state of this security issue: Postponed

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9 4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:C AV:N/AC:H/Au:N/C:N/I:P/A:P
Access Vector Network Network
Access Complexity Low High
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial Partial
Availability Impact Complete Partial
SUSE Bugzilla entry: 770172 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.4
  • krb5 >= 1.8.3-52.1
  • krb5-32bit >= 1.8.3-52.1
  • krb5-client >= 1.8.3-52.1
  • krb5-client-debuginfo >= 1.8.3-52.1
  • krb5-debuginfo >= 1.8.3-52.1
  • krb5-debuginfo-32bit >= 1.8.3-52.1
  • krb5-debuginfo-x86 >= 1.8.3-52.1
  • krb5-debugsource >= 1.8.3-52.1
  • krb5-devel >= 1.8.3-52.1
  • krb5-devel-32bit >= 1.8.3-52.1
  • krb5-plugin-kdb-ldap >= 1.8.3-52.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.8.3-52.1
  • krb5-plugin-preauth-pkinit >= 1.8.3-52.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.8.3-52.1
  • krb5-server >= 1.8.3-52.1
  • krb5-server-debuginfo >= 1.8.3-52.1
  • krb5-x86 >= 1.8.3-52.1
Patchnames:
openSUSE-2012-497


Status of this issue by product and package

Product(s) Source package State
OpenStack Cloud Magnum Orchestration 7.0 krb5 Not affected
SUSE Linux Enterprise Desktop 12 SP1 krb5 Unsupported
SUSE Linux Enterprise Desktop 12 SP2 krb5 Not affected
SUSE Linux Enterprise SDK 11 SP4 krb5 Not affected
SUSE Linux Enterprise SDK 12 SP1 krb5 Unsupported
SUSE Linux Enterprise SDK 12 SP2 krb5 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS krb5 Not affected
SUSE Linux Enterprise Server 11 SP4 krb5 Not affected
SUSE Linux Enterprise Server 12 GA krb5 Not affected
SUSE Linux Enterprise Server 12 SP1 krb5 Unsupported
SUSE Linux Enterprise Server 12 SP2 krb5 Not affected