Upstream information

CVE-2012-0864 at MITRE

Description

Integer overflow in the vfprintf function in stdio-common/vfprintf.c in glibc 2.14 and other versions allows context-dependent attackers to bypass the FORTIFY_SOURCE protection mechanism, conduct format string attacks, and write to arbitrary memory via a large number of arguments.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 747768 [RESOLVED / FIXED], 826666 [RESOLVED / FIXED], 920055 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • glibc >= 2.4-31.77.102.1
  • glibc-devel >= 2.4-31.77.102.1
  • glibc-html >= 2.4-31.77.102.1
  • glibc-i18ndata >= 2.4-31.77.102.1
  • glibc-info >= 2.4-31.77.102.1
  • glibc-locale >= 2.4-31.77.102.1
  • glibc-profile >= 2.4-31.77.102.1
  • nscd >= 2.4-31.77.102.1
Builds
ZYPP Patch Nr: 8645
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • glibc >= 2.4-31.77.102.1
  • glibc-32bit >= 2.4-31.77.102.1
  • glibc-devel >= 2.4-31.77.102.1
  • glibc-devel-32bit >= 2.4-31.77.102.1
  • glibc-html >= 2.4-31.77.102.1
  • glibc-i18ndata >= 2.4-31.77.102.1
  • glibc-info >= 2.4-31.77.102.1
  • glibc-locale >= 2.4-31.77.102.1
  • glibc-locale-32bit >= 2.4-31.77.102.1
  • glibc-profile >= 2.4-31.77.102.1
  • glibc-profile-32bit >= 2.4-31.77.102.1
  • nscd >= 2.4-31.77.102.1
Builds
ZYPP Patch Nr: 8645
SUSE Linux Enterprise Software Development Kit 11 SP1
  • glibc-html >= 2.11.1-0.38.1
  • glibc-info >= 2.11.1-0.38.1
Builds
SAT Patch Nr: 6134
SUSE Linux Enterprise Desktop 11 SP1
  • glibc >= 2.11.1-0.38.1
  • glibc-devel >= 2.11.1-0.38.1
  • glibc-i18ndata >= 2.11.1-0.38.1
  • glibc-locale >= 2.11.1-0.38.1
  • nscd >= 2.11.1-0.38.1
Builds
SAT Patch Nr: 6134
SUSE Linux Enterprise Desktop 11 SP1
  • glibc >= 2.11.1-0.38.1
  • glibc-32bit >= 2.11.1-0.38.1
  • glibc-devel >= 2.11.1-0.38.1
  • glibc-devel-32bit >= 2.11.1-0.38.1
  • glibc-i18ndata >= 2.11.1-0.38.1
  • glibc-locale >= 2.11.1-0.38.1
  • glibc-locale-32bit >= 2.11.1-0.38.1
  • nscd >= 2.11.1-0.38.1
Builds
SAT Patch Nr: 6134
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • glibc >= 2.11.1-0.38.1
  • glibc-32bit >= 2.11.1-0.38.1
  • glibc-devel >= 2.11.1-0.38.1
  • glibc-devel-32bit >= 2.11.1-0.38.1
  • glibc-html >= 2.11.1-0.38.1
  • glibc-i18ndata >= 2.11.1-0.38.1
  • glibc-info >= 2.11.1-0.38.1
  • glibc-locale >= 2.11.1-0.38.1
  • glibc-locale-32bit >= 2.11.1-0.38.1
  • glibc-profile >= 2.11.1-0.38.1
  • glibc-profile-32bit >= 2.11.1-0.38.1
  • nscd >= 2.11.1-0.38.1
Builds
SAT Patch Nr: 6134
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • glibc >= 2.11.1-0.38.1
  • glibc-devel >= 2.11.1-0.38.1
  • glibc-html >= 2.11.1-0.38.1
  • glibc-i18ndata >= 2.11.1-0.38.1
  • glibc-info >= 2.11.1-0.38.1
  • glibc-locale >= 2.11.1-0.38.1
  • glibc-profile >= 2.11.1-0.38.1
  • nscd >= 2.11.1-0.38.1
Builds
SAT Patch Nr: 6134
SUSE Linux Enterprise Server 11 SP1
  • glibc >= 2.11.1-0.38.1
  • glibc-devel >= 2.11.1-0.38.1
  • glibc-html >= 2.11.1-0.38.1
  • glibc-i18ndata >= 2.11.1-0.38.1
  • glibc-info >= 2.11.1-0.38.1
  • glibc-locale >= 2.11.1-0.38.1
  • glibc-locale-x86 >= 2.11.1-0.38.1
  • glibc-profile >= 2.11.1-0.38.1
  • glibc-profile-x86 >= 2.11.1-0.38.1
  • glibc-x86 >= 2.11.1-0.38.1
  • nscd >= 2.11.1-0.38.1
Builds
SAT Patch Nr: 6134
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • glibc >= 2.4-31.101.2
  • glibc-devel >= 2.4-31.101.2
  • glibc-html >= 2.4-31.101.2
  • glibc-i18ndata >= 2.4-31.101.2
  • glibc-info >= 2.4-31.101.2
  • glibc-locale >= 2.4-31.101.2
  • nscd >= 2.4-31.101.2
Builds
ZYPP Patch Nr: 8074
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
  • glibc >= 2.4-31.101.2
  • glibc-32bit >= 2.4-31.101.2
  • glibc-devel >= 2.4-31.101.2
  • glibc-devel-32bit >= 2.4-31.101.2
  • glibc-html >= 2.4-31.101.2
  • glibc-i18ndata >= 2.4-31.101.2
  • glibc-info >= 2.4-31.101.2
  • glibc-locale >= 2.4-31.101.2
  • glibc-locale-32bit >= 2.4-31.101.2
  • nscd >= 2.4-31.101.2
Builds
ZYPP Patch Nr: 8074
SLE SDK 10 SP4 for x86
  • glibc-dceext >= 2.4-31.101.2
  • glibc-html >= 2.4-31.101.2
  • glibc-profile >= 2.4-31.101.2
Builds
ZYPP Patch Nr: 8074
SLE SDK 10 SP4 for IPF
  • glibc-dceext >= 2.4-31.101.2
  • glibc-dceext-x86 >= 2.4-31.101.2
  • glibc-html >= 2.4-31.101.2
  • glibc-profile >= 2.4-31.101.2
  • glibc-profile-x86 >= 2.4-31.101.2
Builds
ZYPP Patch Nr: 8074
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
  • glibc-dceext >= 2.4-31.101.2
  • glibc-dceext-64bit >= 2.4-31.101.2
  • glibc-html >= 2.4-31.101.2
  • glibc-profile >= 2.4-31.101.2
  • glibc-profile-64bit >= 2.4-31.101.2
Builds
ZYPP Patch Nr: 8074
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for X86-64
  • glibc-dceext >= 2.4-31.101.2
  • glibc-dceext-32bit >= 2.4-31.101.2
  • glibc-html >= 2.4-31.101.2
  • glibc-profile >= 2.4-31.101.2
  • glibc-profile-32bit >= 2.4-31.101.2
Builds
ZYPP Patch Nr: 8074
SUSE Linux Enterprise Server 10 SP4 for x86
  • glibc >= 2.4-31.101.2
  • glibc-devel >= 2.4-31.101.2
  • glibc-html >= 2.4-31.101.2
  • glibc-i18ndata >= 2.4-31.101.2
  • glibc-info >= 2.4-31.101.2
  • glibc-locale >= 2.4-31.101.2
  • glibc-profile >= 2.4-31.101.2
  • nscd >= 2.4-31.101.2
Builds
ZYPP Patch Nr: 8074
SUSE Linux Enterprise Server 10 SP4 for IPF
  • glibc >= 2.4-31.101.2
  • glibc-devel >= 2.4-31.101.2
  • glibc-html >= 2.4-31.101.2
  • glibc-i18ndata >= 2.4-31.101.2
  • glibc-info >= 2.4-31.101.2
  • glibc-locale >= 2.4-31.101.2
  • glibc-locale-x86 >= 2.4-31.101.2
  • glibc-profile >= 2.4-31.101.2
  • glibc-profile-x86 >= 2.4-31.101.2
  • glibc-x86 >= 2.4-31.101.2
  • nscd >= 2.4-31.101.2
Builds
ZYPP Patch Nr: 8074
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • glibc >= 2.4-31.101.2
  • glibc-64bit >= 2.4-31.101.2
  • glibc-devel >= 2.4-31.101.2
  • glibc-devel-64bit >= 2.4-31.101.2
  • glibc-html >= 2.4-31.101.2
  • glibc-i18ndata >= 2.4-31.101.2
  • glibc-info >= 2.4-31.101.2
  • glibc-locale >= 2.4-31.101.2
  • glibc-locale-64bit >= 2.4-31.101.2
  • glibc-profile >= 2.4-31.101.2
  • glibc-profile-64bit >= 2.4-31.101.2
  • nscd >= 2.4-31.101.2
Builds
ZYPP Patch Nr: 8074
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • glibc >= 2.4-31.101.2
  • glibc-32bit >= 2.4-31.101.2
  • glibc-devel >= 2.4-31.101.2
  • glibc-devel-32bit >= 2.4-31.101.2
  • glibc-html >= 2.4-31.101.2
  • glibc-i18ndata >= 2.4-31.101.2
  • glibc-info >= 2.4-31.101.2
  • glibc-locale >= 2.4-31.101.2
  • glibc-locale-32bit >= 2.4-31.101.2
  • glibc-profile >= 2.4-31.101.2
  • glibc-profile-32bit >= 2.4-31.101.2
  • nscd >= 2.4-31.101.2
Builds
ZYPP Patch Nr: 8074
SUSE Linux Enterprise Software Development Kit 11 SP2
  • glibc-html >= 2.11.3-17.35.4
  • glibc-info >= 2.11.3-17.35.4
Builds
SAT Patch Nr: 6135
SUSE Linux Enterprise Desktop 11 SP2
  • glibc >= 2.11.3-17.35.4
  • glibc-devel >= 2.11.3-17.35.4
  • glibc-i18ndata >= 2.11.3-17.35.4
  • glibc-locale >= 2.11.3-17.35.4
  • nscd >= 2.11.3-17.35.4
Builds
SAT Patch Nr: 6135
SUSE Linux Enterprise Desktop 11 SP2
  • glibc >= 2.11.3-17.35.4
  • glibc-32bit >= 2.11.3-17.35.4
  • glibc-devel >= 2.11.3-17.35.4
  • glibc-devel-32bit >= 2.11.3-17.35.4
  • glibc-i18ndata >= 2.11.3-17.35.4
  • glibc-locale >= 2.11.3-17.35.4
  • glibc-locale-32bit >= 2.11.3-17.35.4
  • nscd >= 2.11.3-17.35.4
Builds
SAT Patch Nr: 6135
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • glibc >= 2.11.3-17.35.4
  • glibc-devel >= 2.11.3-17.35.4
  • glibc-html >= 2.11.3-17.35.4
  • glibc-i18ndata >= 2.11.3-17.35.4
  • glibc-info >= 2.11.3-17.35.4
  • glibc-locale >= 2.11.3-17.35.4
  • glibc-profile >= 2.11.3-17.35.4
  • nscd >= 2.11.3-17.35.4
Builds
SAT Patch Nr: 6135
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • glibc >= 2.11.3-17.35.4
  • glibc-32bit >= 2.11.3-17.35.4
  • glibc-devel >= 2.11.3-17.35.4
  • glibc-devel-32bit >= 2.11.3-17.35.4
  • glibc-html >= 2.11.3-17.35.4
  • glibc-i18ndata >= 2.11.3-17.35.4
  • glibc-info >= 2.11.3-17.35.4
  • glibc-locale >= 2.11.3-17.35.4
  • glibc-locale-32bit >= 2.11.3-17.35.4
  • glibc-profile >= 2.11.3-17.35.4
  • glibc-profile-32bit >= 2.11.3-17.35.4
  • nscd >= 2.11.3-17.35.4
Builds
SAT Patch Nr: 6135
SUSE Linux Enterprise Server 11 SP2
  • glibc >= 2.11.3-17.35.4
  • glibc-devel >= 2.11.3-17.35.4
  • glibc-html >= 2.11.3-17.35.4
  • glibc-i18ndata >= 2.11.3-17.35.4
  • glibc-info >= 2.11.3-17.35.4
  • glibc-locale >= 2.11.3-17.35.4
  • glibc-locale-x86 >= 2.11.3-17.35.4
  • glibc-profile >= 2.11.3-17.35.4
  • glibc-profile-x86 >= 2.11.3-17.35.4
  • glibc-x86 >= 2.11.3-17.35.4
  • nscd >= 2.11.3-17.35.4
Builds
SAT Patch Nr: 6135


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 glibc Released
SUSE Linux Enterprise Desktop 10 SP4 glibc Affected
SUSE Linux Enterprise Desktop 11 SP1 glibc Released
SUSE Linux Enterprise Desktop 11 SP2 glibc Affected
SUSE Linux Enterprise Desktop 11 SP3 glibc Affected
SUSE Linux Enterprise SDK 11 SP1 glibc Released
SUSE Linux Enterprise SDK 11 SP2 glibc Affected
SUSE Linux Enterprise SDK 11 SP3 glibc Affected
SUSE Linux Enterprise Server 10 SP3 glibc Released
SUSE Linux Enterprise Server 10 SP4 glibc Affected
SUSE Linux Enterprise Server 10 SP4 LTSS glibc Affected
SUSE Linux Enterprise Server 11 SP1 glibc Released
SUSE Linux Enterprise Server 11 SP1 LTSS glibc Released
SUSE Linux Enterprise Server 11 SP2 glibc Affected
SUSE Linux Enterprise Server 11 SP2 LTSS glibc Affected
SUSE Linux Enterprise Server 11 SP3 glibc Affected
SUSE Linux Enterprise Server for SAP AIO 11 SP1 glibc Released
SUSE Linux Enterprise Server for VMWare 11 SP2 glibc Affected
SUSE Linux Enterprise Server for VMWare 11 SP3 glibc Affected