Upstream information

CVE-2011-4599 at MITRE

Description

Stack-based buffer overflow in the _canonicalize function in common/uloc.c in International Components for Unicode (ICU) before 49.1 allows remote attackers to execute arbitrary code via a crafted locale ID that is not properly handled during variant canonicalization.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 736146 [RESOLVED / FIXED], 740453 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • icu >= 4.0-7.26.15
  • libicu >= 4.0-7.26.15
Patchnames:
sledsp2-icu
SUSE Linux Enterprise Server 11 SP1
  • libicu >= 4.0-7.26.1
  • libicu-32bit >= 4.0-7.26.1
  • libicu-doc >= 4.0-7.26.1
Patchnames:
slessp1-icu
SUSE Linux Enterprise Server 11 SP2
  • libicu >= 4.0-7.26.15
  • libicu-32bit >= 4.0-7.26.15
  • libicu-doc >= 4.0-7.26.15
  • libicu-x86 >= 4.0-7.26.15
Patchnames:
slessp2-icu
SUSE Linux Enterprise Server for SAP Applications 11 SP2
  • libicu >= 4.0-7.26.15
  • libicu-32bit >= 4.0-7.26.15
  • libicu-doc >= 4.0-7.26.15
  • libicu-x86 >= 4.0-7.26.15
Patchnames:
slessp2-icu
SUSE Linux Enterprise Server for VMWare 11 SP2
  • libicu >= 4.0-7.26.15
  • libicu-32bit >= 4.0-7.26.15
  • libicu-doc >= 4.0-7.26.15
  • libicu-x86 >= 4.0-7.26.15
Patchnames:
slessp2-icu
SUSE Linux Enterprise Software Development Kit 11 SP2
  • icu >= 4.0-7.26.15
  • libicu-32bit >= 4.0-7.26.15
  • libicu-devel >= 4.0-7.26.15
  • libicu-devel-32bit >= 4.0-7.26.15
Patchnames:
sdksp2-icu
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • libreoffice >= 3.4.5.5-0.7.1
  • libreoffice-af >= 3.4.5.5-0.7.1
  • libreoffice-ar >= 3.4.5.5-0.7.1
  • libreoffice-ca >= 3.4.5.5-0.7.1
  • libreoffice-cs >= 3.4.5.5-0.7.1
  • libreoffice-da >= 3.4.5.5-0.7.1
  • libreoffice-de >= 3.4.5.5-0.7.1
  • libreoffice-el >= 3.4.5.5-0.7.1
  • libreoffice-en-GB >= 3.4.5.5-0.7.1
  • libreoffice-es >= 3.4.5.5-0.7.1
  • libreoffice-fi >= 3.4.5.5-0.7.1
  • libreoffice-fr >= 3.4.5.5-0.7.1
  • libreoffice-galleries >= 3.4.5.5-0.7.1
  • libreoffice-gnome >= 3.4.5.5-0.7.1
  • libreoffice-gu-IN >= 3.4.5.5-0.7.1
  • libreoffice-hi-IN >= 3.4.5.5-0.7.1
  • libreoffice-hu >= 3.4.5.5-0.7.1
  • libreoffice-it >= 3.4.5.5-0.7.1
  • libreoffice-ja >= 3.4.5.5-0.7.1
  • libreoffice-kde >= 3.4.5.5-0.7.1
  • libreoffice-ko >= 3.4.5.5-0.7.1
  • libreoffice-mono >= 3.4.5.5-0.7.1
  • libreoffice-nb >= 3.4.5.5-0.7.1
  • libreoffice-nl >= 3.4.5.5-0.7.1
  • libreoffice-nn >= 3.4.5.5-0.7.1
  • libreoffice-pl >= 3.4.5.5-0.7.1
  • libreoffice-pt-BR >= 3.4.5.5-0.7.1
  • libreoffice-ru >= 3.4.5.5-0.7.1
  • libreoffice-sk >= 3.4.5.5-0.7.1
  • libreoffice-sv >= 3.4.5.5-0.7.1
  • libreoffice-xh >= 3.4.5.5-0.7.1
  • libreoffice-zh-CN >= 3.4.5.5-0.7.1
  • libreoffice-zh-TW >= 3.4.5.5-0.7.1
  • libreoffice-zu >= 3.4.5.5-0.7.1
Builds
ZYPP Patch Nr: 8022
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • libreoffice >= 3.4.5.5-0.7.1
  • libreoffice-cs >= 3.4.5.5-0.7.1
  • libreoffice-de >= 3.4.5.5-0.7.1
  • libreoffice-es >= 3.4.5.5-0.7.1
  • libreoffice-fr >= 3.4.5.5-0.7.1
  • libreoffice-galleries >= 3.4.5.5-0.7.1
  • libreoffice-gnome >= 3.4.5.5-0.7.1
  • libreoffice-hu >= 3.4.5.5-0.7.1
  • libreoffice-it >= 3.4.5.5-0.7.1
  • libreoffice-ja >= 3.4.5.5-0.7.1
  • libreoffice-kde >= 3.4.5.5-0.7.1
  • libreoffice-mono >= 3.4.5.5-0.7.1
  • libreoffice-pl >= 3.4.5.5-0.7.1
  • libreoffice-pt-BR >= 3.4.5.5-0.7.1
  • libreoffice-sk >= 3.4.5.5-0.7.1
  • libreoffice-zh-CN >= 3.4.5.5-0.7.1
  • libreoffice-zh-TW >= 3.4.5.5-0.7.1
Builds
ZYPP Patch Nr: 8022
SUSE Linux Enterprise Software Development Kit 11 SP1
  • icu >= 4.0-7.26.1
  • libicu-devel >= 4.0-7.26.1
sled11-sp1.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.x86-64
sles11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
SAT Patch Nr: 5653
SUSE Linux Enterprise Software Development Kit 11 SP1
  • icu >= 4.0-7.26.1
  • libicu-32bit >= 4.0-7.26.1
  • libicu-devel >= 4.0-7.26.1
  • libicu-devel-32bit >= 4.0-7.26.1
sled11-sp1.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.x86-64
sles11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
SAT Patch Nr: 5653
SUSE Linux Enterprise Desktop 11 SP1
  • icu >= 4.0-7.26.1
  • libicu >= 4.0-7.26.1
sled11-sp1.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.x86-64
sles11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
SAT Patch Nr: 5653
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libicu >= 4.0-7.26.1
  • libicu-32bit >= 4.0-7.26.1
  • libicu-doc >= 4.0-7.26.1
sled11-sp1.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.x86-64
sles11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
SAT Patch Nr: 5653
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libicu >= 4.0-7.26.1
  • libicu-doc >= 4.0-7.26.1
sled11-sp1.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.x86-64
sles11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
SAT Patch Nr: 5653
SUSE Linux Enterprise Software Development Kit 11 SP2
  • icu >= 4.0-7.26.15
  • libicu-devel >= 4.0-7.26.15
Builds
SAT Patch Nr: 7204
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libicu-devel >= 4.0-7.26.15
Builds
SAT Patch Nr: 7204
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libicu-devel >= 4.0-7.26.15
  • libicu-devel-32bit >= 4.0-7.26.15
Builds
SAT Patch Nr: 7204
SUSE Linux Enterprise Software Development Kit 11 SP2
  • icu >= 4.0-7.26.15
  • libicu-32bit >= 4.0-7.26.15
  • libicu-devel >= 4.0-7.26.15
  • libicu-devel-32bit >= 4.0-7.26.15
Builds
SAT Patch Nr: 7204
SUSE Linux Enterprise Desktop 11 SP2
  • icu >= 4.0-7.26.15
  • libicu >= 4.0-7.26.15
Builds
SAT Patch Nr: 7204
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • libicu >= 4.0-7.26.15
  • libicu-doc >= 4.0-7.26.15
Builds
SAT Patch Nr: 7204
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • libicu >= 4.0-7.26.15
  • libicu-32bit >= 4.0-7.26.15
  • libicu-doc >= 4.0-7.26.15
Builds
SAT Patch Nr: 7204
SUSE Linux Enterprise Server 11 SP2
  • libicu >= 4.0-7.26.15
  • libicu-doc >= 4.0-7.26.15
  • libicu-x86 >= 4.0-7.26.15
Builds
SAT Patch Nr: 7204
openSUSE 11.3
  • icu-debuginfo >= 4.2-7.3.1
  • icu-debugsource >= 4.2-7.3.1
  • libicu-debuginfo >= 4.2-7.3.1
  • libicu-debuginfo-32bit >= 4.2-7.3.1
openSUSE 11.3
  • icu >= 4.2-7.3.1
  • icu-data >= 4.2-7.3.1
  • libicu >= 4.2-7.3.1
  • libicu-32bit >= 4.2-7.3.1
  • libicu-devel >= 4.2-7.3.1
  • libicu-devel-32bit >= 4.2-7.3.1
  • libicu-doc >= 4.2-7.3.1
openSUSE 11.4
  • icu >= 4.4.2-4.5.1
  • icu-data >= 4.4.2-4.5.1
  • libicu >= 4.4.2-4.5.1
  • libicu-32bit >= 4.4.2-4.5.1
  • libicu-devel >= 4.4.2-4.5.1
  • libicu-devel-32bit >= 4.4.2-4.5.1
  • libicu-doc >= 4.4.2-4.5.1
openSUSE 11.4
  • icu >= 4.4.2-4.5.1
  • icu-data >= 4.4.2-4.5.1
  • icu-debuginfo >= 4.4.2-4.5.1
  • icu-debugsource >= 4.4.2-4.5.1
  • libicu >= 4.4.2-4.5.1
  • libicu-32bit >= 4.4.2-4.5.1
  • libicu-debuginfo >= 4.4.2-4.5.1
  • libicu-debuginfo-32bit >= 4.4.2-4.5.1
  • libicu-devel >= 4.4.2-4.5.1
  • libicu-devel-32bit >= 4.4.2-4.5.1
  • libicu-doc >= 4.4.2-4.5.1
Patchnames:
icu


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 icu Released
SUSE Linux Enterprise Desktop 10 SP4 icu Affected
SUSE Linux Enterprise Desktop 11 SP1 icu Affected
SUSE Linux Enterprise Desktop 11 SP2 icu Released
SUSE Linux Enterprise SDK 11 SP1 icu Affected
SUSE Linux Enterprise SDK 11 SP2 icu Released
SUSE Linux Enterprise Server 10 SP3 icu Released
SUSE Linux Enterprise Server 10 SP4 icu Affected
SUSE Linux Enterprise Server 10 SP4 LTSS icu Affected
SUSE Linux Enterprise Server 11 SP1 icu Affected
SUSE Linux Enterprise Server 11 SP1 LTSS icu Affected
SUSE Linux Enterprise Server 11 SP2 icu Released
SUSE Linux Enterprise Server 11 SP2 LTSS icu Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 icu Affected
SUSE Linux Enterprise Server for VMWare 11 SP2 icu Released