Upstream information

CVE-2011-4130 at MITRE

Description

Use-after-free vulnerability in the Response API in ProFTPD before 1.3.3g allows remote authenticated users to execute arbitrary code via vectors involving an error that occurs after an FTP data transfer.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9
Vector AV:N/AC:L/Au:S/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 729830 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • proftpd >= 1.3.5b-2.5
  • proftpd-devel >= 1.3.5b-2.5
  • proftpd-doc >= 1.3.5b-2.5
  • proftpd-lang >= 1.3.5b-2.5
  • proftpd-ldap >= 1.3.5b-2.5
  • proftpd-mysql >= 1.3.5b-2.5
  • proftpd-pgsql >= 1.3.5b-2.5
  • proftpd-radius >= 1.3.5b-2.5
  • proftpd-sqlite >= 1.3.5b-2.5
Patchnames:
openSUSE Tumbleweed GA proftpd