Upstream information

CVE-2011-3602 at MITRE

Description

Directory traversal vulnerability in device-linux.c in the router advertisement daemon (radvd) before 1.8.2 allows local users to overwrite arbitrary files, and remote attackers to overwrite certain files, via a .. (dot dot) in an interface name. NOTE: this can be leveraged with a symlink to overwrite arbitrary files.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:N/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 721968 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • radvd >= 1.9.7-2.17
Patchnames:
SUSE Linux Enterprise Desktop 12 GA radvd
SUSE Linux Enterprise Desktop 12 SP1
  • radvd >= 1.9.7-2.17
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA radvd
SUSE Linux Enterprise Desktop 12 SP2
  • radvd >= 1.9.7-2.17
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA radvd
SUSE Linux Enterprise Desktop 12 SP3
  • radvd >= 1.9.7-2.17
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA radvd
SUSE Linux Enterprise Module for Basesystem 15
  • radvd >= 2.17-3.18
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA radvd
SUSE Linux Enterprise Server 11 SP1
  • radvd >= 1.1-1.24.4.1
Patchnames:
slessp1-radvd
SUSE Linux Enterprise Server 11 SP2
  • radvd >= 1.1-1.24.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA radvd
SUSE Linux Enterprise Server 11 SP3
  • radvd >= 1.1-1.24.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA radvd
SUSE Linux Enterprise Server 11 SP4
  • radvd >= 1.1-1.24.8.19
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA radvd
SUSE Linux Enterprise Server 12
  • radvd >= 1.9.7-2.17
Patchnames:
SUSE Linux Enterprise Server 12 GA radvd
SUSE Linux Enterprise Server 12 SP1
  • radvd >= 1.9.7-2.17
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA radvd
SUSE Linux Enterprise Server 12 SP2
  • radvd >= 1.9.7-2.17
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA radvd
SUSE Linux Enterprise Server 12 SP3
  • radvd >= 1.9.7-2.17
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA radvd
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • radvd >= 1.9.7-2.12
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA radvd
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • radvd >= 1.1-1.24.4.1
Builds
SAT Patch Nr: 5397
openSUSE 11.3
  • radvd-debuginfo >= 1.3-6.3.1
  • radvd-debugsource >= 1.3-6.3.1
openSUSE 11.3
  • radvd >= 1.3-6.3.1
openSUSE 11.4
  • radvd >= 1.3-9.10.1
openSUSE 11.4
  • radvd >= 1.3-9.10.1
  • radvd-debuginfo >= 1.3-9.10.1
  • radvd-debugsource >= 1.3-9.10.1
Patchnames:
radvd
openSUSE Leap 15.0
  • radvd >= 2.17-lp150.3.4
Patchnames:
openSUSE Leap 15.0 GA radvd
openSUSE Leap 42.1
  • radvd >= 2.11-3.2
Patchnames:
openSUSE Leap 42.1 GA radvd
openSUSE Leap 42.2
  • radvd >= 2.11-4.6
Patchnames:
openSUSE Leap 42.2 GA radvd
openSUSE Leap 42.3
  • radvd >= 2.11-6.3
Patchnames:
openSUSE Leap 42.3 GA radvd
openSUSE Tumbleweed
  • radvd >= 2.11-1.7
Patchnames:
openSUSE Tumbleweed GA radvd


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Server 10 SP3 radvd Released
SUSE Linux Enterprise Server 10 SP4 radvd Released
SUSE Linux Enterprise Server 10 SP4 LTSS radvd Released
SUSE Linux Enterprise Server 11 SP1 radvd Released
SUSE Linux Enterprise Server 11 SP1 LTSS radvd Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 radvd Released