Upstream information

CVE-2011-3372 at MITRE

Description

imap/nntpd.c in the NNTP server (nntpd) for Cyrus IMAPd 2.4.x before 2.4.12 allows remote attackers to bypass authentication by sending an AUTHINFO USER command without sending an additional AUTHINFO PASS command.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 719998 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • cyrus-imapd >= 2.3.11-60.65.64.1
  • perl-Cyrus-IMAP >= 2.3.11-60.65.64.1
  • perl-Cyrus-SIEVE-managesieve >= 2.3.11-60.65.64.1
Patchnames:
slessp1-cyrus-imapd
SUSE Linux Enterprise Server 11 SP2
  • cyrus-imapd >= 2.3.11-60.65.64.1
  • perl-Cyrus-IMAP >= 2.3.11-60.65.64.1
  • perl-Cyrus-SIEVE-managesieve >= 2.3.11-60.65.64.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA cyrus-imapd
SUSE Linux Enterprise Server 11 SP3
  • cyrus-imapd >= 2.3.11-60.65.64.1
  • perl-Cyrus-IMAP >= 2.3.11-60.65.64.1
  • perl-Cyrus-SIEVE-managesieve >= 2.3.11-60.65.64.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA cyrus-imapd
SUSE Linux Enterprise Server 11 SP4
  • cyrus-imapd >= 2.3.11-60.65.64.1
  • perl-Cyrus-IMAP >= 2.3.11-60.65.64.1
  • perl-Cyrus-SIEVE-managesieve >= 2.3.11-60.65.64.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA cyrus-imapd
SUSE Linux Enterprise Server 12
  • perl-Cyrus-IMAP >= 2.3.18-35.71
  • perl-Cyrus-SIEVE-managesieve >= 2.3.18-35.71
Patchnames:
SUSE Linux Enterprise Server 12 GA perl-Cyrus-IMAP
SUSE Linux Enterprise Server 12 SP1
  • perl-Cyrus-IMAP >= 2.3.18-35.71
  • perl-Cyrus-SIEVE-managesieve >= 2.3.18-35.71
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA perl-Cyrus-IMAP
SUSE Linux Enterprise Software Development Kit 11 SP4
  • cyrus-imapd-devel >= 2.3.11-60.65.64.1
  • perl-Cyrus-IMAP >= 2.3.11-60.65.64.1
  • perl-Cyrus-SIEVE-managesieve >= 2.3.11-60.65.64.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA cyrus-imapd-devel
SUSE Linux Enterprise Software Development Kit 11 SP1
  • cyrus-imapd-devel >= 2.3.11-60.65.64.1
  • perl-Cyrus-IMAP >= 2.3.11-60.65.64.1
  • perl-Cyrus-SIEVE-managesieve >= 2.3.11-60.65.64.1
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86
sles11-sp1.s390x
sles11-sp1.x86-64
sles11-sp1.x86
sles11-sp1.ia64
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sle11-sp1-sdk.ppc
sle11-sp1-sdk.s390x
SAT Patch Nr: 5233
SUSE Linux Enterprise Software Development Kit 11 SP1
  • cyrus-imapd-devel >= 2.3.11-60.65.64.1
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86
sles11-sp1.s390x
sles11-sp1.x86-64
sles11-sp1.x86
sles11-sp1.ia64
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sle11-sp1-sdk.ppc
sle11-sp1-sdk.s390x
SAT Patch Nr: 5233
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • cyrus-imapd >= 2.3.11-60.65.64.1
  • perl-Cyrus-IMAP >= 2.3.11-60.65.64.1
  • perl-Cyrus-SIEVE-managesieve >= 2.3.11-60.65.64.1
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86
sles11-sp1.s390x
sles11-sp1.x86-64
sles11-sp1.x86
sles11-sp1.ia64
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sle11-sp1-sdk.ppc
sle11-sp1-sdk.s390x
SAT Patch Nr: 5233
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • cyrus-imapd >= 2.2.12-27.16.32.2
  • cyrus-imapd-devel >= 2.2.12-27.16.32.2
  • perl-Cyrus-IMAP >= 2.2.12-27.16.32.2
  • perl-Cyrus-SIEVE-managesieve >= 2.2.12-27.16.32.2
sles10-sp3.ppc
sles10-sp3-debuginfo.ppc
sles10-sp3.x86
sles10-sp3-debuginfo.ia64
sle10-sp3-sdk.ppc
sles10-sp3-debuginfo.x86
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.s390x
sles10-sp3.s390x
sles10-sp3-debuginfo.s390x
sles10-sp3.ia64
sles10-sp3.x86-64
sles10-sp3-debuginfo.x86-64
ZYPP Patch Nr: 7786
openSUSE 11.3
  • cyrus-imapd-debuginfo >= 2.3.16-8.9.1
  • cyrus-imapd-debugsource >= 2.3.16-8.9.1
  • perl-Cyrus-IMAP-debuginfo >= 2.3.16-8.9.1
  • perl-Cyrus-SIEVE-managesieve-debuginfo >= 2.3.16-8.9.1
openSUSE 11.3
  • cyrus-imapd >= 2.3.16-8.9.1
  • cyrus-imapd-devel >= 2.3.16-8.9.1
  • perl-Cyrus-IMAP >= 2.3.16-8.9.1
  • perl-Cyrus-SIEVE-managesieve >= 2.3.16-8.9.1
openSUSE 11.4
  • cyrus-imapd >= 2.3.16-16.21.1
  • cyrus-imapd-devel >= 2.3.16-16.21.1
  • perl-Cyrus-IMAP >= 2.3.16-16.21.1
  • perl-Cyrus-SIEVE-managesieve >= 2.3.16-16.21.1
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 for IPF
SUSE Linux Enterprise Server 10 SP4 for x86
  • cyrus-imapd >= 2.2.12-27.30.1
  • cyrus-imapd-devel >= 2.2.12-27.30.1
  • perl-Cyrus-IMAP >= 2.2.12-27.30.1
  • perl-Cyrus-SIEVE-managesieve >= 2.2.12-27.30.1
sles10-sp4.x86-64
sle10-sp4-sdk.x86-64
sles10-sp4.x86
sle10-sp4-sdk.ppc
sles10-sp4.ia64
sle10-sp4-sdk.ia64
sle10-sp4-sdk.s390x
sles10-sp4-debuginfo.s390x
sles10-sp4.ppc
sles10-sp4-debuginfo.ppc
sles10-sp4-debuginfo.x86-64
sles10-sp4.s390x
sles10-sp4-debuginfo.x86
sle10-sp4-sdk.x86
sles10-sp4-debuginfo.ia64
ZYPP Patch Nr: 7785
openSUSE 11.4
  • cyrus-imapd >= 2.3.16-16.21.1
  • cyrus-imapd-debuginfo >= 2.3.16-16.21.1
  • cyrus-imapd-debugsource >= 2.3.16-16.21.1
  • cyrus-imapd-devel >= 2.3.16-16.21.1
  • perl-Cyrus-IMAP >= 2.3.16-16.21.1
  • perl-Cyrus-IMAP-debuginfo >= 2.3.16-16.21.1
  • perl-Cyrus-SIEVE-managesieve >= 2.3.16-16.21.1
  • perl-Cyrus-SIEVE-managesieve-debuginfo >= 2.3.16-16.21.1
Patchnames:
cyrus-imapd
openSUSE Leap 42.1
  • cyradm >= 2.4.18-1.2
  • cyrus-imapd >= 2.4.18-1.2
  • perl-Cyrus-IMAP >= 2.4.18-1.2
  • perl-Cyrus-SIEVE-managesieve >= 2.4.18-1.2
Patchnames:
openSUSE Leap 42.1 GA cyradm
openSUSE Leap 42.2
  • cyradm >= 2.4.18-3.6
  • cyrus-imapd >= 2.4.18-3.6
  • perl-Cyrus-IMAP >= 2.4.18-3.6
  • perl-Cyrus-SIEVE-managesieve >= 2.4.18-3.6
Patchnames:
openSUSE Leap 42.2 GA cyradm
openSUSE Leap 42.3
  • cyradm >= 2.4.18-5.2
  • cyrus-imapd >= 2.4.18-5.2
  • perl-Cyrus-IMAP >= 2.4.18-5.2
  • perl-Cyrus-SIEVE-managesieve >= 2.4.18-5.2
Patchnames:
openSUSE Leap 42.3 GA cyradm
openSUSE Tumbleweed
  • cyradm >= 2.4.18-3.4
  • cyrus-imapd >= 2.4.18-3.4
  • cyrus-imapd-devel >= 2.4.18-3.4
  • cyrus-imapd-snmp >= 2.4.18-3.4
  • cyrus-imapd-snmp-mibs >= 2.4.18-3.4
  • cyrus-imapd-utils >= 2.4.18-3.4
  • perl-Cyrus-IMAP >= 2.4.18-3.4
  • perl-Cyrus-SIEVE-managesieve >= 2.4.18-3.4
Patchnames:
openSUSE Tumbleweed GA cyradm


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP1 cyrus-imapd Released
SUSE Linux Enterprise Server 10 SP3 cyrus-imapd Released
SUSE Linux Enterprise Server 10 SP4 cyrus-imapd Released
SUSE Linux Enterprise Server 10 SP4 LTSS cyrus-imapd Released
SUSE Linux Enterprise Server 11 SP1 cyrus-imapd Released
SUSE Linux Enterprise Server 11 SP1 LTSS cyrus-imapd Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 cyrus-imapd Released