Upstream information

CVE-2011-3048 at MITRE

Description

The png_set_text_2 function in pngset.c in libpng 1.0.x before 1.0.59, 1.2.x before 1.2.49, 1.4.x before 1.4.11, and 1.5.x before 1.5.10 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted text chunk in a PNG image file, which triggers a memory allocation failure that is not properly handled, leading to a heap-based buffer overflow.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.82
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 754745 [RESOLVED / FIXED], 854395 [NEEDINFO]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libpng12-0 >= 1.2.50-8.21
  • libpng12-0-32bit >= 1.2.50-8.21
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libpng12-0
SUSE Linux Enterprise Desktop 12 SP1
  • libpng12-0 >= 1.2.50-8.21
  • libpng12-0-32bit >= 1.2.50-8.21
  • libpng15-15 >= 1.5.22-2.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libpng12-0
SUSE Linux Enterprise Desktop 12 SP1 GA libpng15-15
SUSE Linux Enterprise Desktop 12 SP2
  • libpng12-0 >= 1.2.50-13.1
  • libpng12-0-32bit >= 1.2.50-13.1
  • libpng15-15 >= 1.5.22-4.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libpng12-0
SUSE Linux Enterprise Desktop 12 SP2 GA libpng15-15
SUSE Linux Enterprise Server 11 SP1
  • libpng12-0 >= 1.2.31-5.29.1
  • libpng12-0-32bit >= 1.2.31-5.29.1
  • libpng12-0-x86 >= 1.2.31-5.31.1
Patchnames:
slessp1-libpng-devel
SUSE Linux Enterprise Server 11 SP2
  • libpng12-0 >= 1.2.31-5.29.1
  • libpng12-0-32bit >= 1.2.31-5.29.1
  • libpng12-0-x86 >= 1.2.31-5.31.1
Patchnames:
slessp1-libpng-devel
SUSE Linux Enterprise Server 11 SP3
  • libpng12-0 >= 1.2.31-5.31.1
  • libpng12-0-32bit >= 1.2.31-5.31.1
  • libpng12-0-x86 >= 1.2.31-5.31.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libpng12-0
SUSE Linux Enterprise Server 11 SP4
  • libpng12-0 >= 1.2.31-5.33.1
  • libpng12-0-32bit >= 1.2.31-5.33.1
  • libpng12-0-x86 >= 1.2.31-5.33.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libpng12-0
SUSE Linux Enterprise Server 12
  • libpng12-0 >= 1.2.50-8.21
  • libpng12-0-32bit >= 1.2.50-8.21
Patchnames:
SUSE Linux Enterprise Server 12 GA libpng12-0
SUSE Linux Enterprise Server 12 SP1
  • libpng12-0 >= 1.2.50-8.21
  • libpng12-0-32bit >= 1.2.50-8.21
  • libpng15-15 >= 1.5.22-2.2
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libpng12-0
SUSE Linux Enterprise Server 12 SP1 GA libpng15-15
SUSE Linux Enterprise Server 12 SP2
  • libpng12-0 >= 1.2.50-13.1
  • libpng12-0-32bit >= 1.2.50-13.1
  • libpng15-15 >= 1.5.22-4.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libpng12-0
SUSE Linux Enterprise Server 12 SP2 GA libpng15-15
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpng12-0 >= 1.2.50-13.1
  • libpng15-15 >= 1.5.22-4.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libpng12-0
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libpng15-15
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libpng-devel >= 1.2.31-5.33.1
  • libpng-devel-32bit >= 1.2.31-5.33.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libpng-devel
SUSE Linux Enterprise Software Development Kit 12
  • libpng12-compat-devel >= 1.2.50-8.21
  • libpng12-devel >= 1.2.50-8.21
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libpng12-compat-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libpng12-compat-devel >= 1.2.50-8.21
  • libpng12-devel >= 1.2.50-8.21
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libpng12-compat-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpng12-compat-devel >= 1.2.50-13.1
  • libpng12-devel >= 1.2.50-13.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libpng12-compat-devel
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • libpng >= 1.2.8-19.35.4
  • libpng-devel >= 1.2.8-19.35.4
Builds
ZYPP Patch Nr: 8043
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • libpng >= 1.2.8-19.35.4
  • libpng-32bit >= 1.2.8-19.35.4
  • libpng-devel >= 1.2.8-19.35.4
  • libpng-devel-32bit >= 1.2.8-19.35.4
Builds
ZYPP Patch Nr: 8043
SUSE Linux Enterprise Server 10 SP4 for IPF
  • libpng >= 1.2.8-19.35.4
  • libpng-devel >= 1.2.8-19.35.4
  • libpng-x86 >= 1.2.8-19.35.4
Builds
ZYPP Patch Nr: 8043
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • libpng >= 1.2.8-19.35.4
  • libpng-64bit >= 1.2.8-19.35.4
  • libpng-devel >= 1.2.8-19.35.4
  • libpng-devel-64bit >= 1.2.8-19.35.4
Builds
ZYPP Patch Nr: 8043
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libpng-devel >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libpng-devel >= 1.2.31-5.29.1
  • libpng-devel-32bit >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
  • libpng-devel >= 1.2.31-5.29.1
  • libpng12-0 >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
  • libpng-devel >= 1.2.31-5.29.1
  • libpng12-0 >= 1.2.31-5.29.1
  • libpng12-0-32bit >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libpng12-0 >= 1.2.31-5.29.1
  • libpng12-0-32bit >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libpng12-0 >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • libpng12-0 >= 1.2.31-5.29.1
  • libpng12-0-x86 >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
openSUSE 11.4
  • libpng12 >= 1.2.49-16.1
  • libpng12-0 >= 1.2.49-16.1
  • libpng12-0-32bit >= 1.2.49-16.1
  • libpng12-0-debuginfo >= 1.2.49-16.1
  • libpng12-0-debuginfo-32bit >= 1.2.49-16.1
  • libpng12-0-debuginfo-x86 >= 1.2.49-16.1
  • libpng12-0-x86 >= 1.2.49-16.1
  • libpng12-compat-devel >= 1.2.49-16.1
  • libpng12-compat-devel-32bit >= 1.2.49-16.1
  • libpng12-debugsource >= 1.2.49-16.1
  • libpng12-devel >= 1.2.49-16.1
  • libpng12-devel-32bit >= 1.2.49-16.1
  • libpng14 >= 1.4.4-20.1
  • libpng14-14 >= 1.4.4-20.1
  • libpng14-14-32bit >= 1.4.4-20.1
  • libpng14-14-debuginfo >= 1.4.4-20.1
  • libpng14-14-debuginfo-32bit >= 1.4.4-20.1
  • libpng14-14-debuginfo-x86 >= 1.4.4-20.1
  • libpng14-14-x86 >= 1.4.4-20.1
  • libpng14-compat-devel >= 1.4.4-20.1
  • libpng14-compat-devel-32bit >= 1.4.4-20.1
  • libpng14-debugsource >= 1.4.4-20.1
  • libpng14-devel >= 1.4.4-20.1
  • libpng14-devel-32bit >= 1.4.4-20.1
Patchnames:
openSUSE-2012-217
openSUSE 13.2
  • libpng12-0 >= 1.2.51-3.1.2
  • libpng12-0-32bit >= 1.2.51-3.1.2
  • libpng12-compat-devel >= 1.2.51-3.1.2
  • libpng12-devel >= 1.2.51-3.1.2
Patchnames:
openSUSE 13.2 GA libpng12-0
openSUSE Leap 42.1
  • libpng12-0 >= 1.2.50-3.2
  • libpng12-0-32bit >= 1.2.50-3.2
  • libpng12-devel >= 1.2.50-3.2
Patchnames:
openSUSE Leap 42.1 GA libpng12-0
openSUSE Leap 42.2
  • libpng12-0 >= 1.2.50-9.1
  • libpng12-0-32bit >= 1.2.50-9.1
  • libpng12-devel >= 1.2.50-9.1
Patchnames:
openSUSE Leap 42.2 GA libpng12-0
openSUSE Tumbleweed
  • libpng12-0 >= 1.2.56-1.5
  • libpng12-0-32bit >= 1.2.56-1.5
  • libpng12-compat-devel >= 1.2.56-1.5
  • libpng12-compat-devel-32bit >= 1.2.56-1.5
  • libpng12-devel >= 1.2.56-1.5
  • libpng12-devel-32bit >= 1.2.56-1.5
Patchnames:
openSUSE Tumbleweed GA libpng12-0