Upstream information

CVE-2011-2711 at MITRE

Description

Cross-site scripting (XSS) vulnerability in the print_fileinfo function in ui-diff.c in cgit 0.9.0.2 and earlier allows remote authenticated users to inject arbitrary web script or HTML via the filename associated with the rename hint.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.5
Vector AV:N/AC:M/Au:S/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 707929 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.4
  • cgit >= 0.8.3.3-5.7.1
openSUSE 11.4
  • cgit >= 0.8.3.3-5.7.1
  • cgit-debuginfo >= 0.8.3.3-5.7.1
  • cgit-debugsource >= 0.8.3.3-5.7.1
Patchnames:
cgit
openSUSE Tumbleweed
  • cgit >= 1.0-1.3
Patchnames:
openSUSE Tumbleweed GA cgit