Upstream information

CVE-2011-1945 at MITRE

Description

The elliptic curve cryptography (ECC) subsystem in OpenSSL 1.0.0d and earlier, when the Elliptic Curve Digital Signature Algorithm (ECDSA) is used for the ECDHE_ECDSA cipher suite, does not properly implement curves over binary fields, which makes it easier for context-dependent attackers to determine private keys via a timing attack and a lattice calculation.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.6
Vector AV:N/AC:H/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 693027 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libopenssl-devel >= 0.9.8j-0.66.1
  • libopenssl0_9_8 >= 0.9.8h-30.34.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.34.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.44.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.44.1
  • libopenssl0_9_8-hmac-x86 >= 0.9.8j-0.44.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.44.1
  • openssl >= 0.9.8h-30.34.1
  • openssl-doc >= 0.9.8h-30.34.1
Patchnames:
slessp1-libopenssl-devel
openSUSE 11.3
  • libopenssl1_0_0-debuginfo >= 1.0.0-6.9.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.0-6.9.1
  • openssl-debuginfo >= 1.0.0-6.9.1
  • openssl-debugsource >= 1.0.0-6.9.1
openSUSE 11.3
  • libopenssl-devel >= 1.0.0-6.9.1
  • libopenssl1_0_0 >= 1.0.0-6.9.1
  • libopenssl1_0_0-32bit >= 1.0.0-6.9.1
  • openssl >= 1.0.0-6.9.1
  • openssl-doc >= 1.0.0-6.9.1
openSUSE 11.4
  • libopenssl-devel >= 1.0.0c-18.19.2
  • libopenssl1_0_0 >= 1.0.0c-18.19.2
  • libopenssl1_0_0-32bit >= 1.0.0c-18.19.2
  • openssl >= 1.0.0c-18.19.2
  • openssl-doc >= 1.0.0c-18.19.2
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libopenssl-devel >= 0.9.8h-30.34.1
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.s390x
sle11-sp1-sdk.ppc
sles11-sp1.ppc
sles11-sp1.x86
sled11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.s390x
SAT Patch Nr: 4662
SUSE Linux Enterprise Desktop 11 SP1
  • libopenssl0_9_8 >= 0.9.8h-30.34.1
  • openssl >= 0.9.8h-30.34.1
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.s390x
sle11-sp1-sdk.ppc
sles11-sp1.ppc
sles11-sp1.x86
sled11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.s390x
SAT Patch Nr: 4662
SUSE Linux Enterprise Desktop 11 SP1
  • libopenssl0_9_8 >= 0.9.8h-30.34.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.34.1
  • openssl >= 0.9.8h-30.34.1
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.s390x
sle11-sp1-sdk.ppc
sles11-sp1.ppc
sles11-sp1.x86
sled11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.s390x
SAT Patch Nr: 4662
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libopenssl0_9_8 >= 0.9.8h-30.34.1
  • openssl >= 0.9.8h-30.34.1
  • openssl-doc >= 0.9.8h-30.34.1
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.s390x
sle11-sp1-sdk.ppc
sles11-sp1.ppc
sles11-sp1.x86
sled11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.s390x
SAT Patch Nr: 4662
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libopenssl0_9_8 >= 0.9.8h-30.34.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.34.1
  • openssl >= 0.9.8h-30.34.1
  • openssl-doc >= 0.9.8h-30.34.1
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.s390x
sle11-sp1-sdk.ppc
sles11-sp1.ppc
sles11-sp1.x86
sled11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.s390x
SAT Patch Nr: 4662
SUSE Linux Enterprise Server 11 SP1
  • libopenssl0_9_8 >= 0.9.8h-30.34.1
  • libopenssl0_9_8-x86 >= 0.9.8h-30.34.1
  • openssl >= 0.9.8h-30.34.1
  • openssl-doc >= 0.9.8h-30.34.1
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.s390x
sle11-sp1-sdk.ppc
sles11-sp1.ppc
sles11-sp1.x86
sled11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.s390x
SAT Patch Nr: 4662
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • openssl >= 0.9.8a-18.45.47.1
  • openssl-32bit >= 0.9.8a-18.45.47.1
  • openssl-devel >= 0.9.8a-18.45.47.1
  • openssl-devel-32bit >= 0.9.8a-18.45.47.1
  • openssl-doc >= 0.9.8a-18.45.47.1
sles10-sp3.x86
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ia64
sles10-sp3-debuginfo.ia64
sles10-sp3.x86-64
sle10-sp3-sdk.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.ia64
ZYPP Patch Nr: 7552
SUSE Linux Enterprise SDK 10 SP3
  • openssl-doc >= 0.9.8a-18.45.47.1
sles10-sp3.x86
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ia64
sles10-sp3-debuginfo.ia64
sles10-sp3.x86-64
sle10-sp3-sdk.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.ia64
ZYPP Patch Nr: 7552
SUSE Linux Enterprise Server 10 SP3
  • openssl >= 0.9.8a-18.45.47.1
  • openssl-devel >= 0.9.8a-18.45.47.1
  • openssl-doc >= 0.9.8a-18.45.47.1
sles10-sp3.x86
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ia64
sles10-sp3-debuginfo.ia64
sles10-sp3.x86-64
sle10-sp3-sdk.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.ia64
ZYPP Patch Nr: 7552
SUSE Linux Enterprise Server 10 SP3
  • openssl >= 0.9.8a-18.45.47.1
  • openssl-devel >= 0.9.8a-18.45.47.1
  • openssl-doc >= 0.9.8a-18.45.47.1
  • openssl-x86 >= 0.9.8a-18.45.47.1
sles10-sp3.x86
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ia64
sles10-sp3-debuginfo.ia64
sles10-sp3.x86-64
sle10-sp3-sdk.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.ia64
ZYPP Patch Nr: 7552
SUSE Linux Enterprise Server 10 SP3
  • openssl >= 0.9.8a-18.45.47.1
  • openssl-64bit >= 0.9.8a-18.45.47.1
  • openssl-devel >= 0.9.8a-18.45.47.1
  • openssl-devel-64bit >= 0.9.8a-18.45.47.1
  • openssl-doc >= 0.9.8a-18.45.47.1
sles10-sp3.x86
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ia64
sles10-sp3-debuginfo.ia64
sles10-sp3.x86-64
sle10-sp3-sdk.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.ia64
ZYPP Patch Nr: 7552
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • openssl >= 0.9.8a-18.52.1
  • openssl-devel >= 0.9.8a-18.52.1
sle10-sp4-sdk.ppc
sles10-sp4-debuginfo.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.s390x
sles10-sp4.ia64
sles10-sp4-debuginfo.ia64
sles10-sp4.s390x
sle10-sp4-sdk.x86
sles10-sp4-debuginfo.s390x
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sled10-sp4.x86
sles10-sp4.x86-64
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.ppc
sle10-sp4-sdk.ia64
ZYPP Patch Nr: 7550
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
  • openssl >= 0.9.8a-18.52.1
  • openssl-32bit >= 0.9.8a-18.52.1
  • openssl-devel >= 0.9.8a-18.52.1
  • openssl-devel-32bit >= 0.9.8a-18.52.1
sle10-sp4-sdk.ppc
sles10-sp4-debuginfo.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.s390x
sles10-sp4.ia64
sles10-sp4-debuginfo.ia64
sles10-sp4.s390x
sle10-sp4-sdk.x86
sles10-sp4-debuginfo.s390x
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sled10-sp4.x86
sles10-sp4.x86-64
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.ppc
sle10-sp4-sdk.ia64
ZYPP Patch Nr: 7550
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • openssl-doc >= 0.9.8a-18.52.1
sle10-sp4-sdk.ppc
sles10-sp4-debuginfo.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.s390x
sles10-sp4.ia64
sles10-sp4-debuginfo.ia64
sles10-sp4.s390x
sle10-sp4-sdk.x86
sles10-sp4-debuginfo.s390x
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sled10-sp4.x86
sles10-sp4.x86-64
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.ppc
sle10-sp4-sdk.ia64
ZYPP Patch Nr: 7550
SUSE Linux Enterprise Server 10 SP4 for x86
  • openssl >= 0.9.8a-18.52.1
  • openssl-devel >= 0.9.8a-18.52.1
  • openssl-doc >= 0.9.8a-18.52.1
sle10-sp4-sdk.ppc
sles10-sp4-debuginfo.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.s390x
sles10-sp4.ia64
sles10-sp4-debuginfo.ia64
sles10-sp4.s390x
sle10-sp4-sdk.x86
sles10-sp4-debuginfo.s390x
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sled10-sp4.x86
sles10-sp4.x86-64
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.ppc
sle10-sp4-sdk.ia64
ZYPP Patch Nr: 7550
SUSE Linux Enterprise Server 10 SP4 for IPF
  • openssl >= 0.9.8a-18.52.1
  • openssl-devel >= 0.9.8a-18.52.1
  • openssl-doc >= 0.9.8a-18.52.1
  • openssl-x86 >= 0.9.8a-18.52.1
sle10-sp4-sdk.ppc
sles10-sp4-debuginfo.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.s390x
sles10-sp4.ia64
sles10-sp4-debuginfo.ia64
sles10-sp4.s390x
sle10-sp4-sdk.x86
sles10-sp4-debuginfo.s390x
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sled10-sp4.x86
sles10-sp4.x86-64
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.ppc
sle10-sp4-sdk.ia64
ZYPP Patch Nr: 7550
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • openssl >= 0.9.8a-18.52.1
  • openssl-64bit >= 0.9.8a-18.52.1
  • openssl-devel >= 0.9.8a-18.52.1
  • openssl-devel-64bit >= 0.9.8a-18.52.1
  • openssl-doc >= 0.9.8a-18.52.1
sle10-sp4-sdk.ppc
sles10-sp4-debuginfo.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.s390x
sles10-sp4.ia64
sles10-sp4-debuginfo.ia64
sles10-sp4.s390x
sle10-sp4-sdk.x86
sles10-sp4-debuginfo.s390x
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sled10-sp4.x86
sles10-sp4.x86-64
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.ppc
sle10-sp4-sdk.ia64
ZYPP Patch Nr: 7550
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • openssl >= 0.9.8a-18.52.1
  • openssl-32bit >= 0.9.8a-18.52.1
  • openssl-devel >= 0.9.8a-18.52.1
  • openssl-devel-32bit >= 0.9.8a-18.52.1
  • openssl-doc >= 0.9.8a-18.52.1
sle10-sp4-sdk.ppc
sles10-sp4-debuginfo.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.s390x
sles10-sp4.ia64
sles10-sp4-debuginfo.ia64
sles10-sp4.s390x
sle10-sp4-sdk.x86
sles10-sp4-debuginfo.s390x
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sled10-sp4.x86
sles10-sp4.x86-64
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.ppc
sle10-sp4-sdk.ia64
ZYPP Patch Nr: 7550
openSUSE 11.4
  • libopenssl-devel >= 1.0.0c-18.19.2
  • libopenssl1_0_0 >= 1.0.0c-18.19.2
  • libopenssl1_0_0-32bit >= 1.0.0c-18.19.2
  • libopenssl1_0_0-debuginfo >= 1.0.0c-18.19.2
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.0c-18.19.2
  • openssl >= 1.0.0c-18.19.2
  • openssl-debuginfo >= 1.0.0c-18.19.2
  • openssl-debugsource >= 1.0.0c-18.19.2
  • openssl-doc >= 1.0.0c-18.19.2
Patchnames:
libopenssl-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 openssl Released
SUSE Linux Enterprise Desktop 10 SP4 openssl Released
SUSE Linux Enterprise Desktop 11 SP1 openssl Released
SUSE Linux Enterprise Desktop 11 SP2 openssl Released
SUSE Linux Enterprise Desktop 11 SP3 openssl Released
SUSE Linux Enterprise Desktop 11 SP4 openssl Released
SUSE Linux Enterprise SDK 11 SP1 openssl Released
SUSE Linux Enterprise SDK 11 SP2 openssl Released
SUSE Linux Enterprise SDK 11 SP3 openssl Released
SUSE Linux Enterprise SDK 11 SP4 openssl Released
SUSE Linux Enterprise Server 10 SP3 openssl Released
SUSE Linux Enterprise Server 10 SP4 openssl Released
SUSE Linux Enterprise Server 10 SP4 LTSS openssl Released
SUSE Linux Enterprise Server 11 SP1 openssl Released
SUSE Linux Enterprise Server 11 SP1 LTSS openssl Released
SUSE Linux Enterprise Server 11 SP2 openssl Released
SUSE Linux Enterprise Server 11 SP2 LTSS openssl Released
SUSE Linux Enterprise Server 11 SP3 openssl Released
SUSE Linux Enterprise Server 11 SP3 LTSS openssl Released
SUSE Linux Enterprise Server 11 SP4 openssl Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 openssl Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 openssl Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 openssl Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 openssl Released
SUSE Linux Enterprise Server for VMWare 11 SP2 openssl Released
SUSE Linux Enterprise Server for VMWare 11 SP3 openssl Released
SUSE Studio Onsite 1.3 openssl Released