Upstream information

CVE-2011-1774 at MITRE

Description

WebKit in Apple Safari before 5.0.6 has improper libxslt security settings, which allows remote attackers to create arbitrary files, and consequently execute arbitrary code, via a crafted web site. NOTE: this may overlap CVE-2011-1425.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:M/Au:N/C:N/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 692619 [RESOLVED / WONTFIX]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libwebkit-1_0-2 >= 1.2.7-0.17.1
  • libwebkit-devel >= 1.2.7-0.17.1
  • libwebkit-lang >= 1.2.7-0.17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libwebkit-1_0-2
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libwebkit-1_0-2 >= 1.2.7-0.13.1
  • libwebkit-devel >= 1.2.7-0.13.1
  • libwebkit-lang >= 1.2.7-0.13.1
Builds
SAT Patch Nr: 4917
SUSE Linux Enterprise Desktop 11 SP1
  • libwebkit-1_0-2 >= 1.2.7-0.13.1
  • libwebkit-lang >= 1.2.7-0.13.1
Builds
SAT Patch Nr: 4917


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 libwebkit Released
SUSE Linux Enterprise SDK 11 SP1 libwebkit Released