Upstream information

CVE-2011-1407 at MITRE

Description

The DKIM implementation in Exim 4.7x before 4.76 permits matching for DKIM identities to apply to lookup items, instead of only strings, which allows remote attackers to execute arbitrary code or access a filesystem via a crafted identity.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 694798 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.3
  • exim-debuginfo >= 4.71-4.9.1
  • exim-debugsource >= 4.71-4.9.1
  • eximon-debuginfo >= 4.71-4.9.1
openSUSE 11.3
  • exim >= 4.71-4.9.1
  • eximon >= 4.71-4.9.1
  • eximstats-html >= 4.71-4.9.1
openSUSE 11.4
  • exim >= 4.74-6.9.1
  • eximon >= 4.74-6.9.1
  • eximstats-html >= 4.74-6.9.1
openSUSE 11.4
  • exim >= 4.74-6.9.1
  • exim-debuginfo >= 4.74-6.9.1
  • exim-debugsource >= 4.74-6.9.1
  • eximon >= 4.74-6.9.1
  • eximon-debuginfo >= 4.74-6.9.1
  • eximstats-html >= 4.74-6.9.1
Patchnames:
exim
openSUSE 13.1
  • exim >= 4.83-6.4.1
  • exim-debuginfo >= 4.83-6.4.1
  • exim-debugsource >= 4.83-6.4.1
  • eximon >= 4.83-6.4.1
  • eximon-debuginfo >= 4.83-6.4.1
  • eximstats-html >= 4.83-6.4.1
Patchnames:
openSUSE-2014-482
openSUSE Tumbleweed
  • exim >= 4.86.2-2.2
  • eximon >= 4.86.2-2.2
  • eximstats-html >= 4.86.2-2.2
Patchnames:
openSUSE Tumbleweed GA exim