Upstream information

CVE-2011-1094 at MITRE

Description

kio/kio/tcpslavebase.cpp in KDE KSSL in kdelibs before 4.6.1 does not properly verify that the server hostname matches the domain name of the subject of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a certificate issued by a legitimate Certification Authority for an IP address, a different vulnerability than CVE-2009-2702.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 669222 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • kdelibs4 >= 4.3.5-0.4.1
  • kdelibs4-core >= 4.3.5-0.4.1
  • kdelibs4-doc >= 4.3.5-0.4.1
  • libkde4 >= 4.3.5-0.4.1
  • libkde4-32bit >= 4.3.5-0.4.1
  • libkde4-x86 >= 4.3.5-0.6.1
  • libkdecore4 >= 4.3.5-0.4.1
  • libkdecore4-32bit >= 4.3.5-0.4.1
  • libkdecore4-x86 >= 4.3.5-0.6.1
Patchnames:
slessp1-kdelibs4
openSUSE 11.2
  • kdelibs4-core-debuginfo >= 4.3.5-0.3.1
  • kdelibs4-debuginfo >= 4.3.5-0.3.1
  • kdelibs4-debugsource >= 4.3.5-0.3.1
  • kdelibs4-doc-debuginfo >= 4.3.5-0.3.1
  • libkde4-debuginfo >= 4.3.5-0.3.1
  • libkde4-debuginfo-32bit >= 4.3.5-0.3.1
  • libkdecore4-debuginfo >= 4.3.5-0.3.1
  • libkdecore4-debuginfo-32bit >= 4.3.5-0.3.1
  • libkdecore4-devel-debuginfo >= 4.3.5-0.3.1
openSUSE 11.2
  • kdelibs4 >= 4.3.5-0.3.1
  • kdelibs4-branding-upstream >= 4.3.5-0.3.1
  • kdelibs4-core >= 4.3.5-0.3.1
  • kdelibs4-doc >= 4.3.5-0.3.1
  • libkde4 >= 4.3.5-0.3.1
  • libkde4-32bit >= 4.3.5-0.3.1
  • libkde4-devel >= 4.3.5-0.3.1
  • libkdecore4 >= 4.3.5-0.3.1
  • libkdecore4-32bit >= 4.3.5-0.3.1
  • libkdecore4-devel >= 4.3.5-0.3.1
openSUSE 11.3
  • kdelibs4-core-debuginfo >= 4.4.4-3.4.1
  • kdelibs4-debuginfo >= 4.4.4-3.4.1
  • kdelibs4-debugsource >= 4.4.4-3.4.1
  • kdelibs4-doc-debuginfo >= 4.4.4-3.4.1
  • libkde4-debuginfo >= 4.4.4-3.4.1
  • libkde4-debuginfo-32bit >= 4.4.4-3.4.1
  • libkdecore4-debuginfo >= 4.4.4-3.4.1
  • libkdecore4-debuginfo-32bit >= 4.4.4-3.4.1
  • libkdecore4-devel-debuginfo >= 4.4.4-3.4.1
  • libksuseinstall1-debuginfo >= 4.4.4-3.4.1
  • libksuseinstall1-debuginfo-32bit >= 4.4.4-3.4.1
openSUSE 11.3
  • kdelibs4 >= 4.4.4-3.4.1
  • kdelibs4-branding-upstream >= 4.4.4-3.4.1
  • kdelibs4-core >= 4.4.4-3.4.1
  • kdelibs4-doc >= 4.4.4-3.4.1
  • libkde4 >= 4.4.4-3.4.1
  • libkde4-32bit >= 4.4.4-3.4.1
  • libkde4-devel >= 4.4.4-3.4.1
  • libkdecore4 >= 4.4.4-3.4.1
  • libkdecore4-32bit >= 4.4.4-3.4.1
  • libkdecore4-devel >= 4.4.4-3.4.1
  • libksuseinstall-devel >= 4.4.4-3.4.1
  • libksuseinstall1 >= 4.4.4-3.4.1
  • libksuseinstall1-32bit >= 4.4.4-3.4.1
openSUSE 11.4
  • kdelibs4 >= 4.6.0-6.13.1
  • kdelibs4-branding-upstream >= 4.6.0-6.13.1
  • kdelibs4-core >= 4.6.0-6.13.1
  • kdelibs4-doc >= 4.6.0-6.13.1
  • libkde4 >= 4.6.0-6.13.1
  • libkde4-32bit >= 4.6.0-6.13.1
  • libkde4-devel >= 4.6.0-6.13.1
  • libkdecore4 >= 4.6.0-6.13.1
  • libkdecore4-32bit >= 4.6.0-6.13.1
  • libkdecore4-devel >= 4.6.0-6.13.1
  • libksuseinstall-devel >= 4.6.0-6.13.1
  • libksuseinstall1 >= 4.6.0-6.13.1
  • libksuseinstall1-32bit >= 4.6.0-6.13.1
SUSE Linux Enterprise Software Development Kit 11 SP1
  • kdelibs4-doc >= 4.3.5-0.4.1
  • libkde4-devel >= 4.3.5-0.4.1
  • libkdecore4-devel >= 4.3.5-0.4.1
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
sle11-sp1-sdk.x86
sles11-sp1-vmware.x86
sled11-sp1.x86
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
SAT Patch Nr: 4217
SUSE Linux Enterprise Software Development Kit 11 SP1
  • kdelibs4-doc >= 4.3.5-0.4.1
  • libkde4-32bit >= 4.3.5-0.4.1
  • libkde4-devel >= 4.3.5-0.4.1
  • libkdecore4-32bit >= 4.3.5-0.4.1
  • libkdecore4-devel >= 4.3.5-0.4.1
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
sle11-sp1-sdk.x86
sles11-sp1-vmware.x86
sled11-sp1.x86
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
SAT Patch Nr: 4217
SUSE Linux Enterprise Desktop 11 SP1
  • kdelibs4 >= 4.3.5-0.4.1
  • kdelibs4-core >= 4.3.5-0.4.1
  • libkde4 >= 4.3.5-0.4.1
  • libkdecore4 >= 4.3.5-0.4.1
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
sle11-sp1-sdk.x86
sles11-sp1-vmware.x86
sled11-sp1.x86
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
SAT Patch Nr: 4217
SUSE Linux Enterprise Desktop 11 SP1
  • kdelibs4 >= 4.3.5-0.4.1
  • kdelibs4-core >= 4.3.5-0.4.1
  • libkde4 >= 4.3.5-0.4.1
  • libkde4-32bit >= 4.3.5-0.4.1
  • libkdecore4 >= 4.3.5-0.4.1
  • libkdecore4-32bit >= 4.3.5-0.4.1
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
sle11-sp1-sdk.x86
sles11-sp1-vmware.x86
sled11-sp1.x86
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
SAT Patch Nr: 4217
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • kdelibs4 >= 4.3.5-0.4.1
  • kdelibs4-core >= 4.3.5-0.4.1
  • kdelibs4-doc >= 4.3.5-0.4.1
  • libkde4 >= 4.3.5-0.4.1
  • libkdecore4 >= 4.3.5-0.4.1
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
sle11-sp1-sdk.x86
sles11-sp1-vmware.x86
sled11-sp1.x86
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
SAT Patch Nr: 4217
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • kdelibs4 >= 4.3.5-0.4.1
  • kdelibs4-core >= 4.3.5-0.4.1
  • kdelibs4-doc >= 4.3.5-0.4.1
  • libkde4 >= 4.3.5-0.4.1
  • libkde4-32bit >= 4.3.5-0.4.1
  • libkdecore4 >= 4.3.5-0.4.1
  • libkdecore4-32bit >= 4.3.5-0.4.1
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
sle11-sp1-sdk.x86
sles11-sp1-vmware.x86
sled11-sp1.x86
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
SAT Patch Nr: 4217
SUSE Linux Enterprise Server 11 SP1
  • kdelibs4 >= 4.3.5-0.4.1
  • kdelibs4-core >= 4.3.5-0.4.1
  • kdelibs4-doc >= 4.3.5-0.4.1
  • libkde4 >= 4.3.5-0.4.1
  • libkde4-x86 >= 4.3.5-0.4.1
  • libkdecore4 >= 4.3.5-0.4.1
  • libkdecore4-x86 >= 4.3.5-0.4.1
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
sle11-sp1-sdk.x86
sles11-sp1-vmware.x86
sled11-sp1.x86
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
SAT Patch Nr: 4217
openSUSE 11.4
  • kdelibs4 >= 4.6.0-6.13.1
  • kdelibs4-branding-upstream >= 4.6.0-6.13.1
  • kdelibs4-core >= 4.6.0-6.13.1
  • kdelibs4-core-debuginfo >= 4.6.0-6.13.1
  • kdelibs4-debuginfo >= 4.6.0-6.13.1
  • kdelibs4-debugsource >= 4.6.0-6.13.1
  • kdelibs4-doc >= 4.6.0-6.13.1
  • kdelibs4-doc-debuginfo >= 4.6.0-6.13.1
  • libkde4 >= 4.6.0-6.13.1
  • libkde4-32bit >= 4.6.0-6.13.1
  • libkde4-debuginfo >= 4.6.0-6.13.1
  • libkde4-debuginfo-32bit >= 4.6.0-6.13.1
  • libkde4-devel >= 4.6.0-6.13.1
  • libkdecore4 >= 4.6.0-6.13.1
  • libkdecore4-32bit >= 4.6.0-6.13.1
  • libkdecore4-debuginfo >= 4.6.0-6.13.1
  • libkdecore4-debuginfo-32bit >= 4.6.0-6.13.1
  • libkdecore4-devel >= 4.6.0-6.13.1
  • libkdecore4-devel-debuginfo >= 4.6.0-6.13.1
  • libksuseinstall-devel >= 4.6.0-6.13.1
  • libksuseinstall1 >= 4.6.0-6.13.1
  • libksuseinstall1-32bit >= 4.6.0-6.13.1
  • libksuseinstall1-debuginfo >= 4.6.0-6.13.1
  • libksuseinstall1-debuginfo-32bit >= 4.6.0-6.13.1
Patchnames:
kdelibs4


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 kdelibs4 Released
SUSE Linux Enterprise Desktop 11 SP2 kdelibs4 Released
SUSE Linux Enterprise Desktop 11 SP3 kdelibs4 Released
SUSE Linux Enterprise Desktop 11 SP4 kdelibs4 Released
SUSE Linux Enterprise SDK 11 SP1 kdelibs4 Released
SUSE Linux Enterprise SDK 11 SP2 kdelibs4 Released
SUSE Linux Enterprise SDK 11 SP3 kdelibs4 Released
SUSE Linux Enterprise SDK 11 SP4 kdelibs4 Released
SUSE Linux Enterprise Server 11 SP1 kdelibs4 Released
SUSE Linux Enterprise Server 11 SP1 LTSS kdelibs4 Released
SUSE Linux Enterprise Server 11 SP2 kdelibs4 Released
SUSE Linux Enterprise Server 11 SP2 LTSS kdelibs4 Released
SUSE Linux Enterprise Server 11 SP3 kdelibs4 Released
SUSE Linux Enterprise Server 11 SP3 LTSS kdelibs4 Released
SUSE Linux Enterprise Server 11 SP4 kdelibs4 Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 kdelibs4 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 kdelibs4 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 kdelibs4 Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 kdelibs4 Released
SUSE Linux Enterprise Server for VMWare 11 SP2 kdelibs4 Released
SUSE Linux Enterprise Server for VMWare 11 SP3 kdelibs4 Released