Upstream information

CVE-2011-1022 at MITRE

Description

The cgre_receive_netlink_msg function in daemon/cgrulesengd.c in cgrulesengd in the Control Group Configuration Library (aka libcgroup or libcg) before 0.37.1 does not verify that netlink messages originated in the kernel, which allows local users to bypass intended resource restrictions via a crafted message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:P/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 675048 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libcgroup1 >= 0.41.rc1-1.30
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libcgroup1
SUSE Linux Enterprise Desktop 12 SP1
  • libcgroup1 >= 0.41.rc1-4.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libcgroup1
SUSE Linux Enterprise Desktop 12 SP2
  • libcgroup1 >= 0.41.rc1-4.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libcgroup1
SUSE Linux Enterprise Desktop 12 SP3
  • libcgroup1 >= 0.41.rc1-9.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libcgroup1
SUSE Linux Enterprise Server 11 SP1
  • libcgroup1 >= 0.34-2.5.1
Patchnames:
slessp1-libcgroup-devel
SUSE Linux Enterprise Server 11 SP2
  • libcgroup1 >= 0.34-2.5.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libcgroup1
SUSE Linux Enterprise Server 11 SP3
  • libcgroup1 >= 0.37.1-5.16.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libcgroup1
SUSE Linux Enterprise Server 11 SP4
  • libcgroup1 >= 0.41.rc1-2.34
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libcgroup1
SUSE Linux Enterprise Server 12
  • libcgroup-tools >= 0.41.rc1-1.30
  • libcgroup1 >= 0.41.rc1-1.30
Patchnames:
SUSE Linux Enterprise Server 12 GA libcgroup-tools
SUSE Linux Enterprise Server 12 SP1
  • libcgroup-tools >= 0.41.rc1-4.1
  • libcgroup1 >= 0.41.rc1-4.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libcgroup-tools
SUSE Linux Enterprise Server 12 SP2
  • libcgroup-tools >= 0.41.rc1-4.1
  • libcgroup1 >= 0.41.rc1-4.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libcgroup-tools
SUSE Linux Enterprise Server 12 SP3
  • libcgroup-tools >= 0.41.rc1-9.1
  • libcgroup1 >= 0.41.rc1-9.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libcgroup-tools
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libcgroup-tools >= 0.41.rc1-4.1
  • libcgroup1 >= 0.41.rc1-4.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libcgroup-tools
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libcgroup-devel >= 0.41.rc1-2.34
  • libcgroup1 >= 0.41.rc1-2.34
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libcgroup-devel
SUSE Linux Enterprise Software Development Kit 12
  • libcgroup-devel >= 0.41.rc1-1.30
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libcgroup-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libcgroup-devel >= 0.41.rc1-4.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libcgroup-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libcgroup-devel >= 0.41.rc1-4.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libcgroup-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libcgroup-devel >= 0.41.rc1-9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libcgroup-devel
openSUSE 11.2
  • libcgroup1-debuginfo >= 0.34-3.3.1
  • libcgroup1-debuginfo-32bit >= 0.34-3.3.1
  • libcgroup1-debugsource >= 0.34-3.3.1
openSUSE 11.2
  • libcgroup-devel >= 0.34-3.3.1
  • libcgroup1 >= 0.34-3.3.1
  • libcgroup1-32bit >= 0.34-3.3.1
openSUSE 11.3
  • libcgroup1-debuginfo >= 0.36.2-2.3.1
  • libcgroup1-debuginfo-32bit >= 0.36.2-2.3.1
  • libcgroup1-debugsource >= 0.36.2-2.3.1
openSUSE 11.3
  • libcgroup-devel >= 0.36.2-2.3.1
  • libcgroup1 >= 0.36.2-2.3.1
  • libcgroup1-32bit >= 0.36.2-2.3.1
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libcgroup-devel >= 0.34-2.5.1
  • libcgroup1 >= 0.34-2.5.1
sles11-sp1.s390x
sles11-sp1.ppc
sles11-sp1-vmware.x86
sles11-sp1.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ia64
sles11-sp1.x86
SAT Patch Nr: 4081
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libcgroup-devel >= 0.34-2.5.1
sles11-sp1.s390x
sles11-sp1.ppc
sles11-sp1-vmware.x86
sles11-sp1.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ia64
sles11-sp1.x86
SAT Patch Nr: 4081
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libcgroup1 >= 0.34-2.5.1
sles11-sp1.s390x
sles11-sp1.ppc
sles11-sp1-vmware.x86
sles11-sp1.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ia64
sles11-sp1.x86
SAT Patch Nr: 4081
openSUSE 11.4
  • libcgroup-devel >= 0.36.2-6.3.1
  • libcgroup1 >= 0.36.2-6.3.1
  • libcgroup1-32bit >= 0.36.2-6.3.1
openSUSE 11.4
  • libcgroup-devel >= 0.36.2-6.3.1
  • libcgroup1 >= 0.36.2-6.3.1
  • libcgroup1-32bit >= 0.36.2-6.3.1
  • libcgroup1-debuginfo >= 0.36.2-6.3.1
  • libcgroup1-debuginfo-32bit >= 0.36.2-6.3.1
  • libcgroup1-debugsource >= 0.36.2-6.3.1
Patchnames:
libcgroup-devel
openSUSE Tumbleweed
  • libcgroup-devel >= 0.41-2.8
  • libcgroup-tools >= 0.41-2.8
  • libcgroup1 >= 0.41-2.8
  • libcgroup1-32bit >= 0.41-2.8
Patchnames:
openSUSE Tumbleweed GA libcgroup-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP1 libcgroup1 Released
SUSE Linux Enterprise Server 11 SP1 libcgroup1 Released
SUSE Linux Enterprise Server 11 SP1 LTSS libcgroup1 Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 libcgroup1 Released