Upstream information

CVE-2011-0633 at MITRE

Description

The Net::HTTPS module in libwww-perl (LWP) before 6.00, as used in WWW::Mechanize, LWP::UserAgent, and other products, when running in environments that do not set the If-SSL-Cert-Subject header, does not enable full validation of SSL certificates by default, which allows remote attackers to spoof servers via man-in-the-middle (MITM) attacks involving hostnames that are not properly validated. NOTE: it could be argued that this is a design limitation of the Net::HTTPS API, and separate implementations should be independently assigned CVE identifiers for not working around this limitation. However, because this API was modified within LWP, a single CVE identifier has been assigned.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 693999 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • perl-libwww-perl >= 5.816-2.17.1
Patchnames:
slessp1-perl-libwww-perl
SUSE Linux Enterprise Server 11 SP2
  • perl-libwww-perl >= 5.816-2.23.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA perl-libwww-perl
SUSE Linux Enterprise Server 11 SP3
  • perl-libwww-perl >= 5.816-2.23.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA perl-libwww-perl
SUSE Linux Enterprise Server 11 SP4
  • perl-libwww-perl >= 5.816-2.23.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA perl-libwww-perl
openSUSE 11.4
  • perl-libwww-perl >= 5.837-5.7.1
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • perl-libwww-perl >= 5.816-2.17.1
sles11-sp1-vmware.x86-64
sles11-sp1.x86-64
sled11-sp1.x86
sles11-sp1.ppc
sles11-sp1.ia64
sles11-sp1.x86
sled11-sp1.x86-64
sles11-sp1.s390x
sles11-sp1-vmware.x86
SAT Patch Nr: 4603
openSUSE 11.4
  • perl-libwww-perl >= 5.837-5.7.1
Patchnames:
perl-libwww-perl


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 perl-libwww-perl Released
SUSE Linux Enterprise Server 11 SP1 perl-libwww-perl Released
SUSE Linux Enterprise Server 11 SP1 LTSS perl-libwww-perl Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 perl-libwww-perl Released