Upstream information

CVE-2011-0463 at MITRE

Description

The ocfs2_prepare_page_for_write function in fs/ocfs2/aops.c in the Oracle Cluster File System 2 (OCFS2) subsystem in the Linux kernel before 2.6.39-rc1 does not properly handle holes that cross page boundaries, which allows local users to obtain potentially sensitive information from uninitialized disk locations by reading a file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 670595 [RESOLVED / FIXED], 673037 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability Extension 11 SP1
  • cluster-glue >= 1.0.7-6.6.3
  • corosync >= 1.3.0-5.6.1
  • hawk >= 0.3.6-1.3.6
  • ldirectord >= 1.0.3-0.10.1
  • libcorosync-devel >= 1.3.0-5.6.1
  • libcorosync4 >= 1.3.0-5.6.1
  • libdlm >= 3.00.01-0.10.6
  • libdlm-devel >= 3.00.01-0.10.6
  • libdlm3 >= 3.00.01-0.10.6
  • libglue-devel >= 1.0.7-6.6.3
  • libglue2 >= 1.0.7-6.6.3
  • libopenais-devel >= 1.1.4-5.4.3
  • libopenais3 >= 1.1.4-5.4.3
  • libpacemaker-devel >= 1.1.5-5.5.5
  • libpacemaker3 >= 1.1.5-5.5.5
  • ocfs2-kmp-default >= 1.4_2.6.32.29_0.3-4.15.3
  • ocfs2-kmp-pae >= 1.4_2.6.32.29_0.3-4.15.3
  • ocfs2-kmp-xen >= 1.4_2.6.32.29_0.3-4.15.3
  • ocfs2-tools >= 1.4.3-0.16.7
  • ocfs2-tools-devel >= 1.4.3-0.16.7
  • ocfs2-tools-o2cb >= 1.4.3-0.16.7
  • ocfs2console >= 1.4.3-0.16.7
  • openais >= 1.1.4-5.4.3
  • pacemaker >= 1.1.5-5.5.5
  • pacemaker-mgmt >= 2.0.0-0.5.5
  • pacemaker-mgmt-client >= 2.0.0-0.5.5
  • pacemaker-mgmt-devel >= 2.0.0-0.5.5
  • release-notes-hae >= 10.2.0.3-9.19.2
  • resource-agents >= 1.0.3-0.10.1
sle11-sp1-hae.s390x
sle11-sp1-hae.ia64
sle11-sp1-hae.ppc
sle11-sp1-hae.x86-64
sle11-sp1-hae.x86
SAT Patch Nr: 4124
SUSE Linux Enterprise High Availability Extension 11 SP1
  • cluster-glue >= 1.0.7-6.6.3
  • corosync >= 1.3.0-5.6.1
  • hawk >= 0.3.6-1.3.6
  • ldirectord >= 1.0.3-0.10.1
  • libcorosync-devel >= 1.3.0-5.6.1
  • libcorosync4 >= 1.3.0-5.6.1
  • libdlm >= 3.00.01-0.10.6
  • libdlm-devel >= 3.00.01-0.10.6
  • libdlm3 >= 3.00.01-0.10.6
  • libglue-devel >= 1.0.7-6.6.3
  • libglue2 >= 1.0.7-6.6.3
  • libopenais-devel >= 1.1.4-5.4.3
  • libopenais3 >= 1.1.4-5.4.3
  • libpacemaker-devel >= 1.1.5-5.5.5
  • libpacemaker3 >= 1.1.5-5.5.5
  • ocfs2-kmp-default >= 1.4_2.6.32.29_0.3-4.15.3
  • ocfs2-tools >= 1.4.3-0.16.7
  • ocfs2-tools-devel >= 1.4.3-0.16.7
  • ocfs2-tools-o2cb >= 1.4.3-0.16.7
  • ocfs2console >= 1.4.3-0.16.7
  • openais >= 1.1.4-5.4.3
  • pacemaker >= 1.1.5-5.5.5
  • pacemaker-mgmt >= 2.0.0-0.5.5
  • pacemaker-mgmt-client >= 2.0.0-0.5.5
  • pacemaker-mgmt-devel >= 2.0.0-0.5.5
  • release-notes-hae >= 10.2.0.3-9.19.2
  • resource-agents >= 1.0.3-0.10.1
sle11-sp1-hae.s390x
sle11-sp1-hae.ia64
sle11-sp1-hae.ppc
sle11-sp1-hae.x86-64
sle11-sp1-hae.x86
SAT Patch Nr: 4124
SUSE Linux Enterprise High Availability Extension 11 SP1
  • cluster-glue >= 1.0.7-6.6.3
  • corosync >= 1.3.0-5.6.1
  • hawk >= 0.3.6-1.3.6
  • ldirectord >= 1.0.3-0.10.1
  • libcorosync-devel >= 1.3.0-5.6.1
  • libcorosync4 >= 1.3.0-5.6.1
  • libdlm >= 3.00.01-0.10.6
  • libdlm-devel >= 3.00.01-0.10.6
  • libdlm3 >= 3.00.01-0.10.6
  • libglue-devel >= 1.0.7-6.6.3
  • libglue2 >= 1.0.7-6.6.3
  • libopenais-devel >= 1.1.4-5.4.3
  • libopenais3 >= 1.1.4-5.4.3
  • libpacemaker-devel >= 1.1.5-5.5.5
  • libpacemaker3 >= 1.1.5-5.5.5
  • ocfs2-kmp-default >= 1.4_2.6.32.29_0.3-4.15.3
  • ocfs2-kmp-ppc64 >= 1.4_2.6.32.29_0.3-4.15.3
  • ocfs2-tools >= 1.4.3-0.16.7
  • ocfs2-tools-devel >= 1.4.3-0.16.7
  • ocfs2-tools-o2cb >= 1.4.3-0.16.7
  • ocfs2console >= 1.4.3-0.16.7
  • openais >= 1.1.4-5.4.3
  • pacemaker >= 1.1.5-5.5.5
  • pacemaker-mgmt >= 2.0.0-0.5.5
  • pacemaker-mgmt-client >= 2.0.0-0.5.5
  • pacemaker-mgmt-devel >= 2.0.0-0.5.5
  • release-notes-hae >= 10.2.0.3-9.19.2
  • resource-agents >= 1.0.3-0.10.1
sle11-sp1-hae.s390x
sle11-sp1-hae.ia64
sle11-sp1-hae.ppc
sle11-sp1-hae.x86-64
sle11-sp1-hae.x86
SAT Patch Nr: 4124
SUSE Linux Enterprise High Availability Extension 11 SP1
  • cluster-glue >= 1.0.7-6.6.3
  • corosync >= 1.3.0-5.6.1
  • hawk >= 0.3.6-1.3.6
  • ldirectord >= 1.0.3-0.10.1
  • libcorosync-devel >= 1.3.0-5.6.1
  • libcorosync4 >= 1.3.0-5.6.1
  • libdlm >= 3.00.01-0.10.6
  • libdlm-devel >= 3.00.01-0.10.6
  • libdlm3 >= 3.00.01-0.10.6
  • libglue-devel >= 1.0.7-6.6.3
  • libglue2 >= 1.0.7-6.6.3
  • libopenais-devel >= 1.1.4-5.4.3
  • libopenais3 >= 1.1.4-5.4.3
  • libpacemaker-devel >= 1.1.5-5.5.5
  • libpacemaker3 >= 1.1.5-5.5.5
  • ocfs2-kmp-default >= 1.4_2.6.32.29_0.3-4.15.3
  • ocfs2-kmp-xen >= 1.4_2.6.32.29_0.3-4.15.3
  • ocfs2-tools >= 1.4.3-0.16.7
  • ocfs2-tools-devel >= 1.4.3-0.16.7
  • ocfs2-tools-o2cb >= 1.4.3-0.16.7
  • ocfs2console >= 1.4.3-0.16.7
  • openais >= 1.1.4-5.4.3
  • pacemaker >= 1.1.5-5.5.5
  • pacemaker-mgmt >= 2.0.0-0.5.5
  • pacemaker-mgmt-client >= 2.0.0-0.5.5
  • pacemaker-mgmt-devel >= 2.0.0-0.5.5
  • release-notes-hae >= 10.2.0.3-9.19.2
  • resource-agents >= 1.0.3-0.10.1
sle11-sp1-hae.s390x
sle11-sp1-hae.ia64
sle11-sp1-hae.ppc
sle11-sp1-hae.x86-64
sle11-sp1-hae.x86
SAT Patch Nr: 4124


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability Extension 11 SP1 cluster-glue Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 cluster-glue Released