Upstream information

CVE-2011-0419 at MITRE

Description

Stack consumption vulnerability in the fnmatch implementation in apr_fnmatch.c in the Apache Portable Runtime (APR) library before 1.4.3 and the Apache HTTP Server before 2.2.18, and in fnmatch.c in libc in NetBSD 5.1, OpenBSD 4.8, FreeBSD, Apple Mac OS X 10.6, Oracle Solaris 10, and Android, allows context-dependent attackers to cause a denial of service (CPU and memory consumption) via *? sequences in the first argument, as demonstrated by attacks against mod_autoindex in httpd.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 693778 [RESOLVED / FIXED], 700212 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libapr1 >= 1.5.1-4.5.1
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • apr-devel >= 1.6.3-1.3
  • libapr1 >= 1.6.3-1.3
SUSE Linux Enterprise Server 11 SP1
  • libapr-util1 >= 1.3.4-12.22.21.2
  • libapr-util1-32bit >= 1.3.4-12.22.21.1
  • libapr1 >= 1.3.3-11.18.17.1
  • libapr1-32bit >= 1.3.3-11.18.17.1
Patchnames:
slessp1-libapr-util1
SUSE Linux Enterprise Server 11 SP2
  • libapr1 >= 1.3.3-11.18.17.1
  • libapr1-32bit >= 1.3.3-11.18.17.1
SUSE Linux Enterprise Server 11 SP3
  • libapr1 >= 1.3.3-11.18.19.1
  • libapr1-32bit >= 1.3.3-11.18.19.1
SUSE Linux Enterprise Server 11 SP4
  • libapr1 >= 1.3.3-11.18.19.8
  • libapr1-32bit >= 1.3.3-11.18.19.8
SUSE Linux Enterprise Server 12 SP4
  • libapr1 >= 1.5.1-4.3.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
  • libapr1 >= 1.5.1-2.7
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libapr1 >= 1.5.1-2.3
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libapr1 >= 1.3.3-11.18.19.8
  • libapr1-devel >= 1.3.3-11.18.19.8
  • libapr1-devel-32bit >= 1.3.3-11.18.19.8
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libapr1 >= 1.5.1-4.3.1
  • libapr1-devel >= 1.5.1-4.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libapr1 >= 1.5.1-4.5.1
  • libapr1-devel >= 1.5.1-4.5.1
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libapr1 >= 1.5.1-2.7
  • libapr1-devel >= 1.5.1-2.7
openSUSE 11.4
  • apache2 >= 2.2.17-4.5.1
  • apache2-debuginfo >= 2.2.17-4.5.1
  • apache2-debugsource >= 2.2.17-4.5.1
  • apache2-devel >= 2.2.17-4.5.1
  • apache2-doc >= 2.2.17-4.5.1
  • apache2-example-certificates >= 2.2.17-4.5.1
  • apache2-example-pages >= 2.2.17-4.5.1
  • apache2-itk >= 2.2.17-4.5.1
  • apache2-itk-debuginfo >= 2.2.17-4.5.1
  • apache2-prefork >= 2.2.17-4.5.1
  • apache2-prefork-debuginfo >= 2.2.17-4.5.1
  • apache2-utils >= 2.2.17-4.5.1
  • apache2-utils-debuginfo >= 2.2.17-4.5.1
  • apache2-worker >= 2.2.17-4.5.1
  • apache2-worker-debuginfo >= 2.2.17-4.5.1
  • libapr-util1 >= 1.3.9-10.11.1
  • libapr-util1-dbd-mysql >= 1.3.9-10.11.1
  • libapr-util1-dbd-mysql-debuginfo >= 1.3.9-10.11.1
  • libapr-util1-dbd-pgsql >= 1.3.9-10.11.1
  • libapr-util1-dbd-pgsql-debuginfo >= 1.3.9-10.11.1
  • libapr-util1-dbd-sqlite3 >= 1.3.9-10.11.1
  • libapr-util1-dbd-sqlite3-debuginfo >= 1.3.9-10.11.1
  • libapr-util1-debuginfo >= 1.3.9-10.11.1
  • libapr-util1-debugsource >= 1.3.9-10.11.1
  • libapr-util1-devel >= 1.3.9-10.11.1
  • libapr1 >= 1.4.2-4.5.1
  • libapr1-debuginfo >= 1.4.2-4.5.1
  • libapr1-debugsource >= 1.4.2-4.5.1
  • libapr1-devel >= 1.4.2-4.5.1
Patchnames:
apache2
openSUSE Leap 15.0
  • libapr1 >= 1.6.3-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libapr1
openSUSE Leap 42.1
  • libapr1 >= 1.5.1-5.1
  • libapr1-devel >= 1.5.1-5.1
Patchnames:
openSUSE Leap 42.1 GA libapr1
openSUSE Leap 42.2
  • libapr1 >= 1.5.1-6.6
  • libapr1-devel >= 1.5.1-6.6
Patchnames:
openSUSE Leap 42.2 GA libapr1
openSUSE Leap 42.3
  • libapr1 >= 1.5.1-8.3
  • libapr1-devel >= 1.5.1-8.3
Patchnames:
openSUSE Leap 42.3 GA libapr1
openSUSE Tumbleweed
  • libapr1 >= 1.5.2-3.4
  • libapr1-devel >= 1.5.2-3.4
Patchnames:
openSUSE Tumbleweed GA libapr1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 libapr1 Released
SLED-10-SP4 libapr1 Released
SLES-10-SP3 libapr1 Released
SLES-10-SP4 libapr1 Released
SLES_LTSS-10-SP4 libapr1 Released
SUSE Linux Enterprise Server 11 SP1 libapr1 Released
SUSE Linux Enterprise Server 11 SP1 LTSS libapr1 Released
SUSE Linux Enterprise Server for SAP Business All-in-One libapr1 Released
SUSE Linux Enterprise Software Development Kit 11 SP1 libapr1 Released
SUSE Studio Onsite libapr1 Released